aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-04-28 02:30:32 +0800
committerak <ak@FreeBSD.org>2012-04-28 02:30:32 +0800
commit0b39938871d36a5d667110de3d49ebe6e5fdc376 (patch)
treefb5d1480c4f3c306e8bd4af5b5934a12f2588837 /games
parent9af299ae0bf42c259b2a7e90f54523cb6e687ac5 (diff)
downloadfreebsd-ports-gnome-0b39938871d36a5d667110de3d49ebe6e5fdc376.tar.gz
freebsd-ports-gnome-0b39938871d36a5d667110de3d49ebe6e5fdc376.tar.zst
freebsd-ports-gnome-0b39938871d36a5d667110de3d49ebe6e5fdc376.zip
SDL Jewels is a tile-matching 8x8 puzzle game
PR: ports/167304 Submitted by: nemysis <nemysis@gmx.ch> Approved by: eadler (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile3
-rw-r--r--games/sdl_jewels/Makefile50
-rw-r--r--games/sdl_jewels/distinfo2
-rw-r--r--games/sdl_jewels/files/patch-Makefile11
-rw-r--r--games/sdl_jewels/pkg-descr22
5 files changed, 87 insertions, 1 deletions
diff --git a/games/Makefile b/games/Makefile
index 7dfde9848889..a7b2c1fa0e11 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -784,10 +784,11 @@
SUBDIR += sdb
SUBDIR += sdl-ball
SUBDIR += sdlCC
+ SUBDIR += sdl_jewels
+ SUBDIR += sdl_scavenger
SUBDIR += sdlquake2
SUBDIR += sdlroids
SUBDIR += sdlsand
- SUBDIR += sdl_scavenger
SUBDIR += sea-defender
SUBDIR += seabattle
SUBDIR += seahaven
diff --git a/games/sdl_jewels/Makefile b/games/sdl_jewels/Makefile
new file mode 100644
index 000000000000..1dc77f34b655
--- /dev/null
+++ b/games/sdl_jewels/Makefile
@@ -0,0 +1,50 @@
+# New Ports collection makefile for: SDL_jewels
+# Date created: 2012-04-25
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_jewels
+PORTVERSION= 1.1.1
+CATEGORIES= games
+MASTER_SITES= http://www.linuxmotors.com/gljewel/downloads/
+DISTNAME= ${PORTNAME:S/sdl/SDL/}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= SDL Jewels is a tile-matching 8x8 puzzle game
+
+LICENSE= GPLv2
+
+USE_SDL= sdl image mixer
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/sdljewels
+
+PORTDATA= *
+PORTDOCS= ChangeLog README
+
+ALL_TARGET=
+
+do-install:
+# Scripts
+ @${PRINTF} "#!/bin/sh\n\ncd ${DATADIR} &&\
+ ./gljewel\n" > ${WRKDIR}/sdljewels.sh
+ @${INSTALL_SCRIPT} ${WRKDIR}/sdljewels.sh ${PREFIX}/bin/sdljewels
+# Executable
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/gljewel ${DATADIR}
+# Data
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR})
+
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/sdl_jewels/distinfo b/games/sdl_jewels/distinfo
new file mode 100644
index 000000000000..bb795fa792bd
--- /dev/null
+++ b/games/sdl_jewels/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SDL_jewels-1.1.1.tgz) = c9a40b7e18fabb03e4065e656bc2c30f595103bf20dc74a10847c3f3aa138ee7
+SIZE (SDL_jewels-1.1.1.tgz) = 195366
diff --git a/games/sdl_jewels/files/patch-Makefile b/games/sdl_jewels/files/patch-Makefile
new file mode 100644
index 000000000000..a696152b674b
--- /dev/null
+++ b/games/sdl_jewels/files/patch-Makefile
@@ -0,0 +1,11 @@
+Index: Makefile
+@@ -1,7 +1,7 @@
+ EXE = gljewel
+
+-CFLAGS = -O2 -Wall $(shell sdl-config --cflags)
+-LDFLAGS = $(shell sdl-config --libs) -lGL -lm
++CFLAGS += $(shell sdl-config --cflags)
++LDFLAGS += $(shell sdl-config --libs) -lGL -lm
+
+ OBJS = $(EXE).o matrix.o sound.o
+
diff --git a/games/sdl_jewels/pkg-descr b/games/sdl_jewels/pkg-descr
new file mode 100644
index 000000000000..b528b25b1b18
--- /dev/null
+++ b/games/sdl_jewels/pkg-descr
@@ -0,0 +1,22 @@
+The game is very simple. There is an 8x8 array of jewels of 7 types. You
+need to get 3 or more in a row horizontally or vertically in order to
+score points. You can swap any two jewels that are next to each other
+up and down or left and right. The mechanic is to click the mouse on the
+first one, then drag in the direction to switch with. Then let up on the
+mouse button, but this last isn't so critical.
+
+Jewels can only be swapped if after the swap there is at least one 3 or more
+in a row set created. Otherwise the jewels return to their original position.
+
+There is a clock shown on the left. When it counts down to 0 the game is over.
+You will probably be able to enter your name into the high score table.
+Hit enter when done.
+
+Hit F1 or spacebar to start a new game, or ESC to exit.
+
+This game makes use of OpenGL. Without an OpenGL implementation it won't work.
+If you only have software rendering you can still play but the frame rate
+will be lower. The GLX module must be present as well.
+
+
+WWW: http://www.linuxmotors.com/gljewel/