aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-21 01:49:04 +0800
committerantoine <antoine@FreeBSD.org>2014-12-21 01:49:04 +0800
commit0c760f97b73fbf24faf8cafe5dac9bf8aff60b1e (patch)
tree5f8fd3f6e73a3f177faf63f2e4a6496008b763f1 /games
parent014233e47a1f8756a7907d2ae7817ac1854e02c2 (diff)
downloadfreebsd-ports-gnome-0c760f97b73fbf24faf8cafe5dac9bf8aff60b1e.tar.gz
freebsd-ports-gnome-0c760f97b73fbf24faf8cafe5dac9bf8aff60b1e.tar.zst
freebsd-ports-gnome-0c760f97b73fbf24faf8cafe5dac9bf8aff60b1e.zip
- Use GH_COMMIT
- Convert to USES=python
Diffstat (limited to 'games')
-rw-r--r--games/craft/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/games/craft/Makefile b/games/craft/Makefile
index dcc62e8a7e8f..7c8e8f7bb188 100644
--- a/games/craft/Makefile
+++ b/games/craft/Makefile
@@ -16,19 +16,18 @@ USE_GITHUB= yes
GH_ACCOUNT= daniloegea
GH_PROJECT= Craft
GH_TAGNAME= v1.0fbsd
+GH_COMMIT= fdf801f
OPTIONS_DEFINE= SERVER
SERVER_DESC= Install the craft server
OPTIONS_DEFAULT= SERVER
OPTIONS_SUB= yes
-WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-fdf801f
-
USES= cmake compiler:c11
USE_XORG= x11 xi xrandr
USE_GL= gl glu
-SERVER_USE= PYTHON=yes
+SERVER_USES= python
SERVER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.2:${PORTSDIR}/www/py-requests \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3
SERVER_CMAKE_ON= -DSERVER:BOOL=ON