aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-01-21 01:47:16 +0800
committerjbeich <jbeich@FreeBSD.org>2018-01-21 01:47:16 +0800
commit117f97cfccc18f6932d74bf470d104f71bb85d97 (patch)
tree98844d84cf672c225c0fdf68543188603e9a5b8f /games
parentd06a408baff97e37e8040c65e70192bb09c5380a (diff)
downloadfreebsd-ports-gnome-117f97cfccc18f6932d74bf470d104f71bb85d97.tar.gz
freebsd-ports-gnome-117f97cfccc18f6932d74bf470d104f71bb85d97.tar.zst
freebsd-ports-gnome-117f97cfccc18f6932d74bf470d104f71bb85d97.zip
games/bombherman: unbreak build with Clang 6 (C++14 by default)
display/display.cpp:371:17: error: non-constant-expression cannot be narrowed from type 'Uint16' (aka 'unsigned short') to 'Sint16' (aka 'short') in initializer list [-Wc++11-narrowing] SDL_Rect r = { x, y, w, h }; ^ display/display.cpp:371:17: note: insert an explicit cast to silence this issue SDL_Rect r = { x, y, w, h }; ^ static_cast<Sint16>( ) display/display.cpp:391:48: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal] TTF_Font * fontTitle = TTF_OpenFont(DATADIR"/"FONT_FILE, (height / fSize)); ^ display/display.cpp:560:5: error: non-constant-expression cannot be narrowed from type 'unsigned int' to 'Sint16' (aka 'short') in initializer list [-Wc++11-narrowing] ( ( dh.w - sSize ) / dp.w ) + ( i * dh.x ), ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ display/display.cpp:583:6: error: non-constant-expression cannot be narrowed from type 'int' to 'Uint16' (aka 'unsigned short') in initializer list [-Wc++11-narrowing] wText, ^~~~~ [...] Reported by: pkg-fallout
Diffstat (limited to 'games')
-rw-r--r--games/bombherman/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/bombherman/Makefile b/games/bombherman/Makefile
index d6ddb0312c33..6845ccae24b7 100644
--- a/games/bombherman/Makefile
+++ b/games/bombherman/Makefile
@@ -23,6 +23,7 @@ GH_PROJECT= Bomb-her-man
GH_TAGNAME= 8f5aa22
USES= autoreconf gmake pkgconfig
+USE_CXXSTD= gnu++98
USE_SDL= sdl image mixer ttf
USE_GNOME= cairo intltool librsvg2
GNU_CONFIGURE= yes