aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordeischen <deischen@FreeBSD.org>2013-07-13 01:30:35 +0800
committerdeischen <deischen@FreeBSD.org>2013-07-13 01:30:35 +0800
commit1d8b1b0f9ebdc28a4c3111a8315b8d66cb8dc1f8 (patch)
tree429048202268f10fa92a0c3bca99d8125b4a7547 /games
parent4380e1cd3e69cee34d43649a347c85f0098c27ac (diff)
downloadfreebsd-ports-gnome-1d8b1b0f9ebdc28a4c3111a8315b8d66cb8dc1f8.tar.gz
freebsd-ports-gnome-1d8b1b0f9ebdc28a4c3111a8315b8d66cb8dc1f8.tar.zst
freebsd-ports-gnome-1d8b1b0f9ebdc28a4c3111a8315b8d66cb8dc1f8.zip
From the maintainer:
- Shorten header - Trim dependency for graphics/radius-engine - Trim PLIST_FILES and PLIST_DIRS PR: 179923 Submitted by: nemysis at gmx dot ch
Diffstat (limited to 'games')
-rw-r--r--games/cretan-hubris/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/games/cretan-hubris/Makefile b/games/cretan-hubris/Makefile
index f0a2023d8e0a..6ec0ef493868 100644
--- a/games/cretan-hubris/Makefile
+++ b/games/cretan-hubris/Makefile
@@ -1,9 +1,5 @@
-# New Ports collection makefile for: Cretan Hubris
-# Date created: 2012-05-18
-# Whom: nemysis@gmx.ch
-#
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
-#
PORTNAME= cretan-hubris
PORTVERSION= 0.2
@@ -21,23 +17,24 @@ LICENSE_FILE= ${WRKSRC}/License.txt
LICENSE_FILE_CCbyNCSA3=${WRKSRC}/License.txt
LICENSE_PERMS_CCbyNCSA3=dist-mirror pkg-mirror auto-accept
-BUILD_DEPENDS= ${LOCALBASE}/include/radius.h:${PORTSDIR}/graphics/radius-engine
+BUILD_DEPENDS= ${LOCALBASE}/lib/libradius-engine.a:${PORTSDIR}/graphics/radius-engine
LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua \
png15:${PORTSDIR}/graphics/png \
physfs.1:${PORTSDIR}/devel/physfs
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
-GNU_CONFIGURE= yes
-ALL_TARGET= ${PORTNAME}
+USES= pkgconfig
USE_SDL= sdl sound
USE_GL= glu
+GNU_CONFIGURE= yes
+ALL_TARGET= ${PORTNAME}
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/${PORTNAME} \
share/applications/${PORTNAME}.desktop \
- share/pixmaps/${PORTNAME}.png
+ share/pixmaps/${PORTNAME}.png \
+ %%DATADIR%%/${PORTNAME}.zip
+PLIST_DIRS= %%DATADIR%%
PLIST_DIRSTRY= share/applications
-PORTDATA= *
-
.include <bsd.port.mk>