aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-12-10 10:39:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-12-10 10:39:57 +0800
commit257d09bca843f9a53854bcc98def1a63b8942aa0 (patch)
treed0757801efcaa637d8dccdc898fa5ae8561d1c4b /games
parent3f358f29eb0341e0238fa546b50656c3d64931a9 (diff)
downloadfreebsd-ports-gnome-257d09bca843f9a53854bcc98def1a63b8942aa0.tar.gz
freebsd-ports-gnome-257d09bca843f9a53854bcc98def1a63b8942aa0.tar.zst
freebsd-ports-gnome-257d09bca843f9a53854bcc98def1a63b8942aa0.zip
- Support staging
- Use new LIB_DEPENDS syntax - Add LICENSE - Fix build on 10.x
Diffstat (limited to 'games')
-rw-r--r--games/lander/Makefile27
-rw-r--r--games/lander/files/patch-src-Platform.hpp12
-rw-r--r--games/lander/pkg-plist49
3 files changed, 23 insertions, 65 deletions
diff --git a/games/lander/Makefile b/games/lander/Makefile
index 422e5d19ed99..3ef72c165160 100644
--- a/games/lander/Makefile
+++ b/games/lander/Makefile
@@ -11,21 +11,23 @@ MASTER_SITES= http://www.nickg.me.uk/files/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Lunar Lander clone
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- boost_filesystem:${PORTSDIR}/devel/boost-libs
+LICENSE= GPLv3
+
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
GNU_CONFIGURE= yes
USES= gettext pkgconfig
USE_SDL= sdl image mixer
USE_GL= gl glu
-USE_GCC= 4.2+
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-boost="${LOCALBASE}" \
- --with-boost-filesystem=boost_filesystem
+ --with-boost-filesystem=boost_filesystem \
+ --disable-silent-rules
+LDFLAGS= -L${LOCALBASE}/lib
PORTDOCS= *
+PORTDATA= *
DESKTOP_ENTRIES="Lunar Lander" \
"Lunar Lander clone" \
@@ -34,17 +36,10 @@ DESKTOP_ENTRIES="Lunar Lander" \
"Game;ArcadeGame;" \
false
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e '/LIBS=/ s|-lSDL_|`${SDL_CONFIG} --libs` &|' \
- ${WRKSRC}/configure
+OPTIONS_DEFINE= DOCS
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/games/lander/files/patch-src-Platform.hpp b/games/lander/files/patch-src-Platform.hpp
new file mode 100644
index 000000000000..5116a331f87a
--- /dev/null
+++ b/games/lander/files/patch-src-Platform.hpp
@@ -0,0 +1,12 @@
+--- src/Platform.hpp.orig 2011-05-02 11:39:00.000000000 +0400
++++ src/Platform.hpp 2013-12-10 06:09:21.766657123 +0400
+@@ -127,7 +127,9 @@
+ #include <string>
+
+ using namespace std;
++#ifndef _LIBCPP_VERSION
+ using namespace std::tr1;
++#endif
+
+ void RecreateScreens();
+ string LocateResource(const string& file);
diff --git a/games/lander/pkg-plist b/games/lander/pkg-plist
index 8c1df806faf8..8c45afe46b2d 100644
--- a/games/lander/pkg-plist
+++ b/games/lander/pkg-plist
@@ -1,53 +1,4 @@
bin/lander
-%%DATADIR%%/Default_Font.ttf
-%%DATADIR%%/images/arrowblue.png
-%%DATADIR%%/images/arrowgreen.png
-%%DATADIR%%/images/arrowpink.png
-%%DATADIR%%/images/arrowred.png
-%%DATADIR%%/images/arrowyellow.png
-%%DATADIR%%/images/dirt_surface.png
-%%DATADIR%%/images/dirt_surface2.png
-%%DATADIR%%/images/exit_option.png
-%%DATADIR%%/images/fuelbar.png
-%%DATADIR%%/images/fuelmeter.png
-%%DATADIR%%/images/gameover.png
-%%DATADIR%%/images/gateway.png
-%%DATADIR%%/images/hscore.png
-%%DATADIR%%/images/keyblue.png
-%%DATADIR%%/images/keygreen.png
-%%DATADIR%%/images/keypink.png
-%%DATADIR%%/images/keyred.png
-%%DATADIR%%/images/keyyellow.png
-%%DATADIR%%/images/landingpad.png
-%%DATADIR%%/images/landingpadred.png
-%%DATADIR%%/images/levelcomp.png
-%%DATADIR%%/images/mine.png
-%%DATADIR%%/images/missile.png
-%%DATADIR%%/images/options_option.png
-%%DATADIR%%/images/particle.png
-%%DATADIR%%/images/red_rock_surface.png
-%%DATADIR%%/images/red_rock_surface2.png
-%%DATADIR%%/images/rock_surface.png
-%%DATADIR%%/images/rock_surface2.png
-%%DATADIR%%/images/score_option.png
-%%DATADIR%%/images/ship.png
-%%DATADIR%%/images/shipsmall.png
-%%DATADIR%%/images/snow_surface.png
-%%DATADIR%%/images/snow_surface2.png
-%%DATADIR%%/images/speedmeter.png
-%%DATADIR%%/images/star.png
-%%DATADIR%%/images/start_option.png
-%%DATADIR%%/images/title.png
-%%DATADIR%%/sounds/bleep.wav
-%%DATADIR%%/sounds/boing1.wav
-%%DATADIR%%/sounds/bomb_explosion.wav
-%%DATADIR%%/sounds/collect.wav
-%%DATADIR%%/sounds/firework_1.wav
-%%DATADIR%%/sounds/missile.wav
-%%DATADIR%%/sounds/select.wav
share/locale/en_GB/LC_MESSAGES/lander.mo
share/locale/nl/LC_MESSAGES/lander.mo
share/locale/sv/LC_MESSAGES/lander.mo
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%