aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-05-25 18:07:53 +0800
committerarved <arved@FreeBSD.org>2004-05-25 18:07:53 +0800
commit2707f5fc11c84cc76c1c4dc8e30e2c79fa979ab1 (patch)
tree32de7abecfebeb7995562c568ebc21bb629bf51a /games
parentf7b35151752591fb62ef6a43a0dae0ae2ea0a1e9 (diff)
downloadfreebsd-ports-gnome-2707f5fc11c84cc76c1c4dc8e30e2c79fa979ab1.tar.gz
freebsd-ports-gnome-2707f5fc11c84cc76c1c4dc8e30e2c79fa979ab1.tar.zst
freebsd-ports-gnome-2707f5fc11c84cc76c1c4dc8e30e2c79fa979ab1.zip
Respect PTHREAD_LIBS.
Fix a buildproblem on STABLE
Diffstat (limited to 'games')
-rw-r--r--games/six/Makefile9
-rw-r--r--games/six/files/patch-sixplayer.cpp10
2 files changed, 16 insertions, 3 deletions
diff --git a/games/six/Makefile b/games/six/Makefile
index 0992982c4a75..b51164a3ff17 100644
--- a/games/six/Makefile
+++ b/games/six/Makefile
@@ -15,7 +15,10 @@ COMMENT= KDE HEX clone
USE_KDELIBS_VER= 3
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS}," ${WRKSRC}/configure
+
+
+.include <bsd.port.mk>
diff --git a/games/six/files/patch-sixplayer.cpp b/games/six/files/patch-sixplayer.cpp
new file mode 100644
index 000000000000..ac3374e56e95
--- /dev/null
+++ b/games/six/files/patch-sixplayer.cpp
@@ -0,0 +1,10 @@
+--- six/sixplayer.cpp.orig Tue May 25 11:58:16 2004
++++ six/sixplayer.cpp Tue May 25 11:58:33 2004
+@@ -5,6 +5,7 @@
+ #include <cassert>
+ #include <algorithm>
+ #include <cmath>
++#include <ctype.h>
+
+ using std::endl;
+