aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-11-16 09:13:58 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-11-16 09:13:58 +0800
commit2d683f11d956d7d42129fd769adbd97d86695cf0 (patch)
treedce150c3316fd05f3c018221adc4f956283419bc /games
parentbc0e2675073c86f6e2815f785c0fd404a55e086a (diff)
downloadfreebsd-ports-gnome-2d683f11d956d7d42129fd769adbd97d86695cf0.tar.gz
freebsd-ports-gnome-2d683f11d956d7d42129fd769adbd97d86695cf0.tar.zst
freebsd-ports-gnome-2d683f11d956d7d42129fd769adbd97d86695cf0.zip
Pushover is a fun puzzle game originally published by Ocean in 1992.
In this game you control an ant that can walk along platformt that are connected with ladders. On those platforms are dominos that need to fall according to some rules. WWW: http://pushover.sourceforge.net/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/pushover/Makefile34
-rw-r--r--games/pushover/distinfo3
-rw-r--r--games/pushover/pkg-descr6
-rw-r--r--games/pushover/pkg-plist49
5 files changed, 93 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 955d5b7c93c5..3b5b731b067e 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -624,6 +624,7 @@
SUBDIR += primateplunge
SUBDIR += ptkei
SUBDIR += ptools
+ SUBDIR += pushover
SUBDIR += pvpgn
SUBDIR += py-anki
SUBDIR += py-mnemosyne
diff --git a/games/pushover/Makefile b/games/pushover/Makefile
new file mode 100644
index 000000000000..d5eb2afee054
--- /dev/null
+++ b/games/pushover/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pushover
+# Date created: 15 Nov 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pushover
+PORTVERSION= 0.0.1
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Pushover Screenshot Pushover a lot of dominos
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl mixer ttf
+USE_LUA= 5.1
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e '/PKG_CONFIG/ s|lua5.1|lua-5.1|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/levels\/av/ d' ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/install-data-am/ s|install-dist_docDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/pushover/distinfo b/games/pushover/distinfo
new file mode 100644
index 000000000000..1d37ae53d23d
--- /dev/null
+++ b/games/pushover/distinfo
@@ -0,0 +1,3 @@
+MD5 (pushover-0.0.1.tar.gz) = 0b6c7e98fb0238e6a7bf970bab960295
+SHA256 (pushover-0.0.1.tar.gz) = 8dd517311dc9bba1d6cef27f7bd980a7663ab3cf4464b9dce0d795c694a833fb
+SIZE (pushover-0.0.1.tar.gz) = 2234074
diff --git a/games/pushover/pkg-descr b/games/pushover/pkg-descr
new file mode 100644
index 000000000000..d53392de6d41
--- /dev/null
+++ b/games/pushover/pkg-descr
@@ -0,0 +1,6 @@
+Pushover is a fun puzzle game originally published by Ocean in 1992.
+In this game you control an ant that can walk along platformt that
+are connected with ladders. On those platforms are dominos that
+need to fall according to some rules.
+
+WWW: http://pushover.sourceforge.net/
diff --git a/games/pushover/pkg-plist b/games/pushover/pkg-plist
new file mode 100644
index 000000000000..62a90db5c6e6
--- /dev/null
+++ b/games/pushover/pkg-plist
@@ -0,0 +1,49 @@
+bin/pushover
+%%DATADIR%%/data/01_StandardFalling.ogg
+%%DATADIR%%/data/02_StopperHit.ogg
+%%DATADIR%%/data/03_Splitter.ogg
+%%DATADIR%%/data/04_Exploder.ogg
+%%DATADIR%%/data/05_Delay.ogg
+%%DATADIR%%/data/06_TumblerFalling.ogg
+%%DATADIR%%/data/07_BridgerFalling.ogg
+%%DATADIR%%/data/09_TriggerFalling.ogg
+%%DATADIR%%/data/0A_Ascender.ogg
+%%DATADIR%%/data/0B_Falling.ogg
+%%DATADIR%%/data/0C_Landing.ogg
+%%DATADIR%%/data/0D_PickUpDomino.ogg
+%%DATADIR%%/data/0E_Tapping.ogg
+%%DATADIR%%/data/0F_Schrugging.ogg
+%%DATADIR%%/data/10_DoorClose.ogg
+%%DATADIR%%/data/11_DoorOpen.ogg
+%%DATADIR%%/data/13_Victory.ogg
+%%DATADIR%%/data/FreeSans.ttf
+%%DATADIR%%/data/ant.png
+%%DATADIR%%/data/box.png
+%%DATADIR%%/data/carried.png
+%%DATADIR%%/data/dominos.png
+%%DATADIR%%/levels/original.gz
+%%DATADIR%%/themes/aztec.lua
+%%DATADIR%%/themes/aztec.png
+%%DATADIR%%/themes/castle.lua
+%%DATADIR%%/themes/castle.png
+%%DATADIR%%/themes/cavern.lua
+%%DATADIR%%/themes/cavern.png
+%%DATADIR%%/themes/dungeon.lua
+%%DATADIR%%/themes/dungeon.png
+%%DATADIR%%/themes/electro.lua
+%%DATADIR%%/themes/electro.png
+%%DATADIR%%/themes/greek.lua
+%%DATADIR%%/themes/greek.png
+%%DATADIR%%/themes/japanese.lua
+%%DATADIR%%/themes/japanese.png
+%%DATADIR%%/themes/mechanic.lua
+%%DATADIR%%/themes/mechanic.png
+%%DATADIR%%/themes/space.lua
+%%DATADIR%%/themes/space.png
+%%DATADIR%%/themes/tools.lua
+%%DATADIR%%/themes/toxcity.lua
+%%DATADIR%%/themes/toxcity.png
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%