aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-04-23 06:53:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-04-23 06:53:03 +0800
commit3f0e0a8dd2cf560513767fbc9cbccaad7090da18 (patch)
tree5509fcb1a916e0fe75527a68a33a089d5f9faac9 /games
parentadca24cbb385a1d76a5610ed77ae1a8c996fbc76 (diff)
downloadfreebsd-ports-gnome-3f0e0a8dd2cf560513767fbc9cbccaad7090da18.tar.gz
freebsd-ports-gnome-3f0e0a8dd2cf560513767fbc9cbccaad7090da18.tar.zst
freebsd-ports-gnome-3f0e0a8dd2cf560513767fbc9cbccaad7090da18.zip
- Fix build on 64 bit architectures (cast from pointer to int loses precision)
- Drop @dirrm* from plist - Add empty directories to plist Approved by: portmgr blanket
Diffstat (limited to 'games')
-rw-r--r--games/gtkradiant/files/patch-radiant_treemodel.cpp10
-rw-r--r--games/gtkradiant/pkg-plist43
2 files changed, 8 insertions, 45 deletions
diff --git a/games/gtkradiant/files/patch-radiant_treemodel.cpp b/games/gtkradiant/files/patch-radiant_treemodel.cpp
index cfe71cd62be9..8663dfac8ad5 100644
--- a/games/gtkradiant/files/patch-radiant_treemodel.cpp
+++ b/games/gtkradiant/files/patch-radiant_treemodel.cpp
@@ -9,7 +9,7 @@
+ // C++ code, and Clang will assume that comparison below always evaluates
+ // to true, resulting in a segmentation fault. Use a dirty hack to force
+ // Clang to check those "bad" references for null nonetheless.
-+ volatile int n = (int)&node;
++ volatile intptr_t n = (intptr_t)&node;
+
+ if(n != 0)
{
@@ -20,7 +20,7 @@
void node_detach_name_changed_callback(scene::Node& node, const NameCallback& callback)
{
- if(&node != 0)
-+ volatile int n = (int)&node; // see the comment on line 713
++ volatile intptr_t n = (intptr_t)&node; // see the comment on line 713
+
+ if(n != 0)
{
@@ -31,7 +31,7 @@
const char* node_get_name_safe(scene::Node& node)
{
- if(&node == 0)
-+ volatile int n = (int)&node; // see the comment on line 713
++ volatile intptr_t n = (intptr_t)&node; // see the comment on line 713
+
+ if(n == 0)
{
@@ -42,7 +42,7 @@
void node_attach_name_changed_callback(scene::Node& node, const NameCallback& callback)
{
- if(&node != 0)
-+ volatile int n = (int)&node; // see the comment on line 713
++ volatile intptr_t n = (intptr_t)&node; // see the comment on line 713
+
+ if(n != 0)
{
@@ -53,7 +53,7 @@
void node_detach_name_changed_callback(scene::Node& node, const NameCallback& callback)
{
- if(&node != 0)
-+ volatile int n = (int)&node; // see the comment on line 713
++ volatile intptr_t n = (intptr_t)&node; // see the comment on line 713
+
+ if(n != 0)
{
diff --git a/games/gtkradiant/pkg-plist b/games/gtkradiant/pkg-plist
index 1e5ed9e846db..f5fa34adc7a9 100644
--- a/games/gtkradiant/pkg-plist
+++ b/games/gtkradiant/pkg-plist
@@ -177,43 +177,6 @@ bin/gtkradiant
%%DATADIR%%/wolf.game/main/default_shaderlist.txt
%%DATADIR%%/wolf.game/main/wolf_entities.def
%%DATADIR%%/wolf.game/main/wolf_entities.ent
-@dirrm %%DATADIR%%/wolf.game/main
-@dirrm %%DATADIR%%/wolf.game
-@dirrm %%DATADIR%%/stvef.game/baseEF
-@dirrm %%DATADIR%%/stvef.game
-@dirrm %%DATADIR%%/sof2.game/base
-@dirrm %%DATADIR%%/sof2.game
-@dirrm %%DATADIR%%/q4.game/q4base
-@dirrm %%DATADIR%%/q4.game
-@dirrm %%DATADIR%%/q3bp.game/baseq3
-@dirrm %%DATADIR%%/q3bp.game
-@dirrm %%DATADIR%%/q3.game/missionpack
-@dirrm %%DATADIR%%/q3.game/baseq3
-@dirrm %%DATADIR%%/q3.game
-@dirrm %%DATADIR%%/q2.game/baseq2
-@dirrm %%DATADIR%%/q2.game
-@dirrm %%DATADIR%%/q1.game/id1
-@dirrm %%DATADIR%%/q1.game
-@dirrm %%DATADIR%%/modules
-@dirrm %%DATADIR%%/jk2.game/base
-@dirrm %%DATADIR%%/jk2.game
-@dirrm %%DATADIR%%/jabp.game
-@dirrm %%DATADIR%%/ja.game/base
-@dirrm %%DATADIR%%/ja.game
-@dirrm %%DATADIR%%/hlcs.game
-@dirrm %%DATADIR%%/hl.game/valve
-@dirrm %%DATADIR%%/hl.game/cstrike
-@dirrm %%DATADIR%%/hl.game
-@dirrm %%DATADIR%%/heretic2.game/base
-@dirrm %%DATADIR%%/heretic2.game
-@dirrm %%DATADIR%%/heretic2
-@dirrm %%DATADIR%%/gl
-@dirrm %%DATADIR%%/games
-@dirrm %%DATADIR%%/et.game/etmain
-@dirrm %%DATADIR%%/et.game/bitmaps
-@dirrm %%DATADIR%%/et.game
-@dirrm %%DATADIR%%/doom3.game/base
-@dirrm %%DATADIR%%/doom3.game
-@dirrm %%DATADIR%%/bitmaps
-@dirrm %%DATADIR%%/plugins
-@dirrm %%DATADIR%%
+@dir %%DATADIR%%/hlcs.game
+@dir %%DATADIR%%/jabp.game
+@dir %%DATADIR%%/plugins