aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-10-16 14:36:46 +0800
committeredwin <edwin@FreeBSD.org>2005-10-16 14:36:46 +0800
commit5a5e1c54204cf6364723a7dfed682d720258a22e (patch)
tree6892e57c88d5a63c3c8e46187d7af22d342ad615 /games
parent244c8c12e6da77d112c96e94dd051af7559d51f6 (diff)
downloadfreebsd-ports-gnome-5a5e1c54204cf6364723a7dfed682d720258a22e.tar.gz
freebsd-ports-gnome-5a5e1c54204cf6364723a7dfed682d720258a22e.tar.zst
freebsd-ports-gnome-5a5e1c54204cf6364723a7dfed682d720258a22e.zip
/~ Hey little files, where are you not joining the others in the repository? ~/
"cvs add *" with a files directory does't always give the right results. Add left over files from previous commit PR: ports/86185 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Diffstat (limited to 'games')
-rw-r--r--games/quake3-data/Makefile.include44
-rw-r--r--games/quake3-data/distinfo2
-rw-r--r--games/quake3-data/pkg-plist16
3 files changed, 62 insertions, 0 deletions
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
new file mode 100644
index 000000000000..cede8bcd61de
--- /dev/null
+++ b/games/quake3-data/Makefile.include
@@ -0,0 +1,44 @@
+# Makefile for defining variables used by other Quake III Arena related ports.
+
+# Package name prefix.
+
+Q3PKGNAMEPREFIX=quake3-
+
+.if ${PORTNAME} != "quake3"
+PKGNAMEPREFIX?= ${Q3PKGNAMEPREFIX}
+.endif
+
+# Dependency to "games/quake3-data".
+
+.if ${PORTNAME} != "data"
+RUN_DEPENDS+= ${Q3DIR}/baseq3/pak1.pk3:${PORTSDIR}/games/quake3-data
+.endif
+
+# Installation directories.
+
+Q3DIR= ${LOCALBASE}/share/quake3
+
+.if ${PORTNAME} == "data" || ${PORTNAME} == "quake3"
+DATADIR?= ${Q3DIR}
+.else
+DATADIR?= ${Q3DIR}/${PORTNAME}
+.endif
+
+DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+PLIST_SUB+= Q3DIR="${Q3DIR:S/${PREFIX}\///}"
+
+# Convert "dos" text files to "unix".
+
+.if defined(USE_ZIP)
+EXTRACT_BEFORE_ARGS= -aqo
+.else
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
+
+pre-patch:
+# remove trailing ^M
+ @${FIND} -E ${WRKSRC} -type f \
+ -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|url)" \
+ -exec ${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" {} \;
+.endif
diff --git a/games/quake3-data/distinfo b/games/quake3-data/distinfo
new file mode 100644
index 000000000000..d3fe914f3281
--- /dev/null
+++ b/games/quake3-data/distinfo
@@ -0,0 +1,2 @@
+MD5 (linuxq3apoint-1.32b-3.x86.run) = c71fdddccb20e8fc393d846e9c61d685
+SIZE (linuxq3apoint-1.32b-3.x86.run) = 30923961
diff --git a/games/quake3-data/pkg-plist b/games/quake3-data/pkg-plist
new file mode 100644
index 000000000000..126fe66236ad
--- /dev/null
+++ b/games/quake3-data/pkg-plist
@@ -0,0 +1,16 @@
+%%DATADIR%%/baseq3/pak1.pk3
+%%DATADIR%%/baseq3/pak2.pk3
+%%DATADIR%%/baseq3/pak3.pk3
+%%DATADIR%%/baseq3/pak4.pk3
+%%DATADIR%%/baseq3/pak5.pk3
+%%DATADIR%%/baseq3/pak6.pk3
+%%DATADIR%%/baseq3/pak7.pk3
+%%DATADIR%%/baseq3/pak8.pk3
+%%TEAMARENA%%%%DATADIR%%/missionpack/pak1.pk3
+%%TEAMARENA%%%%DATADIR%%/missionpack/pak2.pk3
+%%TEAMARENA%%%%DATADIR%%/missionpack/pak3.pk3
+share/pixmaps/quake3.xpm
+@unexec rmdir %D/share/pixmaps 2>/dev/null || true
+%%TEAMARENA%%@unexec rmdir %D/%%DATADIR%%/missionpack 2>/dev/null || true
+@unexec rmdir %D/%%DATADIR%%/baseq3 2>/dev/null || true
+@unexec rmdir %D/%%DATADIR%% >/dev/null 2>&1 || echo "If you are permanently removing this port, you should remove any configuration files, data files, and mods left in %D/%%DATADIR%%." | fmt