aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2014-10-13 20:33:47 +0800
committermartymac <martymac@FreeBSD.org>2014-10-13 20:33:47 +0800
commit601a0a165c34860115589f3b451ff3fa4a96c8ed (patch)
tree8ec66d466617b7ae89350faa2ac0ebc406ee30f6 /games
parentaeea77955eba89d44a30b123c89322eb18d7d6b5 (diff)
downloadfreebsd-ports-gnome-601a0a165c34860115589f3b451ff3fa4a96c8ed.tar.gz
freebsd-ports-gnome-601a0a165c34860115589f3b451ff3fa4a96c8ed.tar.zst
freebsd-ports-gnome-601a0a165c34860115589f3b451ff3fa4a96c8ed.zip
Remove @dirrm from my ports
Diffstat (limited to 'games')
-rw-r--r--games/flightgear-aircraft/Makefile4
-rw-r--r--games/flightgear-data/Makefile4
-rw-r--r--games/flightgear-mb339-pan/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/games/flightgear-aircraft/Makefile b/games/flightgear-aircraft/Makefile
index 8ab6ae8449b5..30b66fa53ba9 100644
--- a/games/flightgear-aircraft/Makefile
+++ b/games/flightgear-aircraft/Makefile
@@ -80,8 +80,8 @@ pre-install:
| ${SED} -e 's|^|@exec ${MKDIR} %D/share/flightgear/Aircraft/|' >> ${PLIST} && \
${FIND} * -type f | ${SORT} \
| ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
- ${FIND} * -type d | ${SORT} -r \
- | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+ ${FIND} * -type d -empty | ${SORT} -r \
+ | ${SED} -e 's|^|@dir %%DATADIR%%/|' >> ${PLIST}
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/games/flightgear-data/Makefile b/games/flightgear-data/Makefile
index 1cc486cba816..3897ee1cb7a9 100644
--- a/games/flightgear-data/Makefile
+++ b/games/flightgear-data/Makefile
@@ -37,8 +37,8 @@ pre-install:
| ${SED} -e 's|^|@exec ${MKDIR} %D/share/flightgear/|' >> ${PLIST} && \
${FIND} * -type f | ${SORT} \
| ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
- ${FIND} * -type d | ${SORT} -r \
- | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+ ${FIND} * -type d -empty | ${SORT} -r \
+ | ${SED} -e 's|^|@dir %%DATADIR%%/|' >> ${PLIST}
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/games/flightgear-mb339-pan/Makefile b/games/flightgear-mb339-pan/Makefile
index ccd514b71960..c2e9918d9c53 100644
--- a/games/flightgear-mb339-pan/Makefile
+++ b/games/flightgear-mb339-pan/Makefile
@@ -34,8 +34,8 @@ pre-install:
| ${SED} -e 's|^|@exec ${MKDIR} %D/share/flightgear/Aircraft/|' >> ${PLIST} && \
${FIND} * -type f | ${SORT} \
| ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
- ${FIND} * -type d | ${SORT} -r \
- | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+ ${FIND} * -type d -empty | ${SORT} -r \
+ | ${SED} -e 's|^|@dir %%DATADIR%%/|' >> ${PLIST}
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}