aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-12 04:05:15 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-12 04:05:15 +0800
commit61d7faa2341e952b1af2866fbbecc06f6be75dd9 (patch)
tree625a2818ae7bf5a1a9db2503ca5bd4d2c27b5036 /games
parentaa84476fefa8cbcbea8dcc55dafad17d9e3c5542 (diff)
downloadfreebsd-ports-gnome-61d7faa2341e952b1af2866fbbecc06f6be75dd9.tar.gz
freebsd-ports-gnome-61d7faa2341e952b1af2866fbbecc06f6be75dd9.tar.zst
freebsd-ports-gnome-61d7faa2341e952b1af2866fbbecc06f6be75dd9.zip
games/criticalmass: unbreak with gcc6 or later
In file included from Config.cpp:26:0: ./Config.hpp:94:63: error: template argument 3 is invalid hash_map< string, Value*, hash<string>, equal_to<string> > &kvmap); ^ ./Config.hpp:94:63: error: template argument 3 is invalid ./Config.hpp:94:63: error: template argument 3 is invalid ./Config.hpp:94:6: error: 'hash_map' is not a type hash_map< string, Value*, hash<string>, equal_to<string> > &kvmap); ^~~~~~~~ ./Config.hpp:94:14: error: expected ',' or '...' before '<' token hash_map< string, Value*, hash<string>, equal_to<string> > &kvmap); ^ ./Config.hpp:97:63: error: template argument 3 is invalid hash_map< string, Value*, hash<string>, equal_to<string> > &kvmap); ^ [...]
Diffstat (limited to 'games')
-rw-r--r--games/criticalmass/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 99b160b46ccd..c11d4a9f33d3 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -23,6 +23,7 @@ DOS2UNIX_FILES= tinyxml/*.cpp tinyxml/*.h
USE_XORG= x11
USE_GL= gl
USE_SDL= image mixer sdl
+USE_CXXSTD= gnu++98
USE_GCC= any
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-optimize