aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2003-09-01 22:07:24 +0800
committermat <mat@FreeBSD.org>2003-09-01 22:07:24 +0800
commit6659ef77874f06ca1fd2f5d6b35ec73cd05b8ced (patch)
treec694d09e7537f92ab4cf3dd2755be84a19add9e3 /games
parentb1efd52ad2be3dc5c43d0641547181d66cf19b39 (diff)
downloadfreebsd-ports-gnome-6659ef77874f06ca1fd2f5d6b35ec73cd05b8ced.tar.gz
freebsd-ports-gnome-6659ef77874f06ca1fd2f5d6b35ec73cd05b8ced.tar.zst
freebsd-ports-gnome-6659ef77874f06ca1fd2f5d6b35ec73cd05b8ced.zip
Add p5-Games-Bingo-Bot 0.01,
a simple class holding IRC related methods for bingo. PR: 55820 Submitted by: Lars Thegler <lars@thegler.dk>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile35
-rw-r--r--games/p5-Games-Bingo-Bot/distinfo1
-rw-r--r--games/p5-Games-Bingo-Bot/pkg-descr9
-rw-r--r--games/p5-Games-Bingo-Bot/pkg-plist9
5 files changed, 55 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9b92de4648c1..45c734dcbfed 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -266,6 +266,7 @@
SUBDIR += oonsoo
SUBDIR += openglad
SUBDIR += p5-Games-Bingo
+ SUBDIR += p5-Games-Bingo-Bot
SUBDIR += pengpong
SUBDIR += penguin-command
SUBDIR += pentix
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
new file mode 100644
index 000000000000..2ba03e158548
--- /dev/null
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Games-Bingo-Bot
+# Date created: 20. August 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Bingo-Bot
+PORTVERSION= 0.01
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= A simple class holding IRC related methods for bingo
+
+BUILD_DEPENDS= ${SITE_PERL}/Games/Bingo.pm:${PORTSDIR}/games/p5-Games-Bingo
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Games::Bingo::Bot.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing example for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingobot.pl ${EXAMPLESDIR}
+.endif
+
+test:
+ @cd ${WRKSRC}; make test
+
+.include <bsd.port.mk>
diff --git a/games/p5-Games-Bingo-Bot/distinfo b/games/p5-Games-Bingo-Bot/distinfo
new file mode 100644
index 000000000000..8c73de6ffd06
--- /dev/null
+++ b/games/p5-Games-Bingo-Bot/distinfo
@@ -0,0 +1 @@
+MD5 (Games-Bingo-Bot-0.01.tar.gz) = b2de73a6cfde8fd3eab1564bf345cbd2
diff --git a/games/p5-Games-Bingo-Bot/pkg-descr b/games/p5-Games-Bingo-Bot/pkg-descr
new file mode 100644
index 000000000000..782c2dab203a
--- /dev/null
+++ b/games/p5-Games-Bingo-Bot/pkg-descr
@@ -0,0 +1,9 @@
+This module contains all the commands supported by the Games::Bingo::Bot
+IRC bot (see the script in the bin directory). The Games::Bingo::Bot
+class and the script mentioned above is a complete IRC setup for playing
+Bingo, using the Games::Bingo module.
+
+WWW: http://search.cpan.org/dist/Games-Bingo-Bot/
+
+- Lars Thegler
+lars@thegler.dk
diff --git a/games/p5-Games-Bingo-Bot/pkg-plist b/games/p5-Games-Bingo-Bot/pkg-plist
new file mode 100644
index 000000000000..6bb4ee69b7da
--- /dev/null
+++ b/games/p5-Games-Bingo-Bot/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Games/Bingo/Bot.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo/Bot/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/bingobot.pl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo/Bot
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Games/Bingo 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Games 2>/dev/null || true