aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-08-11 00:24:54 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-08-11 00:24:54 +0800
commit6f1e8d24ab6b718f160628fd4638d24d799bb318 (patch)
tree6e6b781b281de386ada099d361ce0867487e6515 /games
parenta7ff004fda15b3ce55591da92d57c6699d308c91 (diff)
downloadfreebsd-ports-gnome-6f1e8d24ab6b718f160628fd4638d24d799bb318.tar.gz
freebsd-ports-gnome-6f1e8d24ab6b718f160628fd4638d24d799bb318.tar.zst
freebsd-ports-gnome-6f1e8d24ab6b718f160628fd4638d24d799bb318.zip
Update to 0.96
PR: 159454 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'games')
-rw-r--r--games/quackle/Makefile46
-rw-r--r--games/quackle/distinfo4
-rw-r--r--games/quackle/files/patch-fixedstring.h10
-rw-r--r--games/quackle/pkg-descr2
-rw-r--r--games/quackle/pkg-plist65
5 files changed, 83 insertions, 44 deletions
diff --git a/games/quackle/Makefile b/games/quackle/Makefile
index 2bf77a17daf1..4ece6c4d912f 100644
--- a/games/quackle/Makefile
+++ b/games/quackle/Makefile
@@ -6,30 +6,50 @@
#
PORTNAME= quackle
-PORTVERSION= 0.95
-PORTREVISION= 3
+PORTVERSION= 0.96
+DISTVERSIONSUFFIX= -source
CATEGORIES= games
-MASTER_SITES= http://web.mit.edu/jasonkb/www/quackle/downloads/${PORTNAME}-${PORTVERSION}/
-DISTFILES= ${PORTNAME}-${PORTVERSION}-source.tar.gz
+MASTER_SITES= http://people.csail.mit.edu/jasonkb/quackle/downloads/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A scrabble-like word game utilizing qt4
-USE_SCONS= yes
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+BUILD_WRKSRC= ${WRKSRC}/quacker
+
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build gui
+QT_COMPONENTS= corelib gui moc_build qmake_build
USE_GMAKE= yes
-QMAKE_ARGS= -unix -spec ${QMAKESPEC}
+MAKE_JOBS_SAFE= yes
+
+post-extract:
+ @${FIND} ${WRKSRC} \( -name "*.[ao]" -or -name "moc_*" \) -delete
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/debug/s|^CONFIG|#CONFIG| ; \
+ /release/s|^#CONFIG|CONFIG|' ${BUILD_WRKSRC}/quacker.pro
+ @${REINPLACE_CMD} -e \
+ '/QFile::exists/s|("data")|("${DATADIR}")| ; \
+ /setDataDirectory/s|("data")|("${DATADIR}")|' ${BUILD_WRKSRC}/settings.cpp
-pre-patch:
- @${REINPLACE_CMD} -e 's|if (QFile::exists("data"))|if (QFile::exists("${DATADIR}"))|' ${WRKSRC}/quacker/settings.cpp
- @${REINPLACE_CMD} -e 's|QUACKLE_DATAMANAGER->setDataDirectory("data");|QUACKLE_DATAMANAGER->setDataDirectory("${DATADIR}");|' ${WRKSRC}/quacker/settings.cpp
+do-configure:
+.for dir in . quackleio quacker
+ @(cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
+.endfor
-post-build:
- @(cd ${WRKSRC}/quackleio && ${QMAKE} ${QMAKE_ARGS} -o Makefile quackleio.pro && ${SETENV} ${MAKE_ENV} ${GMAKE} && cd ${WRKSRC}/quacker && ${QMAKE} ${QMAKE_ARGS} -o Makefile quacker.pro && ${SETENV} ${MAKE_ENV} ${GMAKE})
+pre-build:
+.for dir in . quackleio
+ @(cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/quacker/quacker ${PREFIX}/bin/quackle
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/quacker ${PREFIX}/bin/quackle
@(cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR})
.include <bsd.port.mk>
diff --git a/games/quackle/distinfo b/games/quackle/distinfo
index ad987d192fd5..0f189fa006c6 100644
--- a/games/quackle/distinfo
+++ b/games/quackle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (quackle-0.95-source.tar.gz) = 21544c41f465818f7c33a514eae3d725108b2992532b6db6ded269aa69de3e4c
-SIZE (quackle-0.95-source.tar.gz) = 49800462
+SHA256 (quackle-0.96-source.tar.gz) = 545a5cf32e5e8391df22a72c63eef3c1fbb991635630ede3b16fb5f4b99b701f
+SIZE (quackle-0.96-source.tar.gz) = 48267335
diff --git a/games/quackle/files/patch-fixedstring.h b/games/quackle/files/patch-fixedstring.h
deleted file mode 100644
index 12c5c5faa76c..000000000000
--- a/games/quackle/files/patch-fixedstring.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- fixedstring.h.orig 2008-04-15 20:02:38.000000000 -0600
-+++ fixedstring.h 2008-04-15 20:02:55.000000000 -0600
-@@ -18,6 +18,7 @@
- * 02110-1301 USA
- */
-
-+#include <cassert>
- #ifndef QUACKLE_FIXEDSTRING_H
- #define QUACKLE_FIXEDSTRING_H
-
diff --git a/games/quackle/pkg-descr b/games/quackle/pkg-descr
index 7202f6074c3f..4ea95aea3f33 100644
--- a/games/quackle/pkg-descr
+++ b/games/quackle/pkg-descr
@@ -5,3 +5,5 @@ You will need to set up a game board with the bonus squares scrabble has.
See http://web.mit.edu/jasonkb/www/quackle/example_report.html for a
reminder of which squares are which, and recreate this board to have
exactly the same rules as Scrabble (TM)
+
+WWW: http://quackle.org/
diff --git a/games/quackle/pkg-plist b/games/quackle/pkg-plist
index 2a0ba3972858..e526e8aef153 100644
--- a/games/quackle/pkg-plist
+++ b/games/quackle/pkg-plist
@@ -3,24 +3,46 @@ bin/quackle
%%DATADIR%%/alphabets/english_super.quackle_alphabet
%%DATADIR%%/alphabets/english_wild.quackle_alphabet
%%DATADIR%%/alphabets/french.quackle_alphabet
+%%DATADIR%%/alphabets/greek.quackle_alphabet
%%DATADIR%%/alphabets/korean.quackle_alphabet
+%%DATADIR%%/alphabets/mandarin.quackle_alphabet
+%%DATADIR%%/alphabets/mandarin.quackle_alphabet~
+%%DATADIR%%/alphabets/pinyin.quackle_alphabet
%%DATADIR%%/alphabets/russian.quackle_alphabet
%%DATADIR%%/alphabets/tuvan.quackle_alphabet
-%%DATADIR%%/lexica/cswfeb07.gaddag
+%%DATADIR%%/alphabets/zhuyin.quackle_alphabet
+%%DATADIR%%/lexica/cswapr07.dawg
+%%DATADIR%%/lexica/cswapr07.gaddag
+%%DATADIR%%/lexica/greek.dawg
%%DATADIR%%/lexica/korean.dawg
-%%DATADIR%%/lexica/ods4.gaddag
-%%DATADIR%%/lexica/russian.dawg
-%%DATADIR%%/lexica/sowpods.gaddag
-%%DATADIR%%/lexica/tuvan.dawg
+%%DATADIR%%/lexica/ods5.dawg
+%%DATADIR%%/lexica/sowpods.dawg
+%%DATADIR%%/lexica/twl06.dawg
%%DATADIR%%/lexica/twl06.gaddag
-%%DATADIR%%/lexica/twl06_wild.dawg
%%DATADIR%%/lexica/twl98.dawg
-%%DATADIR%%/strategy/cswfeb07/superleaves
+%%DATADIR%%/raw_lexica/cswapr07.raw
+%%DATADIR%%/raw_lexica/cswfeb07.raw
+%%DATADIR%%/raw_lexica/faa3.raw
+%%DATADIR%%/raw_lexica/greek.raw
+%%DATADIR%%/raw_lexica/korean.raw
+%%DATADIR%%/raw_lexica/ods4.raw
+%%DATADIR%%/raw_lexica/ods5.raw
+%%DATADIR%%/raw_lexica/sowpods.raw
+%%DATADIR%%/raw_lexica/twl06.raw
+%%DATADIR%%/raw_lexica/twl98.raw
+%%DATADIR%%/strategy/chinese/superleaves
+%%DATADIR%%/strategy/chinese/syn2
+%%DATADIR%%/strategy/chinese/worths
+%%DATADIR%%/strategy/cswapr07/superleaves
+%%DATADIR%%/strategy/greek/superleaves
+%%DATADIR%%/strategy/greek/syn2
+%%DATADIR%%/strategy/greek/worths
%%DATADIR%%/strategy/korean/superleaves
%%DATADIR%%/strategy/korean/syn2
%%DATADIR%%/strategy/korean/worths
-%%DATADIR%%/strategy/ods4/superleaves
-%%DATADIR%%/strategy/ods4/worths
+%%DATADIR%%/strategy/mandarin/superleaves
+%%DATADIR%%/strategy/mandarin/syn2
+%%DATADIR%%/strategy/mandarin/worths
%%DATADIR%%/strategy/russian/superleaves
%%DATADIR%%/strategy/russian/syn2
%%DATADIR%%/strategy/russian/worths
@@ -33,15 +55,20 @@ bin/quackle
%%DATADIR%%/strategy/twl06/vcplace
%%DATADIR%%/strategy/twl06/worths
%%DATADIR%%/strategy/twl98/worths
-@dirrm %%DATADIR%%/alphabets
+@dirrm %%DATADIR%%/strategy/twl98
+@dirrm %%DATADIR%%/strategy/twl06
+@dirrm %%DATADIR%%/strategy/tuvan
+@dirrm %%DATADIR%%/strategy/sowpods
+@dirrm %%DATADIR%%/strategy/russian
+@dirrm %%DATADIR%%/strategy/ods4
+@dirrm %%DATADIR%%/strategy/mandarin
+@dirrm %%DATADIR%%/strategy/korean
+@dirrm %%DATADIR%%/strategy/greek
+@dirrm %%DATADIR%%/strategy/cswfeb07
+@dirrm %%DATADIR%%/strategy/cswapr07
+@dirrm %%DATADIR%%/strategy/chinese
+@dirrm %%DATADIR%%/strategy
+@dirrm %%DATADIR%%/raw_lexica
@dirrm %%DATADIR%%/lexica
-@dirrm %%DATADIR%%/strategy/cswfeb07/
-@dirrm %%DATADIR%%/strategy/korean/
-@dirrm %%DATADIR%%/strategy/ods4/
-@dirrm %%DATADIR%%/strategy/russian/
-@dirrm %%DATADIR%%/strategy/sowpods/
-@dirrm %%DATADIR%%/strategy/tuvan/
-@dirrm %%DATADIR%%/strategy/twl06/
-@dirrm %%DATADIR%%/strategy/twl98/
-@dirrm %%DATADIR%%/strategy/
+@dirrm %%DATADIR%%/alphabets
@dirrm %%DATADIR%%