aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-14 07:23:25 +0800
committerbapt <bapt@FreeBSD.org>2014-07-14 07:23:25 +0800
commit7244029e548a8568a25201a0e345fd4bc5e9ec5b (patch)
tree255b3b2c0cd318aabd72e99ccb876cde204de6b7 /games
parent1fed79fe4ffe7f3c5ecea1df8a93b6926106b4b6 (diff)
downloadfreebsd-ports-gnome-7244029e548a8568a25201a0e345fd4bc5e9ec5b.tar.gz
freebsd-ports-gnome-7244029e548a8568a25201a0e345fd4bc5e9ec5b.tar.zst
freebsd-ports-gnome-7244029e548a8568a25201a0e345fd4bc5e9ec5b.zip
Modernize LIB_DEPENDS
With hat: portmgr
Diffstat (limited to 'games')
-rw-r--r--games/adonthell/Makefile2
-rw-r--r--games/alienarena/Makefile8
-rw-r--r--games/balazar/Makefile2
-rw-r--r--games/balazarbrothers/Makefile2
-rw-r--r--games/criticalmass/Makefile2
-rw-r--r--games/dangerdeep/Makefile4
-rw-r--r--games/eduke32/Makefile4
-rw-r--r--games/foobillard/Makefile2
-rw-r--r--games/frobtads/Makefile4
-rw-r--r--games/gnubg/Makefile6
-rw-r--r--games/imaze/Makefile2
-rw-r--r--games/joequake/Makefile4
-rw-r--r--games/lbreakout2/Makefile2
-rw-r--r--games/mangband/Makefile4
-rw-r--r--games/ninix-aya/Makefile2
-rw-r--r--games/ufoai/Makefile16
-rw-r--r--games/vultures-eye/Makefile2
-rw-r--r--games/xblackjack/Makefile2
-rw-r--r--games/xmine/Makefile2
19 files changed, 36 insertions, 36 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 688f670d24d7..b920cca192db 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -16,7 +16,7 @@ COMMENT= Free role playing game
LICENSE= GPLv2
LICENSE_DISTFILES= ${DISTFILES}
-LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libfreetype.so:${PORTSDIR}/print/freetype2
USE_SDL= mixer ttf sdl
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 01d69813dfb1..d6ebd1cc37a9 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -53,11 +53,11 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MCLIENT}
USES+= openal:soft,alut pkgconfig
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl \
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl \
libfreetype.so:${PORTSDIR}/print/freetype2 \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- vorbis.4:${PORTSDIR}/audio/libvorbis
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
USE_GL= yes
USE_XORG= xxf86dga xxf86vm
.endif
diff --git a/games/balazar/Makefile b/games/balazar/Makefile
index 19a33cac35c8..949248f97796 100644
--- a/games/balazar/Makefile
+++ b/games/balazar/Makefile
@@ -11,7 +11,7 @@ DISTNAME= Balazar-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D adventure and roleplaying game
-LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
+LIB_DEPENDS= libcal3d.so:${PORTSDIR}/graphics/cal3d \
libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= soya_editor:${PORTSDIR}/graphics/py-soya3d \
${PYTHON_SITELIBDIR}/_openal.so:${PORTSDIR}/audio/py-openal \
diff --git a/games/balazarbrothers/Makefile b/games/balazarbrothers/Makefile
index b8ed1b833e75..f23ae89f97d8 100644
--- a/games/balazarbrothers/Makefile
+++ b/games/balazarbrothers/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME:S/b/B/g}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Balazar Brother is a free software 3D puzzle game
-LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
+LIB_DEPENDS= libcal3d.so:${PORTSDIR}/graphics/cal3d \
libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cerealizer/__init__.py:${PORTSDIR}/security/py-cerealizer \
${PYTHON_SITELIBDIR}/soya/__init__.py:${PORTSDIR}/graphics/py-soya3d \
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 858534465a83..1c7fb1aa695d 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -12,7 +12,7 @@ DISTNAME= CriticalMass-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= SDL/OpenGL space shoot\'em up game
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
CONFLICTS= shaaft-[0-9]*
diff --git a/games/dangerdeep/Makefile b/games/dangerdeep/Makefile
index f0c2c11369ec..a803620b00c2 100644
--- a/games/dangerdeep/Makefile
+++ b/games/dangerdeep/Makefile
@@ -12,8 +12,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Open source World War II German submarine simulation
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
-LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
- execinfo.1:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/maps/default.xml:${PORTSDIR}/games/dangerdeep-data
MAKE_ENV= X11BASE=${LOCALBASE}
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index 69e579a2df85..21efd498af6f 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -15,7 +15,7 @@ COMMENT= Duke Nukem 3D Port based on JFDuke and EDuke
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GNU.TXT
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
USES= gmake
USE_CSTD= gnu89
@@ -55,7 +55,7 @@ RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
.endif
post-patch:
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index 85836c5dd08b..e6eda3e25db8 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://foobillard.sunsite.dk/dnl/
MAINTAINER= thomas@bsdunix.ch
COMMENT= Free OpenGL billiards game
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
OPTIONS_DEFINE= SDL NVIDIA_BUMPREF
diff --git a/games/frobtads/Makefile b/games/frobtads/Makefile
index 094abbd8a903..c65c40dbceb7 100644
--- a/games/frobtads/Makefile
+++ b/games/frobtads/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://www.tads.org/${PORTNAME}/ \
MAINTAINER= kaiwang27@gmail.com
COMMENT= TADS interpreter and the compilers for both TADS 2 and 3
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
CONFLICTS= tads-2.*
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index 4f33c76c4c93..95c34b7773d7 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -16,9 +16,9 @@ LICENSE= GPLv3
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
RUN_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- gtkextra-x11-2.0.1:${PORTSDIR}/x11-toolkits/gtkextra2 \
- gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libgtkextra-x11-2.0.so:${PORTSDIR}/x11-toolkits/gtkextra2 \
+ libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
OPTIONS_DEFINE= ESOUND NLS
OPTIONS_DEFAULT=ESOUND NLS
diff --git a/games/imaze/Makefile b/games/imaze/Makefile
index 12c97617e6af..c35d0c1cfeac 100644
--- a/games/imaze/Makefile
+++ b/games/imaze/Makefile
@@ -53,7 +53,7 @@ TOOLKIT= motif
.endif
.if ${PORT_OPTIONS:MXVIEW}
-LIB_DEPENDS+= xview:${PORTSDIR}/x11-toolkits/xview
+LIB_DEPENDS+= libxview.so:${PORTSDIR}/x11-toolkits/xview
TOOLKIT= xview
.endif
diff --git a/games/joequake/Makefile b/games/joequake/Makefile
index c90cb14a1da3..75c1f1ddda06 100644
--- a/games/joequake/Makefile
+++ b/games/joequake/Makefile
@@ -14,7 +14,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Improved NQ engine with ZQuake and FuhQuake graphical effects
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/src
@@ -38,7 +38,7 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MOPENGL}
USE_GL= yes
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
ALL_TARGET+= glx
PLIST_SUB+= GLX=""
.else
diff --git a/games/lbreakout2/Makefile b/games/lbreakout2/Makefile
index 89242dd1b020..ece3d46e6be6 100644
--- a/games/lbreakout2/Makefile
+++ b/games/lbreakout2/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/lgames/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The polished successor to LBreakout
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
USE_SDL= mixer net sdl
USES= gmake
diff --git a/games/mangband/Makefile b/games/mangband/Makefile
index 388461e9e1b2..0da8a4816fd6 100644
--- a/games/mangband/Makefile
+++ b/games/mangband/Makefile
@@ -33,14 +33,14 @@ CONFIGURE_ARGS+= --without-gcu
.endif
.if ${PORT_OPTIONS:MX11}
-LIB_DEPENDS+= X11.6:${PORTSDIR}/x11/libX11
+LIB_DEPENDS+= libX11.so:${PORTSDIR}/x11/libX11
CONFIGURE_ARGS+= --with-x11
.else
CONFIGURE_ARGS+= --without-x11
.endif
.if ${PORT_OPTIONS:MSDL}
-LIB_DEPENDS+= SDL-1.2:${PORTSDIR}/devel/sdl12
+LIB_DEPENDS+= libSDL-1.2.so:${PORTSDIR}/devel/sdl12
CONFIGURE_ARGS+= --with-sdl
.else
CONFIGURE_ARGS+= --without-sdl
diff --git a/games/ninix-aya/Makefile b/games/ninix-aya/Makefile
index 07fe07afee40..076a22da2347 100644
--- a/games/ninix-aya/Makefile
+++ b/games/ninix-aya/Makefile
@@ -15,7 +15,7 @@ COMMENT= Ninix-aya is a compatible with desktop mascot program "Ukagaka"
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
${PYTHON_SITELIBDIR}/chardet/__init__.py:${PORTSDIR}/textproc/py-chardet \
${PYNUMPY} \
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index d89f114b38be..7f2ae60701aa 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -12,14 +12,14 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Strategy game featuring tactical combat
-LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- curl:${PORTSDIR}/ftp/curl \
- execinfo:${PORTSDIR}/devel/libexecinfo \
- theora.0:${PORTSDIR}/multimedia/libtheora \
- xvidcore.4:${PORTSDIR}/multimedia/xvid \
- mxml:${PORTSDIR}/textproc/mxml
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libtheora.so:${PORTSDIR}/multimedia/libtheora \
+ libxvidcore.so:${PORTSDIR}/multimedia/xvid \
+ libmxml.so:${PORTSDIR}/textproc/mxml
BUILD_DEPENDS= ${LOCALBASE}/include/mxml.h:${PORTSDIR}/textproc/mxml
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:${PORTSDIR}/games/ufoai-data
diff --git a/games/vultures-eye/Makefile b/games/vultures-eye/Makefile
index 8141110e357c..678f6808cf77 100644
--- a/games/vultures-eye/Makefile
+++ b/games/vultures-eye/Makefile
@@ -12,7 +12,7 @@ DISTFILES= ${DISTNAME}-full${EXTRACT_SUFX}?format=raw
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical interface for NetHack 3.4.3 forked from Falcon's Eye
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
diff --git a/games/xblackjack/Makefile b/games/xblackjack/Makefile
index 78b3a919d12f..cbf9e2783e03 100644
--- a/games/xblackjack/Makefile
+++ b/games/xblackjack/Makefile
@@ -12,7 +12,7 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= X11/Motif blackjack game
-LIB_DEPENDS= Xm:${PORTSDIR}/x11-toolkits/lesstif
+LIB_DEPENDS= libXm.so:${PORTSDIR}/x11-toolkits/lesstif
USES= imake
USE_XORG= x11 xext xp xt xmu
diff --git a/games/xmine/Makefile b/games/xmine/Makefile
index bf58db82817a..85bec0f5a896 100644
--- a/games/xmine/Makefile
+++ b/games/xmine/Makefile
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-Xaw
MAINTAINER= joerg@FreeBSD.org
COMMENT= The `Athena' port of the xminesweeper game
-LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
USES= imake
USE_XORG= x11 xaw xext xmu xt xpm sm ice