aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-07-30 15:12:06 +0800
committertobik <tobik@FreeBSD.org>2018-07-30 15:12:06 +0800
commit937c368c984e159a76e250b3c8b4dbb8c4d80b06 (patch)
treef52f5b4f2f41518899ee0a99d3abf0051983c54e /games
parent6bb243c90ff63ebe90746acc56545e01e6b97155 (diff)
downloadfreebsd-ports-gnome-937c368c984e159a76e250b3c8b4dbb8c4d80b06.tar.gz
freebsd-ports-gnome-937c368c984e159a76e250b3c8b4dbb8c4d80b06.tar.zst
freebsd-ports-gnome-937c368c984e159a76e250b3c8b4dbb8c4d80b06.zip
games/xye: Fix build with Clang 6
src/xsb_level.cpp:787:45: error: constant expression evaluates to -1 which cannot be narrowed to type 'unsigned char' [-Wc++11-narrowing] static const unsigned char dx[4] = {0,0,-1,1}, dy[4] = {-1,1,0,0}; ^~ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475478_s336801/logs/errors/xye-0.12.2_3.log - While here fix bad absolute symlink
Diffstat (limited to 'games')
-rw-r--r--games/xye/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/xye/Makefile b/games/xye/Makefile
index 92402eba2818..da9eaa723def 100644
--- a/games/xye/Makefile
+++ b/games/xye/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xye
PORTVERSION= 0.12.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF:game \
http://xye.sourceforge.net/levels/ \
@@ -27,10 +27,12 @@ LICENSE= ZLIB
EXTRACT_DEPENDS=${UNZIP_CMD}:archivers/unzip
-USES= gmake
+USES= compiler gmake
USE_SDL= sdl image ttf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-docdir=${PREFIX}/share/doc
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
LEVELS= Xye%20level%20-%204corners Xye%20level%20-%20Against%20the%20force \
Xye%20level%20-%20Stop%20that%20cab Xye%20level%20-%20Helping%20Hand \
@@ -89,7 +91,7 @@ post-install:
@(cd ${WRKDIR}/skins && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/res)
.endif
- ${LN} -sf ${DATADIR}/res/detailed_icon.png \
+ ${RLN} ${STAGEDIR}${DATADIR}/res/detailed_icon.png \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.include <bsd.port.mk>