aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-23 21:11:25 +0800
committerkwm <kwm@FreeBSD.org>2013-03-23 21:11:25 +0800
commita0b35004b37b92af57333fc3763483ce26ac815e (patch)
treedadec2f15d46b1b3218bdfcb240bd80455091a2c /games
parentc7d96ba2ff6f4e6ea868bdce977a3cc347a8ae2d (diff)
downloadfreebsd-ports-gnome-a0b35004b37b92af57333fc3763483ce26ac815e.tar.gz
freebsd-ports-gnome-a0b35004b37b92af57333fc3763483ce26ac815e.tar.zst
freebsd-ports-gnome-a0b35004b37b92af57333fc3763483ce26ac815e.zip
Fix build with glib 2.34 [1]
While here, trim header, pet portlint, add missing gettext depend and switch to pathfix from gnomehack. PR: ports/177311 [1] Submitted by: John Marino <draco@marino.st>
Diffstat (limited to 'games')
-rw-r--r--games/monster-masher/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 0d8c9ce18e74..622bfed868b7 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: Monster-Masher
-# Date created: 26 Oct 2003
-# Whom: Koop Mast <einekoai@chello.nl>
-#
+# Created by: Koop Mast <einekoai@chello.nl>
# $FreeBSD$
-#
PORTNAME= monster
PORTVERSION= 1.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games gnome
MASTER_SITES= http://people.iola.dk/olau/monster-masher/source/
PKGNAMESUFFIX= -masher
@@ -16,17 +12,23 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Gnomemm puzzle game where you have to clean the caves of monsters
-LIB_DEPENDS= gnomecanvasmm-2.6.1:${PORTSDIR}/graphics/libgnomecanvasmm26 \
- gconfmm-2.6.1:${PORTSDIR}/devel/gconfmm26 \
- glademm-2.4.1:${PORTSDIR}/devel/libglademm24
+LIB_DEPENDS= gnomecanvasmm-2.6:${PORTSDIR}/graphics/libgnomecanvasmm26 \
+ gconfmm-2.6:${PORTSDIR}/devel/gconfmm26 \
+ glademm-2.4:${PORTSDIR}/devel/libglademm24
USE_BZIP2= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnome esound
+USES= pathfix
+USE_GNOME= gnomeprefix intlhack libgnome esound
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lesd
GCONF_SCHEMAS= monster-masher.schemas
+post-patch:
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/src/pixbuf-drawing.hpp
+
.include <bsd.port.mk>