aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
committerrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
commitabe85598b76e65884f63f5d35b14a7a5837c77ee (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /games
parenta6ebb885ab3952f319e4a2e650eba1580d82a26e (diff)
downloadfreebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.gz
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.zst
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.zip
Remove compatibility code for FreeBSD < 11.2 from all ports.
Simplify some ports where DragonFlyBSD no longer needs to be special-cased. Submitted by: rene Reviewed by: bapt, jbeich Differential Revision: https://reviews.freebsd.org/D17724
Diffstat (limited to 'games')
-rw-r--r--games/gzdoom/Makefile8
-rw-r--r--games/supertux2/Makefile2
-rw-r--r--games/wesnoth/Makefile1
3 files changed, 1 insertions, 10 deletions
diff --git a/games/gzdoom/Makefile b/games/gzdoom/Makefile
index 5694c8938c0b..22390a788954 100644
--- a/games/gzdoom/Makefile
+++ b/games/gzdoom/Makefile
@@ -43,16 +43,10 @@ PLIST_FILES= bin/${PORTNAME} \
.include "${.CURDIR}/../doom-data/Makefile.include"
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1100000 && ${MACHINE_ARCH} == "i386"
-STRIP= # 10.4/i386 strip(1) is incapable of stripping the gzdoom binary
-.endif
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${CONFIGURE_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${CONFIGURE_WRKSRC}/${PORTNAME}.pk3 ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.xpm ${STAGEDIR}${PREFIX}/share/pixmaps
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/supertux2/Makefile b/games/supertux2/Makefile
index 6d83f2a7c6f0..439c91aa6b9a 100644
--- a/games/supertux2/Makefile
+++ b/games/supertux2/Makefile
@@ -15,8 +15,6 @@ LIB_DEPENDS= libphysfs.so:devel/physfs \
libcurl.so:ftp/curl \
libvorbis.so:audio/libvorbis
-BROKEN_FreeBSD_10= does not build on 10.x
-
LLD_UNSAFE= yes
USE_SDL= sdl2 image2
USE_GL= glew
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 127de90d90dc..996def3f8e75 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -15,7 +15,6 @@ LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_10= fails to build with boost 1.66, see bug 224130
BROKEN_powerpc64= fails to link: schema_validator.cpp: undefined reference to boost::match_results
LIB_DEPENDS= libfreetype.so:print/freetype2 \