aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-07-18 20:03:17 +0800
committersobomax <sobomax@FreeBSD.org>2001-07-18 20:03:17 +0800
commitb15a34e64c669357cb61071d10dee2ba484a049d (patch)
tree552c17c2f93c42dd6c611634cfb28044ae81535e /games
parenta5dbe5b6f35e76b23cff42b7c238de1366a4f5c7 (diff)
downloadfreebsd-ports-gnome-b15a34e64c669357cb61071d10dee2ba484a049d.tar.gz
freebsd-ports-gnome-b15a34e64c669357cb61071d10dee2ba484a049d.tar.zst
freebsd-ports-gnome-b15a34e64c669357cb61071d10dee2ba484a049d.zip
Pass PTHREAD_CFLAGS/PTHREAD_LIBS to the configure - this should fix the port
on -stable. Submitted by: bento
Diffstat (limited to 'games')
-rw-r--r--games/bomberinstinct/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/bomberinstinct/Makefile b/games/bomberinstinct/Makefile
index b18c2c100bfb..75f74361a077 100644
--- a/games/bomberinstinct/Makefile
+++ b/games/bomberinstinct/Makefile
@@ -22,8 +22,8 @@ SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
pre-patch:
@find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e 's|<SDL/|<|g'