aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
committertijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
commitb3a361d8eb7b71f0b468fd98e66a366d09af5fcf (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /games
parent237bc033e6203c347316781328565cb5a7f8b2cf (diff)
downloadfreebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.gz
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.zst
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'games')
-rw-r--r--games/aisleriot/Makefile2
-rw-r--r--games/anki/Makefile3
-rw-r--r--games/bygfoot/Makefile4
-rw-r--r--games/bygfoot/files/patch-po-Makefile.in.in10
-rw-r--r--games/cuyo/Makefile4
-rw-r--r--games/gbottler/Makefile2
-rw-r--r--games/ggz-sdl-games/Makefile12
-rw-r--r--games/gnomebreakout/Makefile4
-rw-r--r--games/live-f1/Makefile2
-rw-r--r--games/pythonsudoku/Makefile4
-rw-r--r--games/scourge/Makefile10
-rw-r--r--games/unknown-horizons/Makefile2
-rw-r--r--games/xboard-devel/Makefile5
13 files changed, 26 insertions, 38 deletions
diff --git a/games/aisleriot/Makefile b/games/aisleriot/Makefile
index 8d7bc1478514..e464b49119c5 100644
--- a/games/aisleriot/Makefile
+++ b/games/aisleriot/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libguile-2.0.so:${PORTSDIR}/lang/guile2 \
CONFLICTS= sol-*
-USES= desktop-file-utils gmake pathfix pkgconfig tar:xz
+USES= desktop-file-utils gettext gmake pathfix pkgconfig tar:xz
USE_GNOME= gconf2 gtk30 intlhack librsvg2 libxml2:build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-card-theme-formats=svg \
diff --git a/games/anki/Makefile b/games/anki/Makefile
index e71db6fb41e4..54c9b57deb90 100644
--- a/games/anki/Makefile
+++ b/games/anki/Makefile
@@ -3,6 +3,7 @@
PORTNAME= anki
PORTVERSION= 2.0.31
+PORTREVISION= 1
CATEGORIES= games python
MASTER_SITES= http://ankisrs.net/download/mirror/
DIST_SUBDIR= python
@@ -31,7 +32,7 @@ USE_QT4= network_run webkit_run
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USES= gettext:run
+NLS_USES= gettext-runtime:run
.include <bsd.port.options.mk>
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
index f50f42e4cc6f..ba71f6bd39a6 100644
--- a/games/bygfoot/Makefile
+++ b/games/bygfoot/Makefile
@@ -18,10 +18,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
-USES= pkgconfig tar:bzip2
+USES= gettext pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= gtk20
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lm
+LIBS+= -L${LOCALBASE}/lib -lm
.include <bsd.port.mk>
diff --git a/games/bygfoot/files/patch-po-Makefile.in.in b/games/bygfoot/files/patch-po-Makefile.in.in
deleted file mode 100644
index 452490ff9067..000000000000
--- a/games/bygfoot/files/patch-po-Makefile.in.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- po/Makefile.in.in.orig 2008-03-02 17:23:22.000000000 +0100
-+++ po/Makefile.in.in 2008-03-14 14:12:46.000000000 +0100
-@@ -21,6 +21,7 @@
-
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
-+top_builddir = $(top_srcdir)
- VPATH = @srcdir@
-
- prefix = @prefix@
diff --git a/games/cuyo/Makefile b/games/cuyo/Makefile
index 568357e60518..de1014bff78a 100644
--- a/games/cuyo/Makefile
+++ b/games/cuyo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cuyo
PORTVERSION= 2.0.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SAVANNAH
@@ -29,7 +29,7 @@ OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext:run
+NLS_USES= gettext-runtime:run
# Do not use older versions
PORTSCOUT= skipv:2.~-1.2~beta1
diff --git a/games/gbottler/Makefile b/games/gbottler/Makefile
index a6f5c203b9ec..ab0c48a7d880 100644
--- a/games/gbottler/Makefile
+++ b/games/gbottler/Makefile
@@ -13,8 +13,8 @@ COMMENT= SSTP Bottle client
RUN_DEPENDS= ${PYXML}
+USES= gettext-tools gmake python
USE_GNOME= pygtk2
-USES= gmake python
PLIST_SUB= VERSION=${PORTVERSION}
.include <bsd.port.mk>
diff --git a/games/ggz-sdl-games/Makefile b/games/ggz-sdl-games/Makefile
index 8a34007d4ec2..f59d7cc9a412 100644
--- a/games/ggz-sdl-games/Makefile
+++ b/games/ggz-sdl-games/Makefile
@@ -9,21 +9,23 @@ CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
COMMENT= The GGZ Gaming Zone - SDL-based games
-USE_GL= gl
-USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
+USES= gettext
USE_GGZ= client
+USE_GL= gl
+USE_SDL= image mixer sdl ttf
+USE_XORG= xcursor
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread -lexpat
+LIBS+= -L${LOCALBASE}/lib -lexpat
post-patch:
- @${REINPLACE_CMD} -e 's|_LDADD =|_LDADD = -lggzcore -lggz|' \
+ @${REINPLACE_CMD} -e '/^ggz_ttt3d_LDADD =/s/$$/ -lggzcore -lggz/' \
${WRKSRC}/ttt3d/Makefile.in
- @${REINPLACE_CMD} -e 's|_LDADD =|_LDADD = -lggzcore|' \
+ @${REINPLACE_CMD} -e '/^geekgame_LDADD =/s/$$/ -lggzcore -lX11/' \
${WRKSRC}/geekgame/Makefile.in
post-install:
diff --git a/games/gnomebreakout/Makefile b/games/gnomebreakout/Makefile
index 96ad75673e0d..75b8b80be283 100644
--- a/games/gnomebreakout/Makefile
+++ b/games/gnomebreakout/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnomebreakout
PORTVERSION= 0.5.3
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= games gnome
MASTER_SITES= SF/${PORTNAME:S/eb/e-b/}/${PORTNAME:S/eb/e-b/}/${PORTVERSION}/ \
http://www.users.on.net/~mipearson/
@@ -29,7 +29,7 @@ PORTDOCS= AUTHORS ChangeLog NEWS README
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-NLS_USES= gettext:run
+NLS_USES= gettext-runtime:run
.include <bsd.port.options.mk>
diff --git a/games/live-f1/Makefile b/games/live-f1/Makefile
index d93eef7b17df..f2d0e75c43d3 100644
--- a/games/live-f1/Makefile
+++ b/games/live-f1/Makefile
@@ -18,7 +18,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
OPTIONS_DEFINE= NLS
-USES= pkgconfig gettext:build iconv gmake tar:tgz
+USES= pkgconfig gettext-tools iconv gmake tar:tgz
USE_OPENSSL= yes
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/pythonsudoku/Makefile b/games/pythonsudoku/Makefile
index 6ca2e43b6f75..8c2880b4dc3b 100644
--- a/games/pythonsudoku/Makefile
+++ b/games/pythonsudoku/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pythonsudoku
PORTVERSION= 0.13
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/Python%20Sudoku/${PORTVERSION}/ \
SF/nemysisfreebsdp/games/:icons
@@ -36,7 +36,7 @@ DESKTOP_ENTRIES="Python Sudoku" "" "${PORTNAME}" \
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-NLS_USES= gettext:run
+NLS_USES= gettext-runtime:run
.include <bsd.port.options.mk>
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index b319634aa178..70f3e45a24a3 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -15,13 +15,12 @@ COMMENT= Rogue-like game
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${DATADIR}/config/scourge.cfg:${PORTSDIR}/games/scourge-data
-USE_AUTOTOOLS= autoconf:env automake:env
+USES= autoreconf gettext gmake
USE_GL= gl
USE_SDL= sdl image mixer net ttf
-USES= gmake
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_LIBS}
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-data-dir=${DATADIR}
@@ -35,9 +34,6 @@ DEBUG_CONFIGURE_ENABLE= debug
post-patch:
@${REINPLACE_CMD} -e 's|GLvoid|void|g' ${WRKSRC}/src/sdlhandler.cpp ${WRKSRC}/src/sdlhandler.h
-pre-configure:
- @cd ${WRKSRC} && ${AUTORECONF} -i
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
diff --git a/games/unknown-horizons/Makefile b/games/unknown-horizons/Makefile
index 164243ba2cc1..bee8a8a64201 100644
--- a/games/unknown-horizons/Makefile
+++ b/games/unknown-horizons/Makefile
@@ -25,7 +25,7 @@ GH_ACCOUNT= ${PORTNAME}
GH_COMMIT= ac7af43
USE_GNOME= intltool
-USES= gettext:build python:2 tar:xz
+USES= gettext-tools python:2 tar:xz
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= UnknownHorizons
diff --git a/games/xboard-devel/Makefile b/games/xboard-devel/Makefile
index 4c08b14bbe0c..613e615c1125 100644
--- a/games/xboard-devel/Makefile
+++ b/games/xboard-devel/Makefile
@@ -26,15 +26,14 @@ DATADIR= ${PREFIX}/share/games/xboard
DOCSDIR= ${PREFIX}/share/doc/xboard
XBOARDCONF= ${WRKSRC}/xboard.conf.in
-USES= gmake shebangfix
+USES= autoreconf gettext-tools gmake shebangfix
SHEBANG_FILES= texi2man
-USE_AUTOTOOLS= automake aclocal
INSTALL_TARGET= install-strip
pre-configure:
+ ${RM} ${WRKSRC}/m4/*.m4
${REINPLACE_CMD} -e "s|\(GITVERSION=\).*|\1${COMMIT_HASH}|" ${WRKSRC}/Makefile.am
${REINPLACE_CMD} -E "s|(AC_INIT\(\[xboard\],\[master-[^]]+)(\].+\))|\1-git:${COMMIT_HASH}\2|" ${WRKSRC}/configure.ac
- @cd ${WRKSRC} && ./autogen.sh
.include "${MASTERDIR}/Makefile"