aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-06-26 08:55:16 +0800
committerjbeich <jbeich@FreeBSD.org>2018-06-26 08:55:16 +0800
commitb428769603642d32887152795ea48c0de02bb6f7 (patch)
tree773ad091231682a1f55cfb77398c403ed2585467 /games
parent21059d35b5471da339acfba1595c24d8947bdbaf (diff)
downloadfreebsd-ports-gnome-b428769603642d32887152795ea48c0de02bb6f7.tar.gz
freebsd-ports-gnome-b428769603642d32887152795ea48c0de02bb6f7.tar.zst
freebsd-ports-gnome-b428769603642d32887152795ea48c0de02bb6f7.zip
games/openbor: update to 6215
Changes: https://github.com/DCurrent/openbor/compare/50ccb3df...4a717a63
Diffstat (limited to 'games')
-rw-r--r--games/openbor/Makefile4
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-sdl_sdlport.c12
3 files changed, 17 insertions, 5 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 130dc0fcf5a6..61c1aab7a00f 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openbor
# Hint: svn revision is git rev-list --count ${GH_TAGNAME}
-PORTVERSION?= 6184
+PORTVERSION?= 6215
.ifndef PKGNAMESUFFIX
PORTREVISION= 0
.endif
@@ -31,7 +31,7 @@ PORTSCOUT= ignore:1
USE_GITHUB= yes
GH_ACCOUNT= DCurrent
-GH_TAGNAME?= 50ccb3df
+GH_TAGNAME?= 4a717a63
USES+= gmake pkgconfig
.if ${PORTVERSION} < 4433
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index 8aad53eb76cf..2bc41e4c50a4 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1527695239
-SHA256 (DCurrent-openbor-6184-50ccb3df_GH0.tar.gz) = dc13b6ec89f53bbc63e8af853583bee6e9daebcc6259c0317321aa326eb90f04
-SIZE (DCurrent-openbor-6184-50ccb3df_GH0.tar.gz) = 185431321
+TIMESTAMP = 1529621537
+SHA256 (DCurrent-openbor-6215-4a717a63_GH0.tar.gz) = 0cbef50b1f9603c5990af3a183ae107a4972976a9fdf7f31e975ee4dd1bc10ab
+SIZE (DCurrent-openbor-6215-4a717a63_GH0.tar.gz) = 154366948
diff --git a/games/openbor/files/patch-sdl_sdlport.c b/games/openbor/files/patch-sdl_sdlport.c
index 8a143220a1c5..c7612ff5aa41 100644
--- a/games/openbor/files/patch-sdl_sdlport.c
+++ b/games/openbor/files/patch-sdl_sdlport.c
@@ -11,6 +11,18 @@ Store settings under ~/.openbor instead of current directory
#include <time.h>
#include <unistd.h>
+@@ -58,10 +58,10 @@ char* AndroidRoot(char *relPath)
+ strcat(filename, relPath);
+ return filename;
+ }
++#endif
+
+ void borExit(int reset)
+ {
+-#endif
+
+ #ifdef GP2X
+ gp2x_end();
@@ -103,6 +105,16 @@ int main(int argc, char *argv[])
#ifdef ANDROID
dirExists(rootDir, 1);