aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-18 08:07:01 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-18 08:07:01 +0800
commitb7afd8764166f4a9712514cdecdca713413a5a8a (patch)
treeb759d9e159d52c1d398793b6e6f1af526fa23aaf /games
parent4d7837333d8de66dac421a678325a9dd2c033c02 (diff)
downloadfreebsd-ports-gnome-b7afd8764166f4a9712514cdecdca713413a5a8a.tar.gz
freebsd-ports-gnome-b7afd8764166f4a9712514cdecdca713413a5a8a.tar.zst
freebsd-ports-gnome-b7afd8764166f4a9712514cdecdca713413a5a8a.zip
Add blobwars.
Since their world was invaded by an alien race, the Blobs have faced a lifetime of war. But now they have a chance to win the war once and for all. In Blob Wars : Metal Blob Solid, you take on the role of a fearless Blob agent, Bob. Bob's mission is to infiltrate the various enemy bases around the Blobs' homeworld and rescue as many MIAs as possible. But standing in his way are many vicious aliens, other Blobs who have been assimilated and the evil alien leader, Galdov. WWW: http://www.parallelrealities.co.uk/blobWars.php PR: ports/82260 Submitted by: Loren M. Lang <lorenl@alzatex.com>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/blobwars/Makefile43
-rw-r--r--games/blobwars/distinfo2
-rw-r--r--games/blobwars/files/patch-makefile80
-rw-r--r--games/blobwars/pkg-descr13
-rw-r--r--games/blobwars/pkg-plist6
6 files changed, 145 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 05e989403ead..afebaf6f56e8 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -45,6 +45,7 @@
SUBDIR += battleball
SUBDIR += biorythm
SUBDIR += blackjack
+ SUBDIR += blobwars
SUBDIR += block
SUBDIR += blockade
SUBDIR += blue
diff --git a/games/blobwars/Makefile b/games/blobwars/Makefile
new file mode 100644
index 000000000000..39f19ea77fdb
--- /dev/null
+++ b/games/blobwars/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: blobwars
+# Date created: 14 June 2005
+# Whom: Loren M. Lang
+#
+# $FreeBSD$
+#
+
+PORTNAME= blobwars
+DISTVERSION= 1.04-1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR=distfiles
+
+MAINTAINER= lorenl@alzatex.com
+COMMENT= You are the fearless Blob agent, Bob
+
+MAKEFILE= makefile
+MAKE_ENV= CXX="${CXX}"
+
+USE_X_PREFIX= yes
+USE_SDL= sdl image mixer ttf
+USE_GMAKE= yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/blobwars-1.04
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/makefile
+.for f in src/headers.h src/CFileData.cpp src/CPak.cpp src/pak.h
+ @${REINPLACE_CMD} -e 's|SDL/SDL\([_a-z]*\)\.h|SDL11/SDL\1.h|' \
+ ${WRKSRC}/${f}
+.endfor
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/blobwars/distinfo b/games/blobwars/distinfo
new file mode 100644
index 000000000000..cf5d0bb111aa
--- /dev/null
+++ b/games/blobwars/distinfo
@@ -0,0 +1,2 @@
+MD5 (blobwars-1.04-1.tar.gz) = fccb31ed097b8db95b58ed9512d98b63
+SIZE (blobwars-1.04-1.tar.gz) = 7682669
diff --git a/games/blobwars/files/patch-makefile b/games/blobwars/files/patch-makefile
new file mode 100644
index 000000000000..b75160796e7f
--- /dev/null
+++ b/games/blobwars/files/patch-makefile
@@ -0,0 +1,80 @@
+--- makefile.orig Mon Apr 25 20:25:37 2005
++++ makefile Sat Jun 18 01:55:54 2005
+@@ -7,9 +7,8 @@
+ RELEASE = 1
+ USEPAK = 1
+
+-PREFIX=$(DESTDIR)/usr
+-BINDIR = $(PREFIX)/games/
+-DATADIR = $(PREFIX)/share/games/parallelrealities/
++BINDIR = $(PREFIX)/bin/
++DATADIR = $(PREFIX)/share/$(PROG)/
+ DOCDIR = $(PREFIX)/share/doc/$(PROG)/
+ ICONDIR = $(PREFIX)/share/icons/
+ KDE = $(PREFIX)/share/applnk/Games/Arcade/
+@@ -35,7 +34,7 @@
+ PAKOBJS = CFileData.o pak.o
+
+ # top-level rule to create the program.
+-all: $(PROG) pak
++all: $(PROG) pak buildpak
+
+ # compiling other source files.
+ %.o: src/%.cpp src/%.h src/defs.h src/defines.h src/headers.h
+@@ -44,7 +43,7 @@
+ # linking the program.
+ $(PROG): $(GAMEOBJS)
+ $(CXX) $(LIBS) $(GAMEOBJS) -o $(PROG)
+-
++
+ pak: $(PAKOBJS)
+ $(CXX) $(LIBS) $(PAKOBJS) -o pak
+
+@@ -55,33 +54,20 @@
+ # cleaning everything that can be automatically recreated with "make".
+ clean:
+ $(RM) $(GAMEOBJS) mapEditor.o pak.o
+-
++
+ buildpak:
+ ./pak data gfx music sound $(PAKNAME)
+
+ # install
+ install:
+-
+- ./pak data gfx music sound $(PAKNAME)
+-
+- mkdir -p $(BINDIR)
+ mkdir -p $(DATADIR)
+- mkdir -p $(DOCDIR)
+- mkdir -p $(ICONDIR)
+- mkdir -p $(ICONDIR)mini
+- mkdir -p $(ICONDIR)large
+- mkdir -p $(KDE)
+- mkdir -p $(GNOME)
+-
+- strip $(PROG)
+- install -o root -g games -m 755 $(PROG) $(BINDIR)$(PROG)
+- install -o root -g games -m 644 $(PAKNAME) $(DATADIR)$(PAKNAME)
+- install -o root -g games -m 644 $(DOCS) $(DOCDIR)
+- cp $(ICONS)$(PROG).png $(ICONDIR)
+- cp $(ICONS)$(PROG)-mini.png $(ICONDIR)mini/$(PROG).png
+- cp $(ICONS)$(PROG)-large.png $(ICONDIR)large/$(PROG).png
+- cp $(ICONS)$(PROG).desktop $(KDE)
+- cp $(ICONS)$(PROG).desktop $(GNOME)
++ mkdir -p $(PREFIX)/share/applications
++ mkdir -p $(PREFIX)/share/pixmaps
++
++ $(BSD_INSTALL_PROGRAM) $(PROG) $(BINDIR)$(PROG)
++ $(BSD_INSTALL_DATA) $(PAKNAME) $(DATADIR)$(PAKNAME)
++ $(BSD_INSTALL_DATA) $(ICONS)$(PROG).desktop $(PREFIX)/share/applications
++ $(BSD_INSTALL_DATA) $(ICONS)$(PROG).png $(PREFIX)/share/pixmaps
+
+ uninstall:
+ $(RM) $(BINDIR)$(PROG)
+@@ -92,4 +78,3 @@
+ $(RM) $(ICONDIR)large/$(PROG).png
+ $(RM) $(KDE)$(ICONS)$(PROG).desktop
+ $(RM) $(GNOME)$(ICONS)$(PROG).desktop
+-
+\ No newline at end of file
diff --git a/games/blobwars/pkg-descr b/games/blobwars/pkg-descr
new file mode 100644
index 000000000000..9d635f1aaa18
--- /dev/null
+++ b/games/blobwars/pkg-descr
@@ -0,0 +1,13 @@
+Since their world was invaded by an alien race, the Blobs have faced a
+lifetime of war. But now they have a chance to win the war once and for all.
+
+In Blob Wars : Metal Blob Solid, you take on the role of a fearless Blob
+agent, Bob. Bob's mission is to infiltrate the various enemy bases around
+the Blobs' homeworld and rescue as many MIAs as possible. But standing in his
+way are many vicious aliens, other Blobs who have been assimilated and the
+evil alien leader, Galdov.
+
+WWW: http://www.parallelrealities.co.uk/blobWars.php
+
+- Loren M. Lang
+lorenl@alzatex.com
diff --git a/games/blobwars/pkg-plist b/games/blobwars/pkg-plist
new file mode 100644
index 000000000000..0ae326a45e78
--- /dev/null
+++ b/games/blobwars/pkg-plist
@@ -0,0 +1,6 @@
+bin/blobwars
+%%DATADIR%%/blobwars.pak
+share/applications/blobwars.desktop
+share/pixmaps/blobwars.png
+@dirrm %%DATADIR%%
+@unexec rmdir %D/share/applications 2>/dev/null || true