aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-25 03:55:15 +0800
committeradamw <adamw@FreeBSD.org>2015-03-25 03:55:15 +0800
commitba5e14d8054d1b30d80d9fa5aa77aee7cb827dde (patch)
tree9c23fa8f466d2dbc5a9fe09c342fce04ce7bee01 /games
parent0ebee877f8b2e376f4b2ff01d9edf50077811bbc (diff)
downloadfreebsd-ports-gnome-ba5e14d8054d1b30d80d9fa5aa77aee7cb827dde.tar.gz
freebsd-ports-gnome-ba5e14d8054d1b30d80d9fa5aa77aee7cb827dde.tar.zst
freebsd-ports-gnome-ba5e14d8054d1b30d80d9fa5aa77aee7cb827dde.zip
Add two patches from DragonFlyBSD trunk:
- 68420e59f12cf9c9fc14db0c493426150dd9ed95 Fix some typos in messages/manpages. (Sascha Wildner) - 890b6f4a25a31acb7bb5b8c16193dc5d404b0805 games: Fix real bugs on three games (found by gcc 5.0) (John Marino)
Diffstat (limited to 'games')
-rw-r--r--games/bsdgames/Makefile1
-rw-r--r--games/bsdgames/files/patch-68420e59f12cf9c9fc14db0c493426150dd9ed9523
-rw-r--r--games/bsdgames/files/patch-890b6f4a25a31acb7bb5b8c16193dc5d404b080598
3 files changed, 122 insertions, 0 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index 23835721a76c..ca2de37b741e 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bsdgames
PORTVERSION= 4.0.5
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
diff --git a/games/bsdgames/files/patch-68420e59f12cf9c9fc14db0c493426150dd9ed95 b/games/bsdgames/files/patch-68420e59f12cf9c9fc14db0c493426150dd9ed95
new file mode 100644
index 000000000000..e1059691311b
--- /dev/null
+++ b/games/bsdgames/files/patch-68420e59f12cf9c9fc14db0c493426150dd9ed95
@@ -0,0 +1,23 @@
+From 68420e59f12cf9c9fc14db0c493426150dd9ed95 Mon Sep 17 00:00:00 2001
+From: Sascha Wildner <saw@online.de>
+Date: Thu, 8 Jan 2015 10:17:46 +0100
+Subject: [PATCH 1/1] Fix some typos in messages/manpages.
+
+---
+ games/canfield/canfield/canfield.c | 2 +-
+ share/man/man4/km.4 | 8 ++++----
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git canfield/canfield/canfield.c canfield/canfield/canfield.c
+index de63fc1..ec6de9d 100644
+--- canfield/canfield/canfield.c
++++ canfield/canfield/canfield.c
+@@ -1543,7 +1543,7 @@ movecard(void)
+ }
+
+ const char *const basicinstructions[] = {
+- "Here are brief instuctions to the game of Canfield:\n\n",
++ "Here are brief instructions to the game of Canfield:\n\n",
+ " If you have never played solitaire before, it is recom-\n",
+ "mended that you consult a solitaire instruction book. In\n",
+ "Canfield, tableau cards may be built on each other downward\n",
diff --git a/games/bsdgames/files/patch-890b6f4a25a31acb7bb5b8c16193dc5d404b0805 b/games/bsdgames/files/patch-890b6f4a25a31acb7bb5b8c16193dc5d404b0805
new file mode 100644
index 000000000000..1a3c69dc3516
--- /dev/null
+++ b/games/bsdgames/files/patch-890b6f4a25a31acb7bb5b8c16193dc5d404b0805
@@ -0,0 +1,98 @@
+From 890b6f4a25a31acb7bb5b8c16193dc5d404b0805 Mon Sep 17 00:00:00 2001
+From: John Marino <draco@marino.st>
+Date: Wed, 11 Feb 2015 09:03:31 +0100
+Subject: [PATCH 1/1] games: Fix real bugs on three games (found by gcc 5.0)
+
+I had NO_GAMES set so I missed these bugs yesterday. Adventure, Fortune,
+and Mille all had bugs in them (the latter had two).
+
+Now gcc-5.0 can build the entire world and kernel.
+I still need to verify that a gcc-5.0 built world and kernel is bootable
+and works though.
+---
+ games/adventure/init.c | 2 +-
+ games/fortune/fortune/fortune.c | 2 +-
+ games/mille/move.c | 11 ++++++-----
+ 3 files changed, 8 insertions(+), 7 deletions(-)
+
+diff --git adventure/init.c adventure/init.c
+index 122b90d..beb3631 100644
+--- adventure/init.c
++++ adventure/init.c
+@@ -81,7 +81,7 @@ linkdata(void)
+ int i, j;
+
+ /* array linkages */
+- for (i = 1; i <= LOCSIZ; i++)
++ for (i = 1; i < LOCSIZ; i++)
+ if (ltext[i].seekadr != 0 && travel[i] != 0)
+ if ((travel[i]->tverb) == 1)
+ cond[i] = 2;
+diff --git fortune/fortune/fortune.c fortune/fortune/fortune.c
+index 175ab53..9606aa0 100644
+--- fortune/fortune/fortune.c
++++ fortune/fortune/fortune.c
+@@ -97,7 +97,7 @@ bool All_forts = false; /* any fortune allowed */
+ bool Equal_probs= false; /* scatter un-allocted prob equally */
+ bool Match = false; /* dump fortunes matching a pattern */
+ #ifdef DEBUG
+-bool Debug = false; /* print debug messages */
++int Debug = 0; /* print debug messages */
+ #endif
+
+ char *Fortbuf = NULL; /* fortune buffer for -m */
+diff --git mille/move.c mille/move.c
+index 7581cc0..8a0da41 100644
+--- mille/move.c
++++ mille/move.c
+@@ -140,7 +140,7 @@ acc:
+ for (i = 1; i < HAND_SZ; i++)
+ if (pp->hand[i] == C_INIT) {
+ for (j = 0; pp->hand[j] == C_INIT; j++)
+- if (j >= HAND_SZ) {
++ if (j == HAND_SZ - 1) {
+ j = 0;
+ break;
+ }
+@@ -193,6 +193,7 @@ playcard(PLAY *pp)
+ {
+ int v;
+ CARD card;
++ bool blockNext;
+
+ /*
+ * check and see if player has picked
+@@ -212,7 +213,7 @@ mustpick:
+ if (Debug)
+ fprintf(outf, "PLAYCARD: Card = %s\n", C_name[card]);
+ #endif
+- Next = FALSE;
++ blockNext = FALSE;
+ switch (card) {
+ case C_200:
+ if (pp->nummiles[C_200] == 2)
+@@ -322,18 +323,18 @@ protected:
+ if (!pp->can_go && isrepair(pp->battle))
+ pp->can_go = TRUE;
+ }
+- Next = -1;
++ blockNext = TRUE;
+ break;
+
+ case C_INIT:
+ error("no card there");
+- Next = -1;
++ blockNext = TRUE;
+ break;
+ }
+ if (pp == &Player[PLAYER])
+ account(card);
+ pp->hand[Card_no] = C_INIT;
+- Next = (Next == -1 ? FALSE : TRUE);
++ Next = !blockNext;
+ return TRUE;
+ }
+
+--
+1.9.3
+