aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-08-02 13:48:38 +0800
committertobik <tobik@FreeBSD.org>2018-08-02 13:48:38 +0800
commitbc087adef9f4a4e51df175d9c4236f7bd933991d (patch)
tree7ec801d028b79a76a4674087ac6a74063f288538 /games
parent8dc5d96db0f4fc2a9c58ad6c8cf60b8abbe3ef03 (diff)
downloadfreebsd-ports-gnome-bc087adef9f4a4e51df175d9c4236f7bd933991d.tar.gz
freebsd-ports-gnome-bc087adef9f4a4e51df175d9c4236f7bd933991d.tar.zst
freebsd-ports-gnome-bc087adef9f4a4e51df175d9c4236f7bd933991d.zip
games/netherearth: Fix build with Clang 6
bullet.cpp:184:7: error: non-constant-expression cannot be narrowed from type 'double' to 'float' in initializer list [-Wc++11-narrowing] bullet->pos.x,bullet->pos.y,0.3,1}; ^~~~~~~~~~~~~ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475964_s336959/logs/errors/netherearth-0.51_9.log - While here add missing dependencies
Diffstat (limited to 'games')
-rw-r--r--games/netherearth/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/games/netherearth/Makefile b/games/netherearth/Makefile
index f8b0618725d2..b38cec3fe066 100644
--- a/games/netherearth/Makefile
+++ b/games/netherearth/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netherearth
PORTVERSION= 0.51
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= http://move.kirishi.ru/soft/netherearth/
@@ -12,9 +12,13 @@ COMMENT= Remake of the first real time strategy game on the SPECTRUM
GNU_CONFIGURE= yes
-USE_GL= glut
+USES= compiler
+USE_GL= gl glu glut
USE_SDL= sdl mixer
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
+
pre-install:
if [ ! -d ${STAGEDIR}${PREFIX}/share/netherearth ] ; then \
${MKDIR} ${STAGEDIR}${PREFIX}/share/netherearth ;\