aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-10-17 06:30:07 +0800
committerak <ak@FreeBSD.org>2012-10-17 06:30:07 +0800
commitce62f4f0cfbdc1b108ad9cb9a29c9c4e6e7fc431 (patch)
tree77d78fe65e89ac326ae3e0c2c8f5a9b007211730 /games
parent68896c01e558f095dc84fa55273b974bd872b075 (diff)
downloadfreebsd-ports-gnome-ce62f4f0cfbdc1b108ad9cb9a29c9c4e6e7fc431.tar.gz
freebsd-ports-gnome-ce62f4f0cfbdc1b108ad9cb9a29c9c4e6e7fc431.tar.zst
freebsd-ports-gnome-ce62f4f0cfbdc1b108ad9cb9a29c9c4e6e7fc431.zip
- Convert Makefile headers to new style
- Convert to new options framework - Remove redundant comments - Add DESKTOP_ENTRIES - Bump PORTREVISION Submitted by: nemysis <nemysis at gmx.ch> (maintainer) Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/sdl_lopan/Makefile51
-rw-r--r--games/sdl_lopan/distinfo6
2 files changed, 33 insertions, 24 deletions
diff --git a/games/sdl_lopan/Makefile b/games/sdl_lopan/Makefile
index eb40fca8b395..50f8d8db3411 100644
--- a/games/sdl_lopan/Makefile
+++ b/games/sdl_lopan/Makefile
@@ -1,54 +1,61 @@
-# New Ports collection makefile for: SDL_Lopan
-# Date created: 2012-04-26
-# Whom: nemysis@gmx.ch
-#
# $FreeBSD$
-#
PORTNAME= sdl_lopan
PORTVERSION= 10
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://www.linuxmotors.com/sdllopan/downloads/
-DISTNAME= ${PORTNAME:S/_//}-${PORTVERSION}
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.linuxmotors.com/sdllopan/downloads/ \
+ http://www.linuxmotors.com/sdllopan/:icons
+DISTFILES= sdllopan-${DISTVERSION}.tgz \
+ sdllopan.gif:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= sdllopan-${DISTVERSION}.tgz
MAINTAINER= nemysis@gmx.ch
COMMENT= Mahjong game remake
LICENSE= GPLv2
+BUILD_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm
+
WRKSRC= ${WRKDIR}/sdllopan-${PORTVERSION}
USE_SDL= sdl image mixer
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/sdllopan
+ALL_TARGET=
+
+PLIST_FILES= bin/sdllopan \
+ share/pixmaps/sdllopan.png
PORTDATA= *
PORTDOCS= Changelog README
-ALL_TARGET=
+DESKTOP_ENTRIES="SDL Lopan" "${COMMENT}" "sdllopan" \
+ "sdllopan" "Game;ArcadeGame;" ${FALSE}
+
+.include <bsd.port.options.mk>
post-patch:
-# Fix data location
- @${REINPLACE_CMD} -e 's!data/bg%d.pcx!${DATADIR}/data/bg%d.pcx!' \
- -e 's!data/tiles%d.pcx!${DATADIR}/data/tiles%d.pcx!' \
- -e 's!char temp\[64\];!char temp\[256\];!' \
- ${WRKSRC}/lopan.c
+ @${REINPLACE_CMD} -e 's|data/bg%d.pcx|${DATADIR}/data/bg%d.pcx|' \
+ -e 's|data/tiles%d.pcx|${DATADIR}/data/tiles%d.pcx|' \
+ -e 's|char temp\[64\];|char temp\[256\];|' \
+ ${WRKSRC}/lopan.c
+
+post-build:
+ @(cd ${WRKSRC} && \
+ ${LOCALBASE}/bin/giftopnm ${DISTDIR}/${DIST_SUBDIR}/sdllopan.gif | \
+ ${LOCALBASE}/bin/pamscale .1 | ${LOCALBASE}/bin/pnmtopng > sdllopan.png)
do-install:
-# Executable
${INSTALL_PROGRAM} ${WRKSRC}/lopan ${PREFIX}/bin/sdllopan
-# Data
@(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR})
+ ${INSTALL_DATA} ${WRKSRC}/sdllopan.png ${PREFIX}/share/pixmaps
-# Documentation
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/sdl_lopan/distinfo b/games/sdl_lopan/distinfo
index b4a76ce6b47d..94ae6a7d2758 100644
--- a/games/sdl_lopan/distinfo
+++ b/games/sdl_lopan/distinfo
@@ -1,2 +1,4 @@
-SHA256 (sdllopan-10.tgz) = 386de065bc8c3449c3b0b5e5651cb035cb1bdc242b425c865dd387c54ce708c3
-SIZE (sdllopan-10.tgz) = 380102
+SHA256 (sdl_lopan/sdllopan-10.tgz) = 386de065bc8c3449c3b0b5e5651cb035cb1bdc242b425c865dd387c54ce708c3
+SIZE (sdl_lopan/sdllopan-10.tgz) = 380102
+SHA256 (sdl_lopan/sdllopan.gif) = 390f26f4792e1116b4f4456a1e2b9713bca6b9fd200badb85e4b9be403a0988a
+SIZE (sdl_lopan/sdllopan.gif) = 45164
d25dc2c14a44bcdb71686a213e00b00'>Install shared libraries to privlibdir.Hans Petter Jansson2005-02-101-1/+1 * Convert to G_DEFINE_TYPEJP Rosevear2004-11-121-12/+12 * do not set position, it's already done in .glade, call set_transient_forRadek Doulik2004-08-041-1/+9 * watch for selection changes and set Delete button sensitivity according toRadek Doulik2004-07-241-0/+21 * clone view before saving it to avoid problems with setting current_view_idRadek Doulik2004-06-211-0/+2 * prepend label " " before the ETableRadek Doulik2004-06-152-14/+57 * HIGified, updated as suggested in #46236Radek Doulik2004-06-112-244/+224 * remove defunct Revert button and replace OK/Cancel buttons with a CloseJon Oberheide2004-06-102-43/+2 * Fixes #48129Jon Oberheide2004-05-101-0/+1 * don't issue the display view signal a second time, connect_view does thisJP Rosevear2004-04-061-1/+0 * NULL out priv->instance when we unref it. Bug #51713.Not Zed2003-12-101-1/+3 * shared object looks for wrong mo file"Suresh Chandrasekharan2003-11-033-3/+3 * fix string duplication and refcounting problems.Larry Ewing2003-06-242-5/+7 * block the signal that got us here until we're done to stop an infiniteMike Kestner2003-05-171-0/+2 * Make sure the galview.xml file exists before trying to parse it withJeffrey Stedfast2003-05-171-3/+7 * Disable debugging messages.Ettore Perazzoli2003-05-162-2/+2 * guard against multiple destroysJP Rosevear2003-05-151-0/+3 * (gal_view_menus_unmerge): Guard againstEttore Perazzoli2003-05-141-1/+2 * Don't convert the label charset from UTF-8 into the locale charset.Jeffrey Stedfast2003-04-291-8/+4 * Try stat'ing the file before loading it with xmlParseFile() to avoidJeffrey Stedfast2003-04-251-4/+6 * Free the id when we're done with it.Hans Petter Jansson2003-04-161-0/+3 * fix padding and default size. Fixed warnings elsewhere in file.Mike Kestner2003-04-161-1/+7 * use stock buttons, remove desc frame. #if out the copy button. addMike Kestner2003-04-113-282/+229 * add ... to "Define Views" and "Save Custom View" menuitem labels.Mike Kestner2003-04-101-2/+2 * fix button order fix button order fix button orderMike Kestner2003-04-083-3/+3 * (set_state): Removed debugging message.Ettore Perazzoli2003-03-281-1/+1 * Use glib macro G_GNUC_FUNCTION instead of __FUNCTION__. Thank u, Ettore.Sanshao Jiang2003-03-222-6/+7 * Instead of using gtk_widget_unparent(), remove the widget from theHans Petter Jansson2003-03-183-3/+3 * use access() like camelMike Kestner2003-03-152-3/+8 * Use G_GNUC_FUNCTION instead of __FUNCTION__.Ettore Perazzoli2003-03-071-2/+2 * Remove unneeded MAP_DIR define. (gladedir): Remove. Defined inDan Winship2003-02-061-0/+1 * Here too.Jeffrey Stedfast2003-01-162-2/+2 * add the parent arg.Chris Toshok2002-12-195-10/+18 * protect against null instance_id's (bug#35540)Mike Kestner2002-12-141-1/+5 * check for null or blank view namesGilbert Fang2002-12-111-5/+9 * convert some GnomeDialog stuff to GtkDialog.Chris Toshok2002-11-173-13/+11 * GtkObject->Gobject and GnomeDialog->GtkDialog work.Chris Toshok2002-11-174-208/+252 * use GtkDialog's ::response instead of GnomeDialog's ::clicked.Chris Toshok2002-11-151-5/+5 * hrm, we shouldn't need to do this, but gtk_widget_show_all the customChris Toshok2002-11-151-0/+1 * more porting work.Chris Toshok2002-11-1414-1098/+971 * menus/gal-view-menus.h GObjectified.Ettore Perazzoli2002-11-142-40/+33 * start porting to GObject.Chris Toshok2002-11-1412-375/+235 * gnome-xml->libxmlNot Zed2002-11-132-3/+3 * First big sync of my GNOME 2 porting work (incomplete, and stillEttore Perazzoli2002-11-021-2/+2 * merging the gal-2 branch back to the trunk.Mike Kestner2002-11-0114-52/+64 * ref/unref the gvmMike Kestner2002-08-151-0/+4 * Edit the view after appending it to the model.Christopher James Lahey2002-06-171-0/+1 * Added this function to let you disable the define views dialog.Christopher James Lahey2002-06-052-41/+67 * Don't show this dialog more than once per collection.Christopher James Lahey2002-06-051-9/+32 * Added this function to set the user visible name of this collection.Christopher James Lahey2002-06-04