aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-08-26 13:11:38 +0800
committertobik <tobik@FreeBSD.org>2018-08-26 13:11:38 +0800
commitd06f4f2d4ccd0eebaf9a058910c84720055b30db (patch)
treee4a72b57a180ee8d0bcf9f3604f79501c3048b4d /games
parent2b69033add09be1675ac09246ab3650140172c1d (diff)
downloadfreebsd-ports-gnome-d06f4f2d4ccd0eebaf9a058910c84720055b30db.tar.gz
freebsd-ports-gnome-d06f4f2d4ccd0eebaf9a058910c84720055b30db.tar.zst
freebsd-ports-gnome-d06f4f2d4ccd0eebaf9a058910c84720055b30db.zip
games/vegastrike: Fix build with Clang 6
In file included from src/cmd/ai/aggressive.cpp:24: ./src/vs_random.h:132:48: error: non-constant-expression cannot be narrowed from type 'int' to 'unsigned int' in initializer list [-Wc++11-narrowing] static unsigned int mag01[2] = {0x0UL, MATRIX_A()}; ^~~~~~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/vegastrike-0.5.1.r1_13.log In file included from src/config_xml.cpp:27: In file included from ./src/xml_support.h:6: ... /usr/include/c++/v1/cstdlib:128:9: error: no member named 'rpl_realloc' in the global namespace using ::realloc; ~~^ ./config.h:444:17: note: expanded from macro 'realloc' #define realloc rpl_realloc ^ Second error is caused by failing configure checks and as a consequence the build assumes FreeBSD does not have realloc() etc.: In file included from conftest.cc:77: In file included from /usr/include/c++/v1/stdlib.h:94: /usr/include/stdlib.h:97:1: error: function declared '[[noreturn]]' after its first declaration _Noreturn void exit(int); ^
Diffstat (limited to 'games')
-rw-r--r--games/vegastrike/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index 67d11dc6f572..50ca6956120e 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= ${PY_BOOST} \
USES= dos2unix gmake localbase:ldflags openal:al pkgconfig python:2.7 \
tar:bzip2
+USE_CXXSTD= c++98
GNU_CONFIGURE= yes
USE_SDL= sdl
USE_GL= glut