aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-26 02:15:14 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-26 02:15:14 +0800
commitd61a812c7ec5e6763b8e4a7aa01f06fd25ab4171 (patch)
tree5f453a15e0b91dab983449a654236478c0b7f08a /games
parent0c880667e6eab94c49be9109357464473d19528f (diff)
downloadfreebsd-ports-gnome-d61a812c7ec5e6763b8e4a7aa01f06fd25ab4171.tar.gz
freebsd-ports-gnome-d61a812c7ec5e6763b8e4a7aa01f06fd25ab4171.tar.zst
freebsd-ports-gnome-d61a812c7ec5e6763b8e4a7aa01f06fd25ab4171.zip
- Change Makefile header, use my name and @FreeBSD.org email
- Use tar:bzip2 instead of USE_BZIP2=yes - Remove USE_GL glu - Add DOCS Option - Change Desktop entry file - Break lines around 80 characters - Remove not needed @${MKDIR} ${DATADIR}
Diffstat (limited to 'games')
-rw-r--r--games/asteroids3d/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/games/asteroids3d/Makefile b/games/asteroids3d/Makefile
index 13bb0d9923d2..b038ded12872 100644
--- a/games/asteroids3d/Makefile
+++ b/games/asteroids3d/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis <nemysis@gmx.ch>
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
# $FreeBSD$
PORTNAME= asteroids3d
@@ -16,22 +16,23 @@ COMMENT= First-person shooter blowing up asteroids in 3D space
LICENSE= GPLv2
-USE_BZIP2= yes
-USE_AUTOTOOLS= aclocal autoheader
+USES= tar:bzip2
+USE_AUTOTOOLS= aclocal autoheader
GNU_CONFIGURE= yes
CONFIGURE_ENV= with_gamesdir="${PREFIX}/bin" with_gamedatadir="${DATADIR}"
-USE_GL= glut glu
+USE_GL= glut
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= README.html
+OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
-DESKTOP_ENTRIES="Asteroids3D" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" false
+DESKTOP_ENTRIES="Asteroids3D" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
@@ -40,10 +41,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' ${WRKSRC}/autogen.sh
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/3d/3D/} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
- @${MKDIR} ${DATADIR}
- @(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" ${STAGEDIR}${DATADIR})
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/3d/3D/} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" \
+ ${STAGEDIR}${DATADIR})
.for s in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps