aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-09-04 02:48:07 +0800
committersat <sat@FreeBSD.org>2006-09-04 02:48:07 +0800
commitdbb8d08c8d42026693783ba5d4a8c38998caee53 (patch)
treed9860894068c334693d3a740dffacc1f4d603a81 /games
parent432ecc8857d4558047f8e62a181c81ad2f27a871 (diff)
downloadfreebsd-ports-gnome-dbb8d08c8d42026693783ba5d4a8c38998caee53.tar.gz
freebsd-ports-gnome-dbb8d08c8d42026693783ba5d4a8c38998caee53.tar.zst
freebsd-ports-gnome-dbb8d08c8d42026693783ba5d4a8c38998caee53.zip
- Depend on libglut
- Respect CFLAGS - Bump portrevision PR: ports/102792 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games')
-rw-r--r--games/palomino/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
index cb1911e607d7..a734e564a5bf 100644
--- a/games/palomino/Makefile
+++ b/games/palomino/Makefile
@@ -7,6 +7,7 @@
PORTNAME= palomino
PORTVERSION= 20060827
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}-sim
@@ -15,6 +16,8 @@ DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= Action flight simulator with its own 3D engine
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_ZIP= yes
USE_PYTHON= yes
USE_GL= yes
@@ -25,8 +28,10 @@ INSTALL_WRKSRC= ${WRKSRC}/${PORTNAME}/game/pony
MAKEFILE= GNUmakefile
post-patch:
- ${REINPLACE_CMD} -Ee 's!(string installDir = ).*$$!\1"${DATADIR}/";!' \
+ @${REINPLACE_CMD} -Ee 's!(string installDir = ).*$$!\1"${DATADIR}/";!' \
-e 's!../game/!!' ${WRKSRC}/palomino/game/pony/src/game_pony_init.cc
+ @${REINPLACE_CMD} -Ee 's!(CC_FLAGS.*:=)!\1 $$(CFLAGS)!' ${WRKSRC}/gfx/GNUmakefile_common
+ @${REINPLACE_CMD} -Ee 's!(-O[0-9s]?|-funroll-loops|-fno-inline)!!g' ${WRKSRC}/gfx/tools/cc-config.sh
do-install:
@${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/out/palomino ${PREFIX}/bin/