aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-11-06 04:13:48 +0800
committerlinimon <linimon@FreeBSD.org>2018-11-06 04:13:48 +0800
commitf70a63af44a928948e7ea6085387d72d48a21f90 (patch)
treed8d37ef067cc1b058dae40d00f87e33198975986 /games
parent0ec1ae87a2b10c504a33b64a815311c6a96dd91b (diff)
downloadfreebsd-ports-gnome-f70a63af44a928948e7ea6085387d72d48a21f90.tar.gz
freebsd-ports-gnome-f70a63af44a928948e7ea6085387d72d48a21f90.tar.zst
freebsd-ports-gnome-f70a63af44a928948e7ea6085387d72d48a21f90.zip
Because of linking to libgraphite2, a C++11-compatible compiler is necessary.
Also, GCC needed an additional include. While here, pet portlint. PR: 232003 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'games')
-rw-r--r--games/gtkradiant/Makefile6
-rw-r--r--games/gtkradiant/files/patch-libs_typesystem.h10
2 files changed, 13 insertions, 3 deletions
diff --git a/games/gtkradiant/Makefile b/games/gtkradiant/Makefile
index 18e65d9b3e20..839f3e5a2a6b 100644
--- a/games/gtkradiant/Makefile
+++ b/games/gtkradiant/Makefile
@@ -16,11 +16,13 @@ COMMENT= Map editor for FPS games, by id Software and Loki Software
LICENSE= GPLv2
+BROKEN_aarch64= Fails to link: error: ldd command returned with exit code 256
+
LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libmhash.so:security/mhash \
libpng.so:graphics/png
-USES= pkgconfig python:2.7,build scons zip
+USES= compiler:c++11-lang gnome pkgconfig python:2.7,build scons zip
USE_GNOME= gtk20 libxml2
MAKE_ARGS= ${MAKE_ENV} BUILD=release
SSP_UNSAFE= yes
@@ -30,8 +32,6 @@ WRKSRC= ${WRKDIR}/GPL/GtkRadiant
SUB_FILES= ${PORTNAME}
-BROKEN_aarch64= Fails to link: error: ldd command returned with exit code 256
-
post-patch:
@${GREP} -Rl 'defined[[:blank:]]*([[:blank:]]*__linux__[[:blank:]]*) || defined[[:blank:]]*([[:blank:]]*__APPLE__[[:blank:]]*)' ${WRKSRC} | \
${XARGS} ${REINPLACE_CMD} -e \
diff --git a/games/gtkradiant/files/patch-libs_typesystem.h b/games/gtkradiant/files/patch-libs_typesystem.h
new file mode 100644
index 000000000000..89941dfdbdb6
--- /dev/null
+++ b/games/gtkradiant/files/patch-libs_typesystem.h
@@ -0,0 +1,10 @@
+--- libs/typesystem.h.orig 2018-10-06 15:03:20 UTC
++++ libs/typesystem.h
+@@ -24,6 +24,7 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
+
+
+ #include <list>
++#include <memory>
+ #include "generic/callback.h"
+ #include "generic/static.h"
+