aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-22 14:23:44 +0800
committeredwin <edwin@FreeBSD.org>2005-11-22 14:23:44 +0800
commitfc57cf2994bfd078d4d2687a7f99a3533bf9daf9 (patch)
tree38b5ef4f0fb31c7f66d725b3bf267b20dd5235ae /games
parentce6d35ff56207079735045c621c5879125f84efd (diff)
downloadfreebsd-ports-gnome-fc57cf2994bfd078d4d2687a7f99a3533bf9daf9.tar.gz
freebsd-ports-gnome-fc57cf2994bfd078d4d2687a7f99a3533bf9daf9.tar.zst
freebsd-ports-gnome-fc57cf2994bfd078d4d2687a7f99a3533bf9daf9.zip
[UPDATE] games/q3server-ra3: integrate with "quake3-data", rename to "quake3-ra3", update to 1.76
Changes: * Update to version 1.76. * Rename to "quake3-ra3" (also rename port directory). * Integrate with "quake3-data". PR: ports/86190 Submitted by: Alejandro Pulver <alejandro@varnet.biz> Approved by: maintainer timeout
Diffstat (limited to 'games')
-rw-r--r--games/quake3-ra3/Makefile101
-rw-r--r--games/quake3-ra3/distinfo6
-rw-r--r--games/quake3-ra3/pkg-descr7
-rw-r--r--games/quake3-ra3/pkg-plist69
4 files changed, 60 insertions, 123 deletions
diff --git a/games/quake3-ra3/Makefile b/games/quake3-ra3/Makefile
index 651707b7893b..f8fa38a03324 100644
--- a/games/quake3-ra3/Makefile
+++ b/games/quake3-ra3/Makefile
@@ -5,96 +5,31 @@
# $FreeBSD$
#
-PORTNAME?= ra3
-PORTVERSION?= 1.65
-CATEGORIES= games linux
-MASTER_SITES?= http://gamefiles.blueyonder.co.uk/blueyondergames/quake3arena/modifications/rocketarena/patches/linux/ \
- http://mir2.ovh.net/ftp.planetquake3.net/modifications/rocketarena3/
-PKGNAMEPREFIX= q3server-
-.ifndef(DISTNAME)
-DISTFILES?= ${PORTNAME}${PORTVERSION:S/.//}cl.zip \
- ${PORTNAME}${PORTVERSION:S/.//}sv.zip
-.endif
-
-MAINTAINER?= pat@FreeBSD.org
-COMMENT?= Quake III Arena Mod: Rocket Arena 3 for Linux
+PORTNAME= ra3
+PORTVERSION= 1.76
+CATEGORIES= games
+MASTER_SITES= ftp.clanbase.com/pub/ \
+ ftp.mirrors.degnet.de/pub/misc/PlanetQuake3.net/modifications/rocketarena3/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
-RUN_DEPENDS= ${LOCALBASE}/games/quake3/q3ded:${Q3SERVER_PORT}
+MAINTAINER= pat@FreeBSD.org
+COMMENT= Quake III Arena Mod: Rocket Arena 3
-ONLY_FOR_ARCHS= i386
-USE_LINUX= yes
-USE_PERL5= yes
-NO_CDROM= "Size; the data set is much too big"
-NO_BUILD= yes
-.if (${PORTNAME}==ra3)
WRKSRC= ${WRKDIR}/arena
-.endif
-.ifndef(DONT_USE_ZIP)
-USE_ZIP= yes
-.endif
-.if defined(HAS_WIERDPATCHES)
-EXTRACT_ONLY?= ${PORTNAME}${PORTVERSION:S/.//}cl.zip
-.endif
-.ifndef(NO_WRKSUBDIR)
-Q3SUBDIR?= ${WRKSRC:T}
-WRKSRC?= ${WRKDIR}/${PORTNAME}
-.else
-Q3SUBDIR?= ${PORTNAME}
-.endif
-Q3DIR= games/quake3/${Q3SUBDIR}/
-
-PLIST_SUB+= Q3DIR="${Q3DIR}"
-INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
-
-Q3SERVER_PORT= ${.CURDIR}/../q3server
-PKGMESSAGE!= cd ${Q3SERVER_PORT} && ${MAKE} -V PKGMESSAGE
+USE_ZIP= yes
+NO_BUILD= yes
-.if defined(HAS_WIERDPATCHES) && defined(DISTFILES)
-post-extract:
-.for files in ${DISTFILES:S/${EXTRACT_ONLY}//}
- @cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
- ${DISTDIR}/${DIST_SUBDIR}/${files}
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in *.cfg *.pk3
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
.endif
-pre-patch:
-# remove trailing ^M
- @${FIND} -E ${WRKSRC} -type f \
- -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|url)" \
- -exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
-
-# Parses PLIST
-# Contributed by <lioux@FreeBSD.org>
-do-install: install-parse-plist install-scripts
-
-install-parse-plist: generate-plist
- @${PERL} -e 'open(FHANDLER,"${TMPPLIST}");' \
- -e 'open(FDIR,">${WRKDIR}/dirs.sh.tmp");' \
- -e 'open(FFILES,">${WRKDIR}/files.sh");' \
- -e 'while (!eof(FHANDLER)) {' \
- -e 'chop($$file = <FHANDLER>);' \
- -e '$$dir = $$file_partial = $$file;' \
- -e '$$file_partial =~ s!^${Q3DIR}!!;' \
- -e 'print FDIR "${INSTALL_DIR}", \
- " ", "\"${PREFIX}/$$dir\"", \
- "\n" if $$dir =~ s!(^\@dirrm\s+)!!;' \
- -e 'print FFILES "${INSTALL_DATA}", \
- " ", "\"${WRKSRC}/$$file_partial\"", \
- " ", "\"${PREFIX}/$$file\"", \
- "\n" if ($$file !~ m!^\@!);' \
- -e '}' \
- -e 'close(FFILES);' \
- -e 'close(FDIR);' \
- -e 'close(FHANDLER);'
-
-install-scripts:
- @${INSTALL_DIR} ${PREFIX}/${Q3DIR}
- @${SORT} ${WRKDIR}/dirs.sh.tmp > ${WRKDIR}/dirs.sh
- @${SH} ${WRKDIR}/dirs.sh
- @${SH} ${WRKDIR}/files.sh
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+.include "${.CURDIR}/../quake3-data/Makefile.include"
.include <bsd.port.mk>
diff --git a/games/quake3-ra3/distinfo b/games/quake3-ra3/distinfo
index 382493c35701..0a030a9d94bd 100644
--- a/games/quake3-ra3/distinfo
+++ b/games/quake3-ra3/distinfo
@@ -1,4 +1,2 @@
-MD5 (ra3165cl.zip) = e06b9e61ce1f64a6cd41e89577ac4671
-SIZE (ra3165cl.zip) = 106817308
-MD5 (ra3165sv.zip) = d85281d1ca468e61fd2ae35ddc58dce9
-SIZE (ra3165sv.zip) = 388538
+MD5 (ra3176.zip) = a055f7608e49b4ebddaed09d2f89d58d
+SIZE (ra3176.zip) = 138018848
diff --git a/games/quake3-ra3/pkg-descr b/games/quake3-ra3/pkg-descr
index 137c33a0263b..943ce9720f0f 100644
--- a/games/quake3-ra3/pkg-descr
+++ b/games/quake3-ra3/pkg-descr
@@ -1,6 +1,7 @@
-This package contains all of the items you'll need to run a
-Quake III Arena dedicated server with Rocket Arena 3 mod
-under FreeBSD with Linux emulation.
+Rocket Arena matches are played in "arenas." Each map may have one or more
+arenas in it. When you connect to a server, you need select an arena and then
+either create or join a team. Once you are in the arena you will be put in
+line to fight.
WWW: http://www.planetquake.com/arena/
diff --git a/games/quake3-ra3/pkg-plist b/games/quake3-ra3/pkg-plist
index d495702bde57..ea35f928dac5 100644
--- a/games/quake3-ra3/pkg-plist
+++ b/games/quake3-ra3/pkg-plist
@@ -1,33 +1,36 @@
-%%Q3DIR%%arena.cfg
-%%Q3DIR%%browser.pk3
-%%Q3DIR%%gfx.pk3
-%%Q3DIR%%icons.pk3
-%%Q3DIR%%menu.pk3
-%%Q3DIR%%qagamei386.so
-%%Q3DIR%%qagamex86.dll
-%%Q3DIR%%ra3_server.bat
-%%Q3DIR%%ra3_server.sh
-%%Q3DIR%%ra3map1.pk3
-%%Q3DIR%%ra3map10.pk3
-%%Q3DIR%%ra3map11.pk3
-%%Q3DIR%%ra3map12.pk3
-%%Q3DIR%%ra3map13.pk3
-%%Q3DIR%%ra3map14.pk3
-%%Q3DIR%%ra3map15.pk3
-%%Q3DIR%%ra3map16.pk3
-%%Q3DIR%%ra3map2.pk3
-%%Q3DIR%%ra3map3.pk3
-%%Q3DIR%%ra3map4.pk3
-%%Q3DIR%%ra3map5.pk3
-%%Q3DIR%%ra3map6.pk3
-%%Q3DIR%%ra3map7.pk3
-%%Q3DIR%%ra3map8.pk3
-%%Q3DIR%%ra3map9.pk3
-%%PORTDOCS%%%%Q3DIR%%readme.txt
-%%PORTDOCS%%%%Q3DIR%%readsrv.txt
-%%Q3DIR%%scripts.pk3
-%%Q3DIR%%server.cfg
-%%Q3DIR%%sounds.pk3
-%%Q3DIR%%textures.pk3
-%%Q3DIR%%vm.pk3
-@unexec rmdir %D/%%Q3DIR%% 2>/dev/null || echo "If you are permanently removing this port, you should do a ``rm -Rf ${PKG_PREFIX}/%%Q3DIR%%`` to remove any configuration files left" | fmt
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/readsrv.txt
+%%DATADIR%%/arena.cfg
+%%DATADIR%%/browser.pk3
+%%DATADIR%%/gfx.pk3
+%%DATADIR%%/icons.pk3
+%%DATADIR%%/menu.pk3
+%%DATADIR%%/models.pk3
+%%DATADIR%%/pb_cvars.cfg
+%%DATADIR%%/ra3map1.pk3
+%%DATADIR%%/ra3map10.pk3
+%%DATADIR%%/ra3map11.pk3
+%%DATADIR%%/ra3map12.pk3
+%%DATADIR%%/ra3map13.pk3
+%%DATADIR%%/ra3map14.pk3
+%%DATADIR%%/ra3map15.pk3
+%%DATADIR%%/ra3map16.pk3
+%%DATADIR%%/ra3map17.pk3
+%%DATADIR%%/ra3map18.pk3
+%%DATADIR%%/ra3map19.pk3
+%%DATADIR%%/ra3map2.pk3
+%%DATADIR%%/ra3map20.pk3
+%%DATADIR%%/ra3map3.pk3
+%%DATADIR%%/ra3map4.pk3
+%%DATADIR%%/ra3map5.pk3
+%%DATADIR%%/ra3map6.pk3
+%%DATADIR%%/ra3map7.pk3
+%%DATADIR%%/ra3map8.pk3
+%%DATADIR%%/ra3map9.pk3
+%%DATADIR%%/scripts.pk3
+%%DATADIR%%/server.cfg
+%%DATADIR%%/sounds.pk3
+%%DATADIR%%/textures.pk3
+%%DATADIR%%/vm.pk3
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%