aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2018-02-02 20:12:31 +0800
committermartymac <martymac@FreeBSD.org>2018-02-02 20:12:31 +0800
commitfcdc76b75c8378acf1618f72507693d6059ceba4 (patch)
treea60f5d30cfe57c179124d4c48f53d9d3d5954b8d /games
parent683fb14517eebe15935284eb528baa333ef19ccb (diff)
downloadfreebsd-ports-gnome-fcdc76b75c8378acf1618f72507693d6059ceba4.tar.gz
freebsd-ports-gnome-fcdc76b75c8378acf1618f72507693d6059ceba4.tar.zst
freebsd-ports-gnome-fcdc76b75c8378acf1618f72507693d6059ceba4.zip
Fix build on -CURRENT
Diffstat (limited to 'games')
-rw-r--r--games/briquolo/Makefile2
-rw-r--r--games/briquolo/files/patch-Constante.h13
-rw-r--r--games/briquolo/files/patch-src-Constante.cpp13
-rw-r--r--games/briquolo/files/patch-src-ElementCollision.h11
-rw-r--r--games/briquolo/files/patch-src-MOGL-MOGL_PoliceTTF.h28
5 files changed, 64 insertions, 3 deletions
diff --git a/games/briquolo/Makefile b/games/briquolo/Makefile
index 2b8dafb6408e..56060342ae8a 100644
--- a/games/briquolo/Makefile
+++ b/games/briquolo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= briquolo
PORTVERSION= 0.5.7
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= games
MASTER_SITES= http://briquolo.free.fr/download/
diff --git a/games/briquolo/files/patch-Constante.h b/games/briquolo/files/patch-Constante.h
new file mode 100644
index 000000000000..7a263ec25f9e
--- /dev/null
+++ b/games/briquolo/files/patch-Constante.h
@@ -0,0 +1,13 @@
+Fix typo
+
+--- src/Constante.h.orig 2018-01-29 22:01:42.080765000 +0100
++++ src/Constante.h 2018-01-29 22:01:53.560724000 +0100
+@@ -20,7 +20,7 @@
+ *
+ *****************************************************************************/
+ #ifndef _CONSTANTE
+-#define _CONTANSTE
++#define _CONSTANTE
+
+ #include <string>
+
diff --git a/games/briquolo/files/patch-src-Constante.cpp b/games/briquolo/files/patch-src-Constante.cpp
index 94c0377ebf4a..cbc3d5a63e13 100644
--- a/games/briquolo/files/patch-src-Constante.cpp
+++ b/games/briquolo/files/patch-src-Constante.cpp
@@ -1,5 +1,5 @@
---- src/Constante.cpp.orig 2013-10-29 17:15:21.000000000 +0100
-+++ src/Constante.cpp 2013-10-29 17:18:30.000000000 +0100
+--- ./src/Constante.cpp.orig 2008-03-22 10:40:33.000000000 +0100
++++ ./src/Constante.cpp 2018-01-29 22:09:08.069039000 +0100
@@ -32,6 +32,7 @@
#define WIN32_LEAN_AND_MEAN
#include <windows.h>
@@ -8,3 +8,12 @@
#include <unistd.h>
#endif
+@@ -102,7 +103,7 @@
+ #else
+
+ string dir1(getenv("HOME"));
+- string dir2("/."PACKAGE);
++ string dir2("/." PACKAGE);
+ _Local=dir1+dir2;
+
+ _NumVersion=VERSION;
diff --git a/games/briquolo/files/patch-src-ElementCollision.h b/games/briquolo/files/patch-src-ElementCollision.h
new file mode 100644
index 000000000000..48f0ee661183
--- /dev/null
+++ b/games/briquolo/files/patch-src-ElementCollision.h
@@ -0,0 +1,11 @@
+--- ./src/ElementCollision.h.orig 2018-01-29 21:56:58.057957000 +0100
++++ ./src/ElementCollision.h 2018-01-29 22:04:08.902625000 +0100
+@@ -30,7 +30,7 @@
+ using namespace std;
+
+ class Balle;
+-class Struct_Collision;
++struct Struct_Collision;
+
+ class Point
+ {
diff --git a/games/briquolo/files/patch-src-MOGL-MOGL_PoliceTTF.h b/games/briquolo/files/patch-src-MOGL-MOGL_PoliceTTF.h
new file mode 100644
index 000000000000..17a982a4c1d2
--- /dev/null
+++ b/games/briquolo/files/patch-src-MOGL-MOGL_PoliceTTF.h
@@ -0,0 +1,28 @@
+Fix types passed to SDL_Rect structure (SDL 1.2)
+
+--- src/MOGL/MOGL_PoliceTTF.h.orig 2018-02-01 22:04:52.124355000 +0100
++++ src/MOGL/MOGL_PoliceTTF.h 2018-02-01 22:06:25.875693000 +0100
+@@ -42,10 +42,10 @@
+ {
+ GLuint TextureName;
+ Uint16 carac;
+- unsigned int x1;
+- unsigned int y1;
+- unsigned int x2;
+- unsigned int y2;
++ Sint16 x1;
++ Sint16 y1;
++ int x2;
++ int y2;
+ };
+
+ struct MOGL_Struct_TextureCarac
+@@ -141,7 +141,7 @@
+ MOGL_Struct_Carac * _Caracteres;
+ MOGL_Struct_Carac * (_Correspondance[256-32]);
+
+- unsigned int _LastTextureX, _LastTextureY;
++ Sint16 _LastTextureX, _LastTextureY;
+ unsigned int maxHeightCarac;
+ MOGL_Map_Carac _MapCarac;
+ MOGL_Vector_TextureName _VectorTextureName;