aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-12-07 01:04:31 +0800
committerthierry <thierry@FreeBSD.org>2004-12-07 01:04:31 +0800
commitfea75a918e8cacdad8d00a020a8cf730819b0b54 (patch)
treecbc73eb7db945da34b85343199caf1cd62b20a90 /games
parent64978cb9d8255d04797d5aee55ee695fc3c3a52a (diff)
downloadfreebsd-ports-gnome-fea75a918e8cacdad8d00a020a8cf730819b0b54.tar.gz
freebsd-ports-gnome-fea75a918e8cacdad8d00a020a8cf730819b0b54.tar.zst
freebsd-ports-gnome-fea75a918e8cacdad8d00a020a8cf730819b0b54.zip
- fix plist by using libtool 1.5 [1]
- update my address - switch from USE_MESA to USE_GL. Reported by: http://pointyhat.freebsd.org/errorlogs/i386-6-latest-logs/extras.html [1]
Diffstat (limited to 'games')
-rw-r--r--games/pinball/Makefile10
-rw-r--r--games/pinball/pkg-plist6
2 files changed, 8 insertions, 8 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 65a2fa2b0b1f..01e4383f852c 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -7,18 +7,18 @@
PORTNAME= pinball
PORTVERSION= 0.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= thierry@pompo.net
+MAINTAINER= thierry@FreeBSD.org
COMMENT= Emilia Pinball is a free pinball game
.if !defined(WITH_ALLEGRO)
BUILD_DEPENDS= ${SDL_CONFIG}:${PORTSDIR}/devel/sdl12
.else
-BROKEN= "support with Allegro is (temporarily) broken as of version 0.31"
+BROKEN= "support with Allegro is (temporarily) broken as of version 0.3.1"
BUILD_DEPENDS= ${ALLEGRO_CONFIG}:${PORTSDIR}/devel/allegro
LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
.endif
@@ -26,8 +26,8 @@ LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
USE_SDL= image mixer sdl
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_MESA= yes
-USE_LIBTOOL_VER=13
+USE_GL= yes
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/games/pinball/pkg-plist b/games/pinball/pkg-plist
index ef3e763cd000..8fe16b0fbbbf 100644
--- a/games/pinball/pkg-plist
+++ b/games/pinball/pkg-plist
@@ -62,13 +62,10 @@ include/pinball/TextureUtil.h
include/pinball/TransformVisitor.h
include/pinball/Visitor.h
include/pinball/pinconfig.h
-lib/pinball/libModuleProfessor.a
lib/pinball/libModuleProfessor.so
lib/pinball/libModuleProfessor.so.0
-lib/pinball/libModuleTest.a
lib/pinball/libModuleTest.so
lib/pinball/libModuleTest.so.0
-lib/pinball/libModuleTux.a
lib/pinball/libModuleTux.so
lib/pinball/libModuleTux.so.0
lib/pinball/libemilia_addon.a
@@ -122,3 +119,6 @@ lib/pinball/libemilia_pin.a
@dirrm %%DATADIR%%/tux
@dirrm %%DATADIR%%/professor
@dirrm %%DATADIR%%
+@unexec rm -f %D/lib/pinball/libModuleTux.la
+@unexec rm -f %D/lib/pinball/libModuleProfessor.la
+@unexec rm -f %D/lib/pinball/libModuleTest.la