aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-01 17:45:44 +0800
committertobik <tobik@FreeBSD.org>2018-09-01 17:45:44 +0800
commitff8d0fcdb83bec59cf71cb7e4cbf9a5fb824878e (patch)
tree02b56d2b887adcc1ce188ac55ccfdfe2558b3aff /games
parent8362f34b16bb4b7d83fab8d9c57909153a6ba67f (diff)
downloadfreebsd-ports-gnome-ff8d0fcdb83bec59cf71cb7e4cbf9a5fb824878e.tar.gz
freebsd-ports-gnome-ff8d0fcdb83bec59cf71cb7e4cbf9a5fb824878e.tar.zst
freebsd-ports-gnome-ff8d0fcdb83bec59cf71cb7e4cbf9a5fb824878e.zip
games/flying: Fix build with Clang 6
./pointer.h:7:4: error: constant expression evaluates to 224 which cannot be narrowed to type 'char' [-Wc++11-narrowing] 0xe0, 0x0e, 0xc0, 0x07, 0x80, 0x03, 0xc0, 0x07, 0xe0, 0x0e, 0x70, 0x1c, ^~~~ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475478_s336801/logs/errors/flying-6.20_3.log
Diffstat (limited to 'games')
-rw-r--r--games/flying/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/flying/Makefile b/games/flying/Makefile
index 2a0d2dbd5e2c..139db0001b76 100644
--- a/games/flying/Makefile
+++ b/games/flying/Makefile
@@ -10,8 +10,12 @@ MASTER_SITES= SUNSITE/games/arcade
MAINTAINER= ports@FreeBSD.org
COMMENT= Pool/snooker/billiards/carrom/etc game
-USES= imake tar:tgz
+USES= compiler imake tar:tgz
USE_XORG= x11
PLIST_FILES= bin/flying man/man1/flying.1.gz
+# build ignores CXXFLAGS, imake gets in the way of fixing it
+CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
+CFLAGS_clang= -Wno-c++11-narrowing
+
.include <bsd.port.mk>