aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-11 17:36:43 +0800
committeraz <az@FreeBSD.org>2013-09-11 17:36:43 +0800
commit1407e95251635a835c8e1f4eb2e42b931c95f6bc (patch)
tree4147b61d5aaf43eadd75d4949ce6a77761ed9b5b /games
parentf8b9d36c914c82d7b80560d88765d1d87b6611fc (diff)
downloadfreebsd-ports-gnome-1407e95251635a835c8e1f4eb2e42b931c95f6bc.tar.gz
freebsd-ports-gnome-1407e95251635a835c8e1f4eb2e42b931c95f6bc.tar.zst
freebsd-ports-gnome-1407e95251635a835c8e1f4eb2e42b931c95f6bc.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'games')
-rw-r--r--games/asciiquarium/Makefile8
-rw-r--r--games/cowsay/Makefile8
-rw-r--r--games/hlstatsx/Makefile3
-rw-r--r--games/ifm/Makefile8
-rw-r--r--games/oolite/Makefile9
-rw-r--r--games/openmortal/Makefile2
-rw-r--r--games/rfksay/Makefile9
-rw-r--r--games/thevalley/Makefile8
8 files changed, 17 insertions, 38 deletions
diff --git a/games/asciiquarium/Makefile b/games/asciiquarium/Makefile
index 7780806f0b0e..0eb88c16ec55 100644
--- a/games/asciiquarium/Makefile
+++ b/games/asciiquarium/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: asciiquarium
-# Date created: 16 Sep 2005
-# Whom: Max Khon <fjoe@FreeBSD.org>
-#
+# Created by: Max Khon <fjoe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= asciiquarium
PORTVERSION= 1.0
@@ -18,7 +14,7 @@ RUN_DEPENDS= p5-Term-Animation>=0:${PORTSDIR}/devel/p5-Term-Animation
WRKSRC= ${WRKDIR}/${DISTNAME}
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/asciiquarium
do-install:
diff --git a/games/cowsay/Makefile b/games/cowsay/Makefile
index 40a6d1d8a822..f68e0befbdf6 100644
--- a/games/cowsay/Makefile
+++ b/games/cowsay/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cowsay
-# Date created: 01 Sep 2000
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
+# Created by: Kris Kennaway <kris@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cowsay
PORTVERSION= 3.03
@@ -14,7 +10,7 @@ MASTER_SITES= http://www.nog.net/~tony/warez/
MAINTAINER= wxs@FreeBSD.org
COMMENT= Configurable talking characters in ASCII art
-USE_PERL5= yes
+USES= perl5
NO_BUILD= # defined
diff --git a/games/hlstatsx/Makefile b/games/hlstatsx/Makefile
index a5bd1b83f1f2..ca154b21a9d3 100644
--- a/games/hlstatsx/Makefile
+++ b/games/hlstatsx/Makefile
@@ -13,7 +13,8 @@ COMMENT= Real-time player and clan rankings and statistics for HL2 and mods
NO_BUILD= yes
USE_APACHE_RUN= 22+
USE_PHP= gd mysql
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_ZIP= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/ifm/Makefile b/games/ifm/Makefile
index 08d433e13312..4858301fe35d 100644
--- a/games/ifm/Makefile
+++ b/games/ifm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ifm
-# Date created: Mon Oct 12 12:32:07 EDT 1998
-# Whom: Dave Chapeskie <dchapes@ddm.on.ca>
-#
+# Created by: Dave Chapeskie <dchapes@ddm.on.ca>
# $FreeBSD$
-#
PORTNAME= ifm
PORTVERSION= 5.4
@@ -16,7 +12,7 @@ COMMENT= Interactive Fiction mapper and walkthrough generator
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
-USE_PERL5= yes
+USES= perl5
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= WISH=${LOCALBASE}/bin/wish8.4
diff --git a/games/oolite/Makefile b/games/oolite/Makefile
index 7e62b538c2e3..d0fde3becfbf 100644
--- a/games/oolite/Makefile
+++ b/games/oolite/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: oolite
-# Date created: 04 Oct 2005
-# Whom: Andriy Gapon <avg@icyb.net.ua>
-#
+# Created by: Andriy Gapon <avg@icyb.net.ua>
# $FreeBSD$
-#
PORTNAME= oolite
PORTVERSION= 1.76
@@ -37,7 +33,8 @@ USE_GNUSTEP_BUILD= yes
USE_MAKEFILE= yes
USE_GMAKE= yes
ALL_TARGET= release-deployment
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
USE_PYTHON_BUILD= yes
SUB_FILES= pkg-message
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
index 9828a4b74f46..2f333147874d 100644
--- a/games/openmortal/Makefile
+++ b/games/openmortal/Makefile
@@ -13,7 +13,7 @@ COMMENT= A parody of the once popular coin-up fighting game, Mortal Kombat
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
USE_SDL= mixer image sdl net
USE_DOS2UNIX= src/gfx.cpp
diff --git a/games/rfksay/Makefile b/games/rfksay/Makefile
index f53eddb96795..920aa9ac43d4 100644
--- a/games/rfksay/Makefile
+++ b/games/rfksay/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: rfksay
-# Date created: Thu Jul 18, 2002
-# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
-#
+# Created by: Michael L. Hostbaek (mich@freebsdcluster.org)
# $FreeBSD$
-#
PORTNAME= rfksay
PORTVERSION= 0.1
@@ -15,7 +10,7 @@ DISTNAME= rfksay
MAINTAINER= mich@FreeBSD.org
COMMENT= Generates a kitten finding robot with a text bubble
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/thevalley/Makefile b/games/thevalley/Makefile
index af8e984371dd..e973a950eb38 100644
--- a/games/thevalley/Makefile
+++ b/games/thevalley/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: thevalley
-# Date created: 28 March 2004
-# Whom: Edwin Groothuis
-#
+# Created by: Edwin Groothuis
# $FreeBSD$
PORTNAME= thevalley
@@ -18,7 +15,8 @@ USE_AUTOTOOLS= libtool
HAS_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_SDL= sdl
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CXXFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include