aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-12-01 19:07:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-12-01 19:07:29 +0800
commit34682c7476bef1f72b3edf8ffdf305c9174cccea (patch)
treefaf84948c6b6a79fbd5b1f02333f76fe97d1068b /games
parentb1b3cccefb1dc8fc7cdd3ac888250d0ae1f9895c (diff)
downloadfreebsd-ports-gnome-34682c7476bef1f72b3edf8ffdf305c9174cccea.tar.gz
freebsd-ports-gnome-34682c7476bef1f72b3edf8ffdf305c9174cccea.tar.zst
freebsd-ports-gnome-34682c7476bef1f72b3edf8ffdf305c9174cccea.zip
- Add LICENSE_FILE
- Switch to USES=localbase - Don't install license with docs - Cosmetic fixes
Diffstat (limited to 'games')
-rw-r--r--games/trophy/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index 7ed677cdd1c1..1274635fd590 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -11,25 +11,23 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Single player racing game
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libclanCore.so:devel/clanlib1
-USES= pkgconfig
-
+USES= pkgconfig localbase
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-PORTDOCS= AUTHORS COPYING ChangeLog README TODO
+PORTDOCS= AUTHORS ChangeLog README TODO
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e "/^icondir =/s,icons,pixmaps," \
+ @${REINPLACE_CMD} -e "/^icondir =/s,icons,pixmaps," \
${WRKSRC}/resources/Makefile.in
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR} && \
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>