aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-05-12 14:54:07 +0800
committerijliao <ijliao@FreeBSD.org>2003-05-12 14:54:07 +0800
commit459844a16c30d9c36ecb04a3487cb422c1bb6928 (patch)
tree45322eb8e7115ac5bb3e07f4c3b75d7eb1bbd675 /games
parentd92ce99b9fb7d839bd4bcaace23b60c8dcbfb21e (diff)
downloadfreebsd-ports-gnome-459844a16c30d9c36ecb04a3487cb422c1bb6928.tar.gz
freebsd-ports-gnome-459844a16c30d9c36ecb04a3487cb422c1bb6928.tar.zst
freebsd-ports-gnome-459844a16c30d9c36ecb04a3487cb422c1bb6928.zip
utilize USE_GETOPT_LONG
PR: 51852 Submitted by: Ports Fury
Diffstat (limited to 'games')
-rw-r--r--games/afternoonstalker/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/afternoonstalker/Makefile b/games/afternoonstalker/Makefile
index 734930240ae5..f1c5eb9086a6 100644
--- a/games/afternoonstalker/Makefile
+++ b/games/afternoonstalker/Makefile
@@ -14,16 +14,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A clone of the 1981 Night Stalker video game
LIB_DEPENDS= gengameng.4:${PORTSDIR}/devel/gengameng \
- SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+USE_GETOPT_LONG= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CXX="${CXX} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt"
-CONFIGURE_TARGET= # none
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
MAN6= afternoonstalker.6
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
post-patch:
${REINPLACE_CMD} "s@SDL/@SDL11/@g" ${WRKSRC}/configure \
${WRKSRC}/src/SoundMixer.h