aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-09-23 16:58:57 +0800
committerdanfe <danfe@FreeBSD.org>2004-09-23 16:58:57 +0800
commit4ecec35452897f1e5c4e191ee68587be2c832eb7 (patch)
treeb2e8cd0078b041eee54f78de6768a75d0f8818bc /games
parent8b3b894ce7c6da527970b45a17f4d03de867d1db (diff)
downloadfreebsd-ports-gnome-4ecec35452897f1e5c4e191ee68587be2c832eb7.tar.gz
freebsd-ports-gnome-4ecec35452897f1e5c4e191ee68587be2c832eb7.tar.zst
freebsd-ports-gnome-4ecec35452897f1e5c4e191ee68587be2c832eb7.zip
Unbreak (fix build on 5.X and -CURRENT).
Reported by: kris Approved by: portmgr (marcus), fjoe (mentor, implicit), maintainer
Diffstat (limited to 'games')
-rw-r--r--games/cube/Makefile8
-rw-r--r--games/cube/files/patch-source::src::tools.h19
2 files changed, 20 insertions, 7 deletions
diff --git a/games/cube/Makefile b/games/cube/Makefile
index a1e9d6b375fb..79636c5e0cc6 100644
--- a/games/cube/Makefile
+++ b/games/cube/Makefile
@@ -27,12 +27,6 @@ BUILD_WRKSRC= ${WRKSRC}/source/src
DATADIR= ${PREFIX}/share/cube
CONFIGURE_WRKSRC= ${WRKSRC}/source/enet
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-extract:
@ ${UNZIP_CMD} -a -q -o ${WRKSRC}/source/${DISTNAME}_src.zip -d ${WRKSRC}/source/
@@ -53,4 +47,4 @@ do-install:
${CP} -Rp ${WRKSRC}/data ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/autoexec.cfg ${DATADIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/cube/files/patch-source::src::tools.h b/games/cube/files/patch-source::src::tools.h
new file mode 100644
index 000000000000..6978be65dccd
--- /dev/null
+++ b/games/cube/files/patch-source::src::tools.h
@@ -0,0 +1,19 @@
+--- source/src/tools.h.orig Wed Sep 22 16:54:56 2004
++++ source/src/tools.h Wed Sep 22 17:00:21 2004
+@@ -136,6 +136,8 @@
+ void allocnext(int allocsize);
+ };
+
++pool *gp();
++
+ template <class T> struct vector
+ {
+ T *buf;
+@@ -259,7 +261,6 @@
+
+ #define enumerate(ht,t,e,b) loopi(ht->size) for(ht->enumc = ht->table[i]; ht->enumc; ht->enumc = ht->enumc->next) { t e = &ht->enumc->data; b; }
+
+-pool *gp();
+ inline char *newstring(char *s) { return gp()->string(s); };
+ inline char *newstring(char *s, int l) { return gp()->string(s, l); };
+ inline char *newstringbuf(char *s) { return gp()->stringbuf(s); };