aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-08-31 19:48:47 +0800
committergarga <garga@FreeBSD.org>2005-08-31 19:48:47 +0800
commit62f2e17a46762b48a3d1627107adbf0de0053be8 (patch)
tree7c6b654526a24f38697d615ea39f6c5ee159bb51 /games
parent69d39cd6bae6d1001a4b6b2e8b24143a46f93b62 (diff)
downloadfreebsd-ports-gnome-62f2e17a46762b48a3d1627107adbf0de0053be8.tar.gz
freebsd-ports-gnome-62f2e17a46762b48a3d1627107adbf0de0053be8.tar.zst
freebsd-ports-gnome-62f2e17a46762b48a3d1627107adbf0de0053be8.zip
Add p5-Games-Sequential 0.4.3, sequential games framework with OO
interface. PR: ports/84164 Submitted by: Aaron Dalton <aaron@daltons.ca>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/p5-Games-Sequential/Makefile31
-rw-r--r--games/p5-Games-Sequential/distinfo2
-rw-r--r--games/p5-Games-Sequential/pkg-descr17
-rw-r--r--games/p5-Games-Sequential/pkg-plist7
5 files changed, 58 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e5c8e88fc02e..5aa1f111c047 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -378,6 +378,7 @@
SUBDIR += p5-Games-Bingo-Bot
SUBDIR += p5-Games-Bingo-Print
SUBDIR += p5-Games-Dice
+ SUBDIR += p5-Games-Sequential
SUBDIR += pathological
SUBDIR += pcgen
SUBDIR += pengpong
diff --git a/games/p5-Games-Sequential/Makefile b/games/p5-Games-Sequential/Makefile
new file mode 100644
index 000000000000..eb060d38dcb3
--- /dev/null
+++ b/games/p5-Games-Sequential/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Games-Sequential
+# Date created: 27 July 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Sequential
+PORTVERSION= 0.4.3
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Sequential games framework with OO interface
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Games::Sequential.3 Games::Sequential::Position.3
+
+.include <bsd.port.pre.mk>
+
+.if (${PERL_LEVEL} < 500601)
+BROKEN= "Perl 5.6.1 or above is required"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/p5-Games-Sequential/distinfo b/games/p5-Games-Sequential/distinfo
new file mode 100644
index 000000000000..59cfe369f5f5
--- /dev/null
+++ b/games/p5-Games-Sequential/distinfo
@@ -0,0 +1,2 @@
+MD5 (Games-Sequential-0.4.3.tar.gz) = 38694a375220f8275721806f4ca40a30
+SIZE (Games-Sequential-0.4.3.tar.gz) = 5908
diff --git a/games/p5-Games-Sequential/pkg-descr b/games/p5-Games-Sequential/pkg-descr
new file mode 100644
index 000000000000..95a2735e501b
--- /dev/null
+++ b/games/p5-Games-Sequential/pkg-descr
@@ -0,0 +1,17 @@
+Games::Sequential is a framework for producing sequential games. Among
+other things it keeps track of the sequence of moves, and provides an
+unlimited undo() mechanism. It also has methods to clone() or take a
+snapshot() of a game.
+
+Users must pass an object representing the initial state of the game as the
+first argument to new(). This object must provide the two methods copy()
+and apply(). You can use Games::Sequential::Position as a base class, in
+which case the copy() method will be provided for you. The apply() method
+must take a move and apply it to the current position, producing the next
+position in the game.
+
+WWW: http://search.cpan.org/dist/Games-Sequential
+Author: Stig Brautaset <stig@brautaset.org>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/games/p5-Games-Sequential/pkg-plist b/games/p5-Games-Sequential/pkg-plist
new file mode 100644
index 000000000000..488e596efbf1
--- /dev/null
+++ b/games/p5-Games-Sequential/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Games/Sequential.pm
+%%SITE_PERL%%/Games/Sequential/Position.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Sequential/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Sequential
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Games/Sequential
+@unexec rmdir %D/%%SITE_PERL%%/Games 2>/dev/null || true