aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-09-26 10:43:13 +0800
committerkris <kris@FreeBSD.org>2004-09-26 10:43:13 +0800
commit6424fd5192e6e888303ce266ccb6b88a31cd3003 (patch)
tree344dec9163299897e862e1053185162428fc0e36 /games
parentf0ffa4773cf009acee4354c9b5ae2066182c2d78 (diff)
downloadfreebsd-ports-gnome-6424fd5192e6e888303ce266ccb6b88a31cd3003.tar.gz
freebsd-ports-gnome-6424fd5192e6e888303ce266ccb6b88a31cd3003.tar.zst
freebsd-ports-gnome-6424fd5192e6e888303ce266ccb6b88a31cd3003.zip
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
Diffstat (limited to 'games')
-rw-r--r--games/prboom/Makefile8
-rw-r--r--games/pykawari/Makefile5
2 files changed, 12 insertions, 1 deletions
diff --git a/games/prboom/Makefile b/games/prboom/Makefile
index 90c1d0c28e17..6fe6b562e171 100644
--- a/games/prboom/Makefile
+++ b/games/prboom/Makefile
@@ -26,6 +26,12 @@ CONFIGURE_ENV= CFLAGS+="-I${LOCALBASE}/include" \
MAN5= boom.cfg.5
MAN6= prboom.6 prboom-game-server.6
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/prboom
@@ -35,4 +41,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/boom.txt ${PREFIX}/share/doc/prboom
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/pykawari/Makefile b/games/pykawari/Makefile
index 8dd313a24502..2472944216af 100644
--- a/games/pykawari/Makefile
+++ b/games/pykawari/Makefile
@@ -38,6 +38,11 @@ WRKSRC= ${WRKDIR}/kawari-${PORTVERSION:S/.//g}
CFLAGS+= ${PTHREAD_CFLAGS} -fPIC
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 50126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} == "amd64"
CFLAGS+= -fPIC
.endif