aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2019-08-20 18:55:50 +0800
committermartymac <martymac@FreeBSD.org>2019-08-20 18:55:50 +0800
commit817fed8888616ae785563005121919afe779479a (patch)
tree598c7006740c6ed677f50b64c6a1516dd40a76ea /games
parent029b02b6094c4c537dda77608a0cb50d352e891c (diff)
downloadfreebsd-ports-gnome-817fed8888616ae785563005121919afe779479a.tar.gz
freebsd-ports-gnome-817fed8888616ae785563005121919afe779479a.tar.zst
freebsd-ports-gnome-817fed8888616ae785563005121919afe779479a.zip
devel/simgear: Use expat from ports instead of internal version
That prepares the port for the upcoming update of textproc/expat2. As a consequence, Simgear is now provided as a shared library (only). That commit chases dependencies to Simgear and fixes them for dependent ports [1]. PR: 239282 Submitted by: Sergei Vyshenski <svysh.fbsd@gmail.com> Approved by: portmgr blanket [1]
Diffstat (limited to 'games')
-rw-r--r--games/flightgear-terragear/Makefile7
-rw-r--r--games/flightgear/Makefile7
2 files changed, 6 insertions, 8 deletions
diff --git a/games/flightgear-terragear/Makefile b/games/flightgear-terragear/Makefile
index 5559501f3bc0..b1d9e9a6f4c8 100644
--- a/games/flightgear-terragear/Makefile
+++ b/games/flightgear-terragear/Makefile
@@ -2,7 +2,7 @@
PORTNAME= flightgear-terragear
PORTVERSION= 20171007
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games
MAINTAINER= mike.d.ft402@gmail.com
@@ -10,7 +10,6 @@ COMMENT= Tools for building scenery for the FlightGear project
LICENSE= GPLv2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
LIB_DEPENDS= libCGAL.so:math/cgal \
libgdal.so:graphics/gdal \
libmpfr.so:math/mpfr \
@@ -20,8 +19,8 @@ LIB_DEPENDS= libCGAL.so:math/cgal \
libboost_chrono.so:devel/boost-libs \
libboost_date_time.so:devel/boost-libs \
libboost_atomic.so:devel/boost-libs \
- libtiff.so:graphics/tiff
-RUN_DEPENDS= ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
+ libtiff.so:graphics/tiff \
+ libSimGearCore.so:devel/simgear
USES= cmake compiler:c++11-lang
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 9707566fe401..6f4b25c99840 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flightgear
PORTVERSION= 2018.3.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
@@ -20,12 +20,11 @@ LIB_DEPENDS= libpng.so:graphics/png \
libspeex.so:audio/speex \
libspeexdsp.so:audio/speexdsp \
libcurl.so:ftp/curl \
- libudev.so:devel/libudev-devd
+ libudev.so:devel/libudev-devd \
+ libSimGearCore.so:devel/simgear
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
- ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear \
${LOCALBASE}/include/linux/input.h:devel/evdev-proto
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
- ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear \
${LOCALBASE}/share/flightgear/version:games/flightgear-data
# Disable ninja, see https://sourceforge.net/p/flightgear/codetickets/2118/