aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-09-14 09:16:31 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-09-14 09:16:31 +0800
commit85da4219a1c6086061ba50b279f4249043d3c4a0 (patch)
treecced1a731e53297e1b134eff9d6a39270c7b55b7 /games
parent8c32b0811fa80bbc2b69ef9e4198914c559881a6 (diff)
downloadfreebsd-ports-gnome-85da4219a1c6086061ba50b279f4249043d3c4a0.tar.gz
freebsd-ports-gnome-85da4219a1c6086061ba50b279f4249043d3c4a0.tar.zst
freebsd-ports-gnome-85da4219a1c6086061ba50b279f4249043d3c4a0.zip
Fix build with clang/libc++
Diffstat (limited to 'games')
-rw-r--r--games/jag/Makefile1
-rw-r--r--games/jag/files/patch-Game.pro13
2 files changed, 14 insertions, 0 deletions
diff --git a/games/jag/Makefile b/games/jag/Makefile
index 76eaa8b1ccbf..35bd46207349 100644
--- a/games/jag/Makefile
+++ b/games/jag/Makefile
@@ -16,6 +16,7 @@ COMMENT= 2D arcade-puzzle game like KDiamonds
USE_ZIP= yes
USE_SDL= sdl mixer
+USE_DOS2UNIX= Game.pro
USE_QT4= qmake_build uic_build moc_build rcc_build \
corelib svg xml opengl network
diff --git a/games/jag/files/patch-Game.pro b/games/jag/files/patch-Game.pro
new file mode 100644
index 000000000000..02048db53a54
--- /dev/null
+++ b/games/jag/files/patch-Game.pro
@@ -0,0 +1,13 @@
+Uses X11 functions, but doesnt link with libX11
+--- Game.pro.orig 2013-09-14 02:35:13.963226272 +0400
++++ Game.pro 2013-09-14 02:36:05.820226581 +0400
+@@ -24,7 +24,8 @@
+ }
+ LIBS += -lSDLmain \
+ -lSDL \
+- -lSDL_mixer
++ -lSDL_mixer \
++ -lX11
+ TEMPLATE = app
+ SOURCES += main.cpp \
+ gamewidget.cpp \