aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-12-25 20:58:59 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-12-25 20:58:59 +0800
commit930a614ef8a3a5676e3338761b81f9942a02376d (patch)
tree79a125069865449a97a40075cea4574a9e006bdd /games
parentc5f504acccdaa090d9bffd3e67dd43f3811f1ddd (diff)
downloadfreebsd-ports-gnome-930a614ef8a3a5676e3338761b81f9942a02376d.tar.gz
freebsd-ports-gnome-930a614ef8a3a5676e3338761b81f9942a02376d.tar.zst
freebsd-ports-gnome-930a614ef8a3a5676e3338761b81f9942a02376d.zip
- Resurrect games/jumpnbump, update to 1.60
Diffstat (limited to 'games')
-rw-r--r--games/jumpnbump/Makefile41
-rw-r--r--games/jumpnbump/distinfo3
-rw-r--r--games/jumpnbump/files/patch-menu_Makefile15
-rw-r--r--games/jumpnbump/files/patch-menu_po_Makefile12
-rw-r--r--games/jumpnbump/pkg-descr13
-rw-r--r--games/jumpnbump/pkg-plist13
6 files changed, 97 insertions, 0 deletions
diff --git a/games/jumpnbump/Makefile b/games/jumpnbump/Makefile
new file mode 100644
index 000000000000..a39834552299
--- /dev/null
+++ b/games/jumpnbump/Makefile
@@ -0,0 +1,41 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jumpnbump
+PORTVERSION= 1.60
+CATEGORIES= games
+MASTER_SITES= https://gitlab.com/LibreGames/jumpnbump/repository/${PORTVERSION}/archive.tar.bz2?dummy=/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Play cute bunnies jumping on each other's heads
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gettext gmake shebangfix tar:bzip2
+SHEBANG_FILES= ${WRKSRC}/menu/jumpnbump_menu.py.pre
+USE_SDL= sdl2 mixer2 net2
+
+WRKSRC= ${WRKDIR}/${DISTNAME}-3b37e6f8951419bfce4601cda0ed500622d5bedf
+PORTDOCS= AUTHORS ChangeLog README.md
+
+OPTIONS_DEFINE= LAUNCHER DOCS NLS
+OPTIONS_DEFAULT=LAUNCHER
+OPTIONS_SUB= yes
+
+LAUNCHER_DESC= Install pygtk launcher
+LAUNCHER_USES= python:2.7,run
+LAUNCHER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>0:x11-toolkits/py-gtk2@${PY_FLAVOR}
+
+post-install:
+.for f in jnbpack gobpack jnbunpack jumpnbump
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
+.endfor
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/jumpnbump/distinfo b/games/jumpnbump/distinfo
new file mode 100644
index 000000000000..b86aa50ec782
--- /dev/null
+++ b/games/jumpnbump/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513863624
+SHA256 (jumpnbump-1.60.tar.bz2) = b156d1ecd35fd02281f55787ebf1c33e74adcaea2773a3450bf2554120774a2c
+SIZE (jumpnbump-1.60.tar.bz2) = 377991
diff --git a/games/jumpnbump/files/patch-menu_Makefile b/games/jumpnbump/files/patch-menu_Makefile
new file mode 100644
index 000000000000..2ff760373f2c
--- /dev/null
+++ b/games/jumpnbump/files/patch-menu_Makefile
@@ -0,0 +1,15 @@
+--- menu/Makefile.orig 2017-05-24 18:01:25 UTC
++++ menu/Makefile
+@@ -20,8 +20,10 @@ clean:
+ $(MAKE) -C po clean
+
+ install:
+- install -D -m 644 jumpnbump_menu.glade $(DESTDIR)$(GAMEDATADIR)/jumpnbump/jumpnbump_menu.glade
+- install -D -m 755 jumpnbump_menu.py $(DESTDIR)$(BINDIR)/jumpnbump-menu
++ install -d $(DESTDIR)$(GAMEDATADIR)/jumpnbump/
++ install -m 644 jumpnbump_menu.glade $(DESTDIR)$(GAMEDATADIR)/jumpnbump/jumpnbump_menu.glade
++ install -d $(DESTDIR)$(BINDIR)
++ install -m 755 jumpnbump_menu.py $(DESTDIR)$(BINDIR)/jumpnbump-menu
+
+ $(MAKE) -C po install
+
diff --git a/games/jumpnbump/files/patch-menu_po_Makefile b/games/jumpnbump/files/patch-menu_po_Makefile
new file mode 100644
index 000000000000..e0a432ca67de
--- /dev/null
+++ b/games/jumpnbump/files/patch-menu_po_Makefile
@@ -0,0 +1,12 @@
+--- menu/po/Makefile.orig 2017-05-24 18:01:25 UTC
++++ menu/po/Makefile
+@@ -12,7 +12,8 @@ clean:
+
+ install:
+ for lang in $(LANGS) ; do \
+- install -D -m 0644 $$lang.mo $(DESTDIR)$(DATADIR)/locale/$$lang/LC_MESSAGES/jumpnbump-menu.mo ; \
++ install -d $(DESTDIR)$(DATADIR)/locale/$$lang/LC_MESSAGES ; \
++ install -m 0644 $$lang.mo $(DESTDIR)$(DATADIR)/locale/$$lang/LC_MESSAGES/jumpnbump-menu.mo ; \
+ done
+
+ uninstall:
diff --git a/games/jumpnbump/pkg-descr b/games/jumpnbump/pkg-descr
new file mode 100644
index 000000000000..1cda349eb7d4
--- /dev/null
+++ b/games/jumpnbump/pkg-descr
@@ -0,0 +1,13 @@
+This is a game for the whole family. You play cute fluffy little
+bunnies and hop on each other's heads.
+
+At the beginning you are in the menu, where you have to let each
+active player jump over the tree trunk to enter the play area, and
+then walk to the right. You will then enter the arena. The aim is
+to jump on the other bunnies' heads...
+
+Jump 'n Bump was originally a DOS game by Brainchild Design, which
+was open sourced under the GPL license and ported to SDL, and then
+SDL2.
+
+WWW: https://gitlab.com/LibreGames/jumpnbump
diff --git a/games/jumpnbump/pkg-plist b/games/jumpnbump/pkg-plist
new file mode 100644
index 000000000000..34b7f8ef8fe1
--- /dev/null
+++ b/games/jumpnbump/pkg-plist
@@ -0,0 +1,13 @@
+bin/gobpack
+bin/jnbpack
+bin/jnbunpack
+bin/jumpnbump
+%%LAUNCHER%%bin/jumpnbump-menu
+share/appdata/jumpnbump.appdata.xml
+%%LAUNCHER%%share/applications/jumpnbump-menu.desktop
+share/applications/jumpnbump.desktop
+share/icons/jumpnbump.png
+%%DATADIR%%/jumpbump.dat
+%%LAUNCHER%%%%DATADIR%%/jumpnbump_menu.glade
+%%NLS%%share/locale/fr/LC_MESSAGES/jumpnbump-menu.mo
+share/man/man6/jumpnbump.6