aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-12-24 12:37:06 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-12-24 12:37:06 +0800
commit97ebf64e563ccc83f30fd77e20746b81510314ab (patch)
treeb07a537a43fee287934b7245669f80257a23b6a0 /games
parenta7d44cc713e72808039928f7408051b319ebfa11 (diff)
downloadfreebsd-ports-gnome-97ebf64e563ccc83f30fd77e20746b81510314ab.tar.gz
freebsd-ports-gnome-97ebf64e563ccc83f30fd77e20746b81510314ab.tar.zst
freebsd-ports-gnome-97ebf64e563ccc83f30fd77e20746b81510314ab.zip
Fix compiliation errors
PORTDOCS support was already added by someone else PR: 33128 Submitted by: tkato@prontomail.com
Diffstat (limited to 'games')
-rw-r--r--games/gltron/Makefile23
-rw-r--r--games/gltron/files/patch-ad6
2 files changed, 14 insertions, 15 deletions
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index 7347063ab035..e5c48861b83c 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -23,27 +23,26 @@ SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
USE_MESA= yes
-GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= X11BASE="${X11BASE}" \
- LOCALBASE="${LOCALBASE}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}" \
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
SDL_CONFIG="${SDL_CONFIG}"
-pre-build:
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lXext ${PTHREAD_LIBS}
+
+post-patch:
${PERL} -pi -e "s+#include <SDL\/+#include <+g" ${WRKSRC}/*.[ch]
do-install:
- @${MKDIR} ${PREFIX}/share/gltron
- (cd ${WRKSRC} && ${TAR} -c -f - art data sounds) \
- | (cd ${PREFIX}/share/gltron && ${TAR} --unlink -x -f -)
${INSTALL_PROGRAM} ${WRKSRC}/gltron ${PREFIX}/bin
-
-post-install:
+ @${MKDIR} ${DATADIR}
+ ${TAR} -C ${WRKSRC} -cf - art data sounds | \
+ ${TAR} -C ${DATADIR} --unlink -xf -
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/gltron
+ @${MKDIR} ${DOCSDIR}
.for file in CHANGELOG CREDITS README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gltron
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/games/gltron/files/patch-ad b/games/gltron/files/patch-ad
index 725c0c90fec6..2d5a41a186a8 100644
--- a/games/gltron/files/patch-ad
+++ b/games/gltron/files/patch-ad
@@ -8,7 +8,7 @@ $FreeBSD$
-LIBS='-L/usr/X11R6/lib'
-+LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
++LIBS="$LIBS $LDFLAGS"
# Extract the first word of "gcc", so it can be a program name with args.
set dummy gcc; ac_word=$2
@@ -17,7 +17,7 @@ $FreeBSD$
-CFLAGS=""
-+CFLAGS="$CFLAGS -I${X11BASE}/include -I${LOCALBASE}/include"
++CFLAGS="$CFLAGS $CPPFLAGS"
# Check whether --enable-warn or --disable-warn was given.
if test "${enable_warn+set}" = set; then
@@ -26,7 +26,7 @@ $FreeBSD$
if test "x$enable_optimize" ; then
- CFLAGS="$CFLAGS -O$enable_optimize"
-+# CFLAGS="$CFLAGS -O$enable_optimize"
++ CFLAGS="$CFLAGS"
fi
# Check whether --enable-network or --disable-network was given.