aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-01 12:52:01 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-01 12:52:01 +0800
commita6988e3f945a97f5ca6795128e66b3f30a85f1f2 (patch)
tree2f0a7c80584dce7c9539d0c92f2cda83a3280c1e /games
parentc8c99a6e833ce9d2887a64918d8d3bbf615b29ad (diff)
downloadfreebsd-ports-gnome-a6988e3f945a97f5ca6795128e66b3f30a85f1f2.tar.gz
freebsd-ports-gnome-a6988e3f945a97f5ca6795128e66b3f30a85f1f2.tar.zst
freebsd-ports-gnome-a6988e3f945a97f5ca6795128e66b3f30a85f1f2.zip
- Make kobodeluxe compile with gcc41.
- Take maintainership. PR: ports/103857 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games')
-rw-r--r--games/kobodeluxe/Makefile2
-rw-r--r--games/kobodeluxe/files/patch-gamestate.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/kobodeluxe/Makefile b/games/kobodeluxe/Makefile
index 46cccd994b80..5e2289a06d0c 100644
--- a/games/kobodeluxe/Makefile
+++ b/games/kobodeluxe/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= games
MASTER_SITES= http://olofson.net/kobodl/download/
DISTNAME= KoboDeluxe-${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@mail.ru
COMMENT= An SDL port of the scrolling game XKobo
USE_SDL= image sdl
diff --git a/games/kobodeluxe/files/patch-gamestate.h b/games/kobodeluxe/files/patch-gamestate.h
new file mode 100644
index 000000000000..37957db29d2a
--- /dev/null
+++ b/games/kobodeluxe/files/patch-gamestate.h
@@ -0,0 +1,11 @@
+--- gamestate.h.orig Sun Apr 28 05:48:59 2002
++++ gamestate.h Sat Sep 30 23:58:17 2006
+@@ -24,6 +24,8 @@
+
+ #include "window.h"
+
++class gamestatemanager_t;
++
+ class gamestate_t
+ {
+ friend class gamestatemanager_t;