aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2012-12-05 04:09:16 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2012-12-05 04:09:16 +0800
commitaf3cf63ac28aab7d67abbfdbe2c6c87a033dc84d (patch)
treec4c77efb1f8ff33a569c9dc13853b5798a056b26 /games
parent4107cb5aed7a3416ffbd97b85a32655e2e8354f0 (diff)
downloadfreebsd-ports-gnome-af3cf63ac28aab7d67abbfdbe2c6c87a033dc84d.tar.gz
freebsd-ports-gnome-af3cf63ac28aab7d67abbfdbe2c6c87a033dc84d.tar.zst
freebsd-ports-gnome-af3cf63ac28aab7d67abbfdbe2c6c87a033dc84d.zip
- Fix build by adding forgotten patch
Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/widelands/Makefile1
-rw-r--r--games/widelands/files/patch-src-CMakeLists.txt14
2 files changed, 15 insertions, 0 deletions
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index e5f74c99c9ef..50d8cc4e5625 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -3,6 +3,7 @@
PORTNAME= widelands
DISTVERSION= build17
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= https://launchpadlibrarian.net/102893896/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/games/widelands/files/patch-src-CMakeLists.txt b/games/widelands/files/patch-src-CMakeLists.txt
new file mode 100644
index 000000000000..a3740f6e6bb0
--- /dev/null
+++ b/games/widelands/files/patch-src-CMakeLists.txt
@@ -0,0 +1,14 @@
+--- src/CMakeLists.txt.orig 2012-04-23 13:46:49.000000000 +0400
++++ src/CMakeLists.txt 2012-11-30 17:09:45.876932960 +0400
+@@ -134,9 +134,9 @@
+ target_link_libraries(widelands widelands_all)
+ target_link_libraries(widelands ${SDL_LIBRARY})
+
+-if (APPLE OR WIN32)
++if (APPLE OR WIN32 OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+ target_link_libraries(widelands_all ${INTL_LIBRARY})
+-endif (APPLE OR WIN32)
++endif (APPLE OR WIN32 OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+
+ if (WIN32)
+ if (DEFINED MSVC)