aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2002-04-06 17:23:07 +0800
committermarkp <markp@FreeBSD.org>2002-04-06 17:23:07 +0800
commitb8cd85a6b6ac171927df447cf3bfe8bb3b3fe0df (patch)
tree255d6997e8604bc0a69e0289e7b79dbc49399e06 /games
parent6274ac19e2c221d7f1e5b53ae3ed32a7b70d18ba (diff)
downloadfreebsd-ports-gnome-b8cd85a6b6ac171927df447cf3bfe8bb3b3fe0df.tar.gz
freebsd-ports-gnome-b8cd85a6b6ac171927df447cf3bfe8bb3b3fe0df.tar.zst
freebsd-ports-gnome-b8cd85a6b6ac171927df447cf3bfe8bb3b3fe0df.zip
Patch to use stdlib.h instead of malloc.h.
Diffstat (limited to 'games')
-rw-r--r--games/nighthawk/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/games/nighthawk/Makefile b/games/nighthawk/Makefile
index 846346ada954..4ba403e8227f 100644
--- a/games/nighthawk/Makefile
+++ b/games/nighthawk/Makefile
@@ -21,6 +21,11 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-scores=/var/games/nighthawk.scores --enable-sound
MAN6= nighthawk.6
+post-patch:
+ @${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/src/floor.cc \
+ ${WRKSRC}/src/ship.cc ${WRKSRC}/src_sound/nighthawk_sound.c \
+ ${WRKSRC}/src_sound/funkload.c ${WRKSRC}/src_sound/dsp_mixxer.c
+
post-install:
${CHOWN} root:games ${PREFIX}/bin/nighthawk
${CHMOD} g+s ${PREFIX}/bin/nighthawk