aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-06-23 16:38:08 +0800
committerwill <will@FreeBSD.org>2002-06-23 16:38:08 +0800
commitd93ee734ec16330ff5645b3613d13756b756b235 (patch)
tree4c62a591b222add7fba34da8f51bbc3c5ab96db0 /games
parent36ecfb760dd0507b536728fff04b20576c9c40a5 (diff)
downloadfreebsd-ports-gnome-d93ee734ec16330ff5645b3613d13756b756b235.tar.gz
freebsd-ports-gnome-d93ee734ec16330ff5645b3613d13756b756b235.tar.zst
freebsd-ports-gnome-d93ee734ec16330ff5645b3613d13756b756b235.zip
Add xrick 010808, a clone of Rick Dangerous.
PR: 37129 Submitted by: David Siebörger <drs@rucus.ru.ac.za>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/xrick/Makefile30
-rw-r--r--games/xrick/distinfo1
-rw-r--r--games/xrick/files/patch-config40
-rw-r--r--games/xrick/pkg-comment1
-rw-r--r--games/xrick/pkg-descr9
-rw-r--r--games/xrick/pkg-plist1
7 files changed, 83 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index fea51a4dc2cd..473203dda640 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -394,6 +394,7 @@
SUBDIR += xqf
SUBDIR += xquarto
SUBDIR += xracer
+ SUBDIR += xrick
SUBDIR += xripple
SUBDIR += xrisk
SUBDIR += xroach
diff --git a/games/xrick/Makefile b/games/xrick/Makefile
new file mode 100644
index 000000000000..3469416dd483
--- /dev/null
+++ b/games/xrick/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xrick
+# Date created: 15 March 2002
+# Whom: David Siebörger <drs@rucus.ru.ac.za>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xrick
+PORTVERSION= 010808
+CATEGORIES= games
+MASTER_SITES= http://www.bigorno.net/xrick/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= drs@rucus.ru.ac.za
+
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+WRKSRC= ${WRKDIR}/xrick
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= config
+USE_GMAKE= yes
+
+MAN6= xrick.6
+MANCOMPRESSED= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xrick ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xrick.6.gz ${PREFIX}/man/man6/xrick.6.gz
+
+.include <bsd.port.mk>
diff --git a/games/xrick/distinfo b/games/xrick/distinfo
new file mode 100644
index 000000000000..9bea3b290128
--- /dev/null
+++ b/games/xrick/distinfo
@@ -0,0 +1 @@
+MD5 (xrick-010808.tgz) = 0a25621afe66b5ef5733cea75f410d40
diff --git a/games/xrick/files/patch-config b/games/xrick/files/patch-config
new file mode 100644
index 000000000000..280ff41c0b36
--- /dev/null
+++ b/games/xrick/files/patch-config
@@ -0,0 +1,40 @@
+--- config.orig Mon Apr 15 22:08:26 2002
++++ config Mon Apr 15 22:33:35 2002
+@@ -46,31 +46,20 @@
+ CFLAGS="$CFLAGS -DVERSION=\\\"$VERSION\\\""
+
+ # SDL
+-SDLVER=`sdl-config --version 2>&1`
++SDLVER=`sdl11-config --version 2>&1`
+ if [ $? -ne 0 ]; then
+ echo "Error: SDL not found"
+ echo "Abort"
+ exit 1
+ else
+ echo "SDL version $SDLVER detected"
+- CFLAGS="$CFLAGS `sdl-config --cflags`"
+- LDFLAGS="$LDFLAGS `sdl-config --libs`"
++ CFLAGS="$CFLAGS `sdl11-config --cflags`"
++ LDFLAGS="$LDFLAGS `sdl11-config --libs`"
+ fi
+
+-POSDOT=`expr index $SDLVER '.'`
+-POSDOTp=`expr $POSDOT - 1`
+-POSDOTn=`expr $POSDOT + 1`
+-SDL_MAJ=`expr substr $SDLVER 1 $POSDOTp`
+-LEN=`expr length $SDLVER`
+-LEN=`expr $LEN - $POSDOT`
+-SDLVER=`expr substr $SDLVER $POSDOTn $LEN`
+-POSDOT=`expr index $SDLVER '.'`
+-POSDOTp=`expr $POSDOT - 1`
+-POSDOTn=`expr $POSDOT + 1`
+-SDL_MIN=`expr substr $SDLVER 1 $POSDOTp`
+-LEN=`expr length $SDLVER`
+-LEN=`expr $LEN - $POSDOT`
+-SDL_MIC=`expr substr $SDLVER $POSDOTn $LEN`
++SDL_MAJ=`echo $SDLVER | awk -F '.' '{print $1}'`
++SDL_MIN=`echo $SDLVER | awk -F '.' '{print $2}'`
++SDL_MIC=`echo $SDLVER | awk -F '.' '{print $3}'`
+
+ case "$TARGET" in
+ cygwin* | CYGWIN*)
diff --git a/games/xrick/pkg-comment b/games/xrick/pkg-comment
new file mode 100644
index 000000000000..7f089d8901eb
--- /dev/null
+++ b/games/xrick/pkg-comment
@@ -0,0 +1 @@
+A clone of Rick Dangerous
diff --git a/games/xrick/pkg-descr b/games/xrick/pkg-descr
new file mode 100644
index 000000000000..23d2fa0e2004
--- /dev/null
+++ b/games/xrick/pkg-descr
@@ -0,0 +1,9 @@
+Way before Lara Croft, back in the 1980's and early 1990's, Rick
+Dangerous was the Indiana Jones of computer games, running away from
+rolling rocks, avoiding traps, from South America to a futuristic
+missile base via Egypt and the Schwarzendumpf castle.
+
+xrick is a clone of Rick Dangerous. Written entirely in C, it relies on
+the Simple DirectMedia Layer library.
+
+WWW: http://www.bigorno.net/xrick/
diff --git a/games/xrick/pkg-plist b/games/xrick/pkg-plist
new file mode 100644
index 000000000000..707a71a5fbd3
--- /dev/null
+++ b/games/xrick/pkg-plist
@@ -0,0 +1 @@
+bin/xrick