aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2010-10-06 03:57:56 +0800
committerade <ade@FreeBSD.org>2010-10-06 03:57:56 +0800
commite74307c7a7b8d3cc36e4106d40fb9c6c9c76b973 (patch)
tree26fe74a7c2c257fcd8de12bb4ae7aa37e14cded4 /games
parentb30ffe50e036033f7a762ff34b0640d1797bc559 (diff)
downloadfreebsd-ports-gnome-e74307c7a7b8d3cc36e4106d40fb9c6c9c76b973.tar.gz
freebsd-ports-gnome-e74307c7a7b8d3cc36e4106d40fb9c6c9c76b973.tar.zst
freebsd-ports-gnome-e74307c7a7b8d3cc36e4106d40fb9c6c9c76b973.zip
Round one migration of ports from automake{19,110} to automake111
Diffstat (limited to 'games')
-rw-r--r--games/atr3d/Makefile2
-rw-r--r--games/cheech/Makefile2
-rw-r--r--games/critterding/Makefile2
-rw-r--r--games/d2x-xl/Makefile2
-rw-r--r--games/daimonin/Makefile2
-rw-r--r--games/flightgear-atlas/Makefile2
-rw-r--r--games/glest/Makefile2
-rw-r--r--games/gno3dtet/Makefile2
-rw-r--r--games/gnubg/Makefile2
-rw-r--r--games/kmastermind/Makefile3
-rw-r--r--games/lianliankan/Makefile2
-rw-r--r--games/mangos/Makefile2
-rw-r--r--games/naev/Makefile2
-rw-r--r--games/openalchemist/Makefile2
-rw-r--r--games/ri-li/Makefile4
-rw-r--r--games/ri-li/pkg-plist1
-rw-r--r--games/scorched3d/Makefile4
-rw-r--r--games/scourge/Makefile2
-rw-r--r--games/spacejunk/Makefile4
-rw-r--r--games/tecnoballz/Makefile2
-rw-r--r--games/ufoai/Makefile2
21 files changed, 25 insertions, 23 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 9434bdf249ee..09fa0f17d5ba 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -30,7 +30,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sound
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
SDL_CONFIG="${SDL_CONFIG}"
-USE_AUTOTOOLS= automake:19 autoconf:267
+USE_AUTOTOOLS= automake:111 autoconf:267
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/games/cheech/Makefile b/games/cheech/Makefile
index e149ea3df1b3..3f23d4d58c2e 100644
--- a/games/cheech/Makefile
+++ b/games/cheech/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:19:env
+USE_AUTOTOOLS= automake:111:env
DESKTOP_ENTRIES= "cheech" \
"A networked Chinese Checkers Game" \
diff --git a/games/critterding/Makefile b/games/critterding/Makefile
index 1fb553822b59..b69289a2bcb3 100644
--- a/games/critterding/Makefile
+++ b/games/critterding/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:267:env aclocal:110:env automake:110:env libtool:22
+USE_AUTOTOOLS= autoconf:267:env aclocal:111:env automake:111:env libtool:22
USE_SDL= sdl
USE_GL= gl
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
diff --git a/games/d2x-xl/Makefile b/games/d2x-xl/Makefile
index bf374de8168c..07f6d1ab491f 100644
--- a/games/d2x-xl/Makefile
+++ b/games/d2x-xl/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ARGS= --disable-debug --enable-release=yes \
--with-sharepath=${PREFIX}/share/d2x-xl
USE_SDL= sdl mixer image
USE_GMAKE= yes
-USE_AUTOTOOLS= aclocal:110 autoheader:267 automake:110 autoconf:267
+USE_AUTOTOOLS= aclocal:111 autoheader:267 automake:111 autoconf:267
USE_MOTIF= yes
MAKE_JOBS_SAFE= yes
AUTOMAKE_ARGS= --add-missing --copy
diff --git a/games/daimonin/Makefile b/games/daimonin/Makefile
index d89acbcd4745..d44ce403f0e6 100644
--- a/games/daimonin/Makefile
+++ b/games/daimonin/Makefile
@@ -23,7 +23,7 @@ FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX}
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --disable-simplelayout --enable-getaddrinfo
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-USE_AUTOTOOLS= automake:110 autoconf:267
+USE_AUTOTOOLS= automake:111 autoconf:267
USE_SDL= mixer image
SUB_FILES= daimonin.sh
SUB_LIST= PORTVERSION=${PORTVERSION}
diff --git a/games/flightgear-atlas/Makefile b/games/flightgear-atlas/Makefile
index a63b11055015..738ca2d2c727 100644
--- a/games/flightgear-atlas/Makefile
+++ b/games/flightgear-atlas/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/include/simgear/version.h:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/FlightGear/version:${PORTSDIR}/games/flightgear-data
-USE_AUTOTOOLS= aclocal:19 autoheader:267 automake:15 autoconf:267
+USE_AUTOTOOLS= aclocal:111 autoheader:267 automake:111 autoconf:267
AUTOMAKE_ARGS= --add-missing
GNU_CONFIGURE= yes
diff --git a/games/glest/Makefile b/games/glest/Makefile
index 61bd845263bf..588bcdc488f1 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
RUN_DEPENDS= ${DATADIR}/servers.ini:${PORTSDIR}/games/glest-data
-USE_AUTOTOOLS= automake:19:env autoconf:267:env
+USE_AUTOTOOLS= automake:111:env autoconf:267:env
USE_ZIP= yes
USE_OPENAL= al alut
USE_DOS2UNIX= yes
diff --git a/games/gno3dtet/Makefile b/games/gno3dtet/Makefile
index 60454af15028..a5506b1e264e 100644
--- a/games/gno3dtet/Makefile
+++ b/games/gno3dtet/Makefile
@@ -19,7 +19,7 @@ EXTRACT_DEPENDS=intltoolize:${PORTSDIR}/textproc/intltool
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui librsvg2
USE_GMAKE= yes
-USE_AUTOTOOLS= autoheader:267 automake:19 aclocal:19 autoconf:267
+USE_AUTOTOOLS= autoheader:267 automake:111 aclocal:111 autoconf:267
ACLOCAL_ARGS= -I m4 -I ${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= -a -c -f
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index cee3c27d71ce..583eb371699a 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -38,7 +38,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
USE_GNOME= gnomehack gnometarget libxml2
USE_GMAKE= yes
USE_PYTHON= 2.0+
-USE_AUTOTOOLS= libtool:22 automake:110
+USE_AUTOTOOLS= libtool:22 automake:111
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/games/kmastermind/Makefile b/games/kmastermind/Makefile
index 8ec86b207850..114287579083 100644
--- a/games/kmastermind/Makefile
+++ b/games/kmastermind/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11/kdelibs3:extract
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_AUTOTOOLS= automake:19:env autoconf:267:env libtool:22
+USE_AUTOTOOLS= automake:111:env autoconf:267:env libtool:22
USE_PERL5_BUILD= yes
USE_KDELIBS_VER= 3
USE_BZIP2= yes
@@ -30,6 +30,7 @@ pre-configure:
`cd ${PORTSDIR}/x11/kdelibs3 && ${MAKE} -V WRKSRC`/admin \
${WRKSRC}/admin
${TOUCH} ${WRKSRC}/NEWS
+ @${REINPLACE_CMD} -e 's|1.10|1.11|' ${WRKSRC}/admin/cvs.sh
cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} -f admin/Makefile.common cvs
.include <bsd.port.mk>
diff --git a/games/lianliankan/Makefile b/games/lianliankan/Makefile
index 36b35bfbede5..cc47eced7411 100644
--- a/games/lianliankan/Makefile
+++ b/games/lianliankan/Makefile
@@ -15,7 +15,7 @@ DISTNAME= llk_linux-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A scarce recreation game
-USE_AUTOTOOLS= automake:19:env
+USE_AUTOTOOLS= automake:111:env
USE_GNOME= gtk20 esound
USE_GETTEXT= yes
GNU_CONFIGURE= yes
diff --git a/games/mangos/Makefile b/games/mangos/Makefile
index 6b997bdd389c..d806118b3d2a 100644
--- a/games/mangos/Makefile
+++ b/games/mangos/Makefile
@@ -23,7 +23,7 @@ OPTIONS= SCRIPTDEV2 "ScriptDev2" on \
RA "Remote Administration support" off \
DBC "Install DBC files" on
-USE_AUTOTOOLS= aclocal:19 libtoolize autoconf:267 autoheader:267 automake:19 libtool:22
+USE_AUTOTOOLS= aclocal:111 libtoolize autoconf:267 autoheader:267 automake:111 libtool:22
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= -a
USE_MYSQL= yes
diff --git a/games/naev/Makefile b/games/naev/Makefile
index 1c00929af603..0896cb9b936b 100644
--- a/games/naev/Makefile
+++ b/games/naev/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/ndata-${PORTVERSION}:${PORTSDIR}/games/naev-data
-USE_AUTOTOOLS= automake:19:env aclocal:19:env autoconf:267:env
+USE_AUTOTOOLS= automake:111:env aclocal:111:env autoconf:267:env
USE_BZIP2= yes
USE_DOS2UNIX= conf.example
GNU_CONFIGURE= yes
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index 98c774962ed2..0fdfcfd1b00b 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png
-USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:267
+USE_AUTOTOOLS= aclocal:111 automake:111 autoconf:267
# Necessary to find pkg.m4 (PKG_CHECK_MODULES)
ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/ri-li/Makefile b/games/ri-li/Makefile
index 4d3948d9f0c8..cdcfd97f4a6a 100644
--- a/games/ri-li/Makefile
+++ b/games/ri-li/Makefile
@@ -7,14 +7,13 @@
PORTNAME= Ri-li
PORTVERSION= 2.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}%20Linux_Unix/${PORTNAME}%20V${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Drive a toy wood train in many levels - snake-like arcade game
-USE_AUTOTOOLS= automake:19
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -32,6 +31,7 @@ DESKTOP_ENTRIES="Ri-li" \
post-patch:
@${REINPLACE_CMD} -e 's|-lSDL |`${SDL_CONFIG} --libs`|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| gentoo||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/strcpy.*DefPath/ s|.*|strcpy(DefPath,"${DATADIR}/");|' ${WRKSRC}/src/main.cc
.include <bsd.port.mk>
diff --git a/games/ri-li/pkg-plist b/games/ri-li/pkg-plist
index 0f77d8bfc3e5..5178551f355b 100644
--- a/games/ri-li/pkg-plist
+++ b/games/ri-li/pkg-plist
@@ -1,6 +1,5 @@
bin/Ri_li
%%DATADIR%%/COPYING.Music
-%%DATADIR%%/Ri-li-2.0.1-r1.ebuild
%%DATADIR%%/Ri-li-icon-16x16.png
%%DATADIR%%/Ri-li-icon-32x32.png
%%DATADIR%%/Ri-li-icon-48x48.png
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 911fa964bef9..98257ade0543 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -32,7 +32,7 @@ USE_SDL= mixer net sdl
GNU_CONFIGURE= yes
USE_GL= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:19 autoconf:267
+USE_AUTOTOOLS= automake:111 autoconf:267
USE_PERL5= yes
USE_WX= 2.4+
WX_CONF_ARGS= absolute
@@ -61,6 +61,8 @@ post-patch:
pre-configure:
@cd ${WRKSRC}/scripts && ${PERL} createAMMakefile.pl
@cd ${WRKSRC} && ${ACLOCAL}
+ @${INSTALL_SCRIPT} ${AUTOCONF_DIR}/install-sh ${WRKSRC}
+# @${REINPLACE_CMD} -e 's/ $$//' ${WRKSRC}/install-sh
pre-install:
@${MKDIR} ${PREFIX}/games/scorched3d
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index 6497681fdf1e..8d0482d93924 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -19,7 +19,7 @@ COMMENT= S.C.O.U.R.G.E. is a rogue-like game
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${DATADIR}/config/scourge.cfg:${PORTSDIR}/games/scourge-data
-USE_AUTOTOOLS= autoconf:267:env automake:19:env
+USE_AUTOTOOLS= autoconf:267:env automake:111:env
USE_GL= gl
USE_SDL= sdl image mixer net ttf
USE_GMAKE= yes
diff --git a/games/spacejunk/Makefile b/games/spacejunk/Makefile
index dfc52287f0d4..310394c76640 100644
--- a/games/spacejunk/Makefile
+++ b/games/spacejunk/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A video game about traveling in 2D planetary systems
USE_SDL= sdl mixer image
-USE_AUTOTOOLS= automake:110
+USE_AUTOTOOLS= automake:111
AUTOMAKE_ARGS= -i --add-missing
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
@@ -45,7 +45,7 @@ post-patch:
${WRKSRC}/libinfo/gem-uta.c
@${REINPLACE_CMD} -e 's|data/|${DATADIR}/&|' ${WRKSRC}/src/*.c*
@${RM} -f ${WRKSRC}/config.guess
- @${REINPLACE_CMD} -e 's|1.10.1|1.10.3|' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|1.10.1|1.11.1|' ${WRKSRC}/aclocal.m4
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/spacejunk ${PREFIX}/libexec/
diff --git a/games/tecnoballz/Makefile b/games/tecnoballz/Makefile
index 5cffa473bbd2..7c1909017cbc 100644
--- a/games/tecnoballz/Makefile
+++ b/games/tecnoballz/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod \
ogg.7:${PORTSDIR}/audio/libogg \
smpeg.1:${PORTSDIR}/multimedia/smpeg
-USE_AUTOTOOLS= automake:19 aclocal:19
+USE_AUTOTOOLS= automake:111 aclocal:111
USE_SDL= sdl mixer image
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 00b7e9d717b9..cd62d2000e68 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
xvidcore.4:${PORTSDIR}/multimedia/xvid
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:${PORTSDIR}/games/ufoai-data
-USE_AUTOTOOLS= aclocal:110 autoconf:267
+USE_AUTOTOOLS= aclocal:111 autoconf:267
USE_BZIP2= yes
USE_GL= yes
USE_SDL= sdl image mixer ttf