aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /games
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'games')
-rw-r--r--games/alephone/Makefile12
-rw-r--r--games/battleball/Makefile12
-rw-r--r--games/clanbomber/Makefile12
-rw-r--r--games/criticalmass/Makefile12
-rw-r--r--games/nethack33/Makefile11
-rw-r--r--games/nethack34/Makefile11
-rw-r--r--games/nil/Makefile12
-rw-r--r--games/pipenightdreams/Makefile12
-rw-r--r--games/rtb/Makefile10
-rw-r--r--games/xdeblock/Makefile10
10 files changed, 58 insertions, 56 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index d25e4b4b24e5..7d0182652ece 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -18,18 +18,18 @@ COMMENT= The open source version of Bungie's Marathon game
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12:install \
SDL_image.10:${PORTSDIR}/graphics/sdl_image:install
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
@${PERL} -pi -e 's,^#include \"network_modem.h\".*,,' \
${WRKSRC}/Source_Files/Network/network.cpp \
diff --git a/games/battleball/Makefile b/games/battleball/Makefile
index 1adae103a101..e53db21910ff 100644
--- a/games/battleball/Makefile
+++ b/games/battleball/Makefile
@@ -15,18 +15,18 @@ DISTNAME= ${PORTNAME}.${PORTVERSION:S/.//}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D single/multiplayer military soccer game for X Window System
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_X_PREFIX= yes
USE_MESA= yes
WRKSRC= ${WRKDIR}/battleball-2.1-src
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/battleball ${PREFIX}/bin
diff --git a/games/clanbomber/Makefile b/games/clanbomber/Makefile
index 8d13e2c7bdb8..3362f06cc48e 100644
--- a/games/clanbomber/Makefile
+++ b/games/clanbomber/Makefile
@@ -16,16 +16,16 @@ COMMENT= A bomberman-like multiplayer game
LIB_DEPENDS= clanCore.0:${PORTSDIR}/devel/clanlib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
CFLAGS+= -fpermissive
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 64f7e74d2969..a672ae195158 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -19,12 +19,6 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
SDL_image.10:${PORTSDIR}/graphics/sdl_image \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -34,6 +28,12 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${X11BASE}/lib" \
SDLINCPFILES= utilities/GLBitmapCollection.cpp utilities/GLExtension.hpp \
utilities/GLTexture.hpp utilities/PNG.hpp
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's#sdl-config#sdl11-config#; s#-lSDL # #;' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's#SDL/#SDL11/#;' ${SDLINCPFILES:S#^#${WRKSRC}/#}
diff --git a/games/nethack33/Makefile b/games/nethack33/Makefile
index 363f74c3bbc0..2a4b2e21cf2d 100644
--- a/games/nethack33/Makefile
+++ b/games/nethack33/Makefile
@@ -27,8 +27,6 @@ MAKE_ENV= CXX="${CXX}" GRAPHICS="${GRAPHICS}"
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
-.include <bsd.port.pre.mk>
-
.if defined(WITH_GNOME_GRAPHICS)
CATEGORIES= games gnome
PKGNAMESUFFIX= -gnome
@@ -36,9 +34,6 @@ LIB_DEPENDS+= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_GNOME= yes
GRAPHICS= GNOME_GRAPHICS
.elif defined(WITH_QT_GRAPHICS)
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not build"
-.endif
PKGNAMESUFFIX= -qt
USE_QT_VER= 2
MAKE_ENV+= QTCPPFLAGS="${QTCPPFLAGS}" QTCFGLIBS="${QTCFGLIBS}" \
@@ -51,6 +46,12 @@ USE_XPM= yes
GRAPHICS= X11_GRAPHICS
.endif
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_QT_GRAPHICS) && ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
pre-everything::
.if defined(WITH_GNOME_GRAPHICS) || defined(WITH_QT_GRAPHICS) \
|| defined(WITH_TTY_GRAPHICS) || defined(WITHOUT_X11)
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index b1e4bc6f70bb..8d19ede9e6ca 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -33,8 +33,6 @@ HACKNAME?= nethack
HACKDIR?= lib/${HACKNAME}
HACKDOCSDIR?= share/doc/${HACKNAME}
-.include <bsd.port.pre.mk>
-
.if defined(WITH_GNOME_GRAPHICS)
CATEGORIES= games gnome
PKGNAMESUFFIX= -gnome
@@ -43,9 +41,6 @@ USE_GNOME= gnomelibs
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GRAPHICS= GNOME_GRAPHICS
.elif defined(WITH_QT_GRAPHICS)
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
PKGNAMESUFFIX= -qt
USE_QT_VER= 3
MAKE_ENV+= QTCPPFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
@@ -59,6 +54,12 @@ USE_XPM= yes
GRAPHICS= X11_GRAPHICS
.endif
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_QT_GRAPHICS) && ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-everything::
.if defined(WITH_GNOME_GRAPHICS) || defined(WITH_QT_GRAPHICS) \
|| defined(WITH_TTY_GRAPHICS) || defined(WITHOUT_X11)
diff --git a/games/nil/Makefile b/games/nil/Makefile
index 849a5f171d00..c61655d6e146 100644
--- a/games/nil/Makefile
+++ b/games/nil/Makefile
@@ -17,12 +17,6 @@ COMMENT= A multiplayer game that can be described as Quake in 2D or Worms done r
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTNAME}
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
@@ -31,6 +25,12 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
@find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
xargs ${PERL} -pi -e 's|"SDL/|"|g ; s|<SDL/|<|g'
diff --git a/games/pipenightdreams/Makefile b/games/pipenightdreams/Makefile
index e63c29405cc8..08d30978502b 100644
--- a/games/pipenightdreams/Makefile
+++ b/games/pipenightdreams/Makefile
@@ -15,12 +15,6 @@ COMMENT= A puzzle game similar to PipeMania
LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -30,6 +24,12 @@ USE_REINPLACE= yes
MAN6= pipenightdreams.6
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
${REINPLACE_CMD} 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g; \
s|SDL_LIBSS|SDL_LIBS|g; s|datadir/games|datadir|;' \
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 47bb4c0dde88..413d5c0e50e7 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -14,15 +14,15 @@ MASTER_SITES= http://www.lysator.liu.se/realtimebattle/Download/
MAINTAINER= draj@oceanfree.net
COMMENT= Robot programming game for UNIX
+USE_X_PREFIX= yes
+USE_GNOME= gtk12
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --enable-debug
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-USE_X_PREFIX= yes
-USE_GNOME= gtk12
-USE_LIBTOOL= yes
-CONFIGURE_ARGS= --enable-debug
-
.include <bsd.port.post.mk>
diff --git a/games/xdeblock/Makefile b/games/xdeblock/Makefile
index d354cb0fd143..67c278153094 100644
--- a/games/xdeblock/Makefile
+++ b/games/xdeblock/Makefile
@@ -14,17 +14,17 @@ DISTFILES= ${PORTNAME}.tgz
MAINTAINER= nakai@FreeBSD.org
COMMENT= Block action game
+WRKSRC= ${WRKDIR}/xdeblo_v1.0
+USE_IMAKE= yes
+USE_XPM= yes
+NO_INSTALL_MANPAGES= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-WRKSRC= ${WRKDIR}/xdeblo_v1.0
-USE_IMAKE= yes
-USE_XPM= yes
-NO_INSTALL_MANPAGES= yes
-
post-patch:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/main.c