aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-02 18:35:11 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-02 18:35:11 +0800
commit026d6e64ac46f39403cca1bb49320827f78ecd55 (patch)
tree7688ba85ad79352464ec64ac1d6bb0414f52ce7f /games
parent5be053a156510243431c7f2b7aa53f61adf79af5 (diff)
downloadfreebsd-ports-gnome-026d6e64ac46f39403cca1bb49320827f78ecd55.tar.gz
freebsd-ports-gnome-026d6e64ac46f39403cca1bb49320827f78ecd55.tar.zst
freebsd-ports-gnome-026d6e64ac46f39403cca1bb49320827f78ecd55.zip
Mark as broken with gcc4.2.
Diffstat (limited to 'games')
-rw-r--r--games/euchre/Makefile8
-rw-r--r--games/fuhquake/Makefile4
2 files changed, 11 insertions, 1 deletions
diff --git a/games/euchre/Makefile b/games/euchre/Makefile
index 710f7a626e48..83eb967c736c 100644
--- a/games/euchre/Makefile
+++ b/games/euchre/Makefile
@@ -19,4 +19,10 @@ PLIST_FILES= bin/euchre
USE_AUTOTOOLS= automake:14 autoconf:213
USE_GNOME= gtk12
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/fuhquake/Makefile b/games/fuhquake/Makefile
index 461eca70da62..dd4cd79cc301 100644
--- a/games/fuhquake/Makefile
+++ b/games/fuhquake/Makefile
@@ -39,6 +39,10 @@ MAKE_ENV= DATADIR="${DATADIR}"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
.if !defined(WITH_GLX) && !defined(WITH_X11)
IGNORE= needs at least one client (GLX or X11)
.endif