aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-17 16:58:05 +0800
committeredwin <edwin@FreeBSD.org>2004-12-17 16:58:05 +0800
commit0ce57ccab8058fd372e55fe4ebd3f8d282810f0c (patch)
tree5d87c62daae12a9086166b63cab1480e08808eb9 /games
parentd68116c677615ee3fe508bd98a10bf15fd4629f9 (diff)
downloadfreebsd-ports-gnome-0ce57ccab8058fd372e55fe4ebd3f8d282810f0c.tar.gz
freebsd-ports-gnome-0ce57ccab8058fd372e55fe4ebd3f8d282810f0c.tar.zst
freebsd-ports-gnome-0ce57ccab8058fd372e55fe4ebd3f8d282810f0c.zip
games/linux-q3ademo - libGL.so symbolic link needed
I believe a symbolic link to /compat/linux/usr/X11R6/lib/libGL.so.1 is needed in /usr/local/share/q3ademo Otherwise, quake will complain that it can not find the libGL.so. Perhaps /compat/linux/usr/X11R6/lib/ could also be added to the library path, but creating a link may be a simplier solution. PR: ports/74934 Submitted by: Yonas <yonas_@yahoo.com>
Diffstat (limited to 'games')
-rw-r--r--games/linux-q3ademo/Makefile13
-rw-r--r--games/linux-q3ademo/pkg-plist1
-rw-r--r--games/linux-quake3-demo/Makefile13
-rw-r--r--games/linux-quake3-demo/pkg-plist1
4 files changed, 16 insertions, 12 deletions
diff --git a/games/linux-q3ademo/Makefile b/games/linux-q3ademo/Makefile
index fe6974906428..b82ada239563 100644
--- a/games/linux-q3ademo/Makefile
+++ b/games/linux-q3ademo/Makefile
@@ -21,19 +21,19 @@ EXTRACT_SUFX=
MAINTAINER= ports@FreeBSD.org
COMMENT= Linux 3d shooter from id Software / Loki Software (demo version)
-RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+RUN_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+
+USE_X_PREFIX= yes
+USE_GL= yes
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-3
-RUN_DEPENDS += /compat/linux/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+RUN_DEPENDS += ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.else
-RUN_DEPENDS += /compat/linux/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
+RUN_DEPENDS += ${LINUXBASE}/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
.endif
-USE_X_PREFIX= yes
-USE_MESA= yes
-
# Linux binary should not be stripped by INSTALL_PROGRAM as it uses /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
STRIP=
@@ -319,6 +319,7 @@ do-install:
.endif
post-install:
+ ${LN} -fs ${LINUXBASE}/usr/X11R6/lib/libGL.so.1 ${PREFIX}/share/q3ademo/libGL.so
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/games/linux-q3ademo/pkg-plist b/games/linux-q3ademo/pkg-plist
index 872c95ee29a0..1ea881b6f820 100644
--- a/games/linux-q3ademo/pkg-plist
+++ b/games/linux-q3ademo/pkg-plist
@@ -4,6 +4,7 @@ share/q3ademo/icon.bmp
share/q3ademo/icon.xpm
share/q3ademo/q3ded
share/q3ademo/q3demo
+share/q3ademo/libGL.so
share/q3ademo/demoq3/pak0.pk3
share/q3ademo/Help/BotCommands.html
share/q3ademo/Help/DedicatedServer.html
diff --git a/games/linux-quake3-demo/Makefile b/games/linux-quake3-demo/Makefile
index fe6974906428..b82ada239563 100644
--- a/games/linux-quake3-demo/Makefile
+++ b/games/linux-quake3-demo/Makefile
@@ -21,19 +21,19 @@ EXTRACT_SUFX=
MAINTAINER= ports@FreeBSD.org
COMMENT= Linux 3d shooter from id Software / Loki Software (demo version)
-RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+RUN_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+
+USE_X_PREFIX= yes
+USE_GL= yes
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-3
-RUN_DEPENDS += /compat/linux/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+RUN_DEPENDS += ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.else
-RUN_DEPENDS += /compat/linux/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
+RUN_DEPENDS += ${LINUXBASE}/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
.endif
-USE_X_PREFIX= yes
-USE_MESA= yes
-
# Linux binary should not be stripped by INSTALL_PROGRAM as it uses /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
STRIP=
@@ -319,6 +319,7 @@ do-install:
.endif
post-install:
+ ${LN} -fs ${LINUXBASE}/usr/X11R6/lib/libGL.so.1 ${PREFIX}/share/q3ademo/libGL.so
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/games/linux-quake3-demo/pkg-plist b/games/linux-quake3-demo/pkg-plist
index 872c95ee29a0..1ea881b6f820 100644
--- a/games/linux-quake3-demo/pkg-plist
+++ b/games/linux-quake3-demo/pkg-plist
@@ -4,6 +4,7 @@ share/q3ademo/icon.bmp
share/q3ademo/icon.xpm
share/q3ademo/q3ded
share/q3ademo/q3demo
+share/q3ademo/libGL.so
share/q3ademo/demoq3/pak0.pk3
share/q3ademo/Help/BotCommands.html
share/q3ademo/Help/DedicatedServer.html